aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorzi <zi@FreeBSD.org>2012-05-27 23:30:36 +0800
committerzi <zi@FreeBSD.org>2012-05-27 23:30:36 +0800
commit7e1a31ab62edcddccc005616a1258463fc03d823 (patch)
tree0e118ebf8db911775c62a25794ff13e70c1ae785 /security
parentb0881fd88eac9668088764ac245bce80f7197c9d (diff)
downloadfreebsd-ports-gnome-7e1a31ab62edcddccc005616a1258463fc03d823.tar.gz
freebsd-ports-gnome-7e1a31ab62edcddccc005616a1258463fc03d823.tar.zst
freebsd-ports-gnome-7e1a31ab62edcddccc005616a1258463fc03d823.zip
- Update to 3.20
Diffstat (limited to 'security')
-rw-r--r--security/openconnect/Makefile10
-rw-r--r--security/openconnect/distinfo4
-rw-r--r--security/openconnect/files/patch-tun.c56
-rw-r--r--security/openconnect/pkg-message9
4 files changed, 5 insertions, 74 deletions
diff --git a/security/openconnect/Makefile b/security/openconnect/Makefile
index 4028c7e2ceec..20cff6a304ba 100644
--- a/security/openconnect/Makefile
+++ b/security/openconnect/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= openconnect
-PORTVERSION= 3.16
+PORTVERSION= 3.20
CATEGORIES= security
MASTER_SITES= ftp://ftp.infradead.org/pub/openconnect/ \
http://mirrors.rit.edu/zi/
@@ -18,10 +18,10 @@ LICENSE= LGPL21
LICENSE_FILE= ${WRKSRC}/COPYING.LGPL
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
+RUN_DEPENDS= vpnc-script:${PORTSDIR}/sysutils/vpnc-scripts
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-nls --with-openssl=/usr
-MAKE_ENV+= OPENSSL_CFLAGS=-I/usr/include
+CONFIGURE_ARGS= --disable-nls --with-vpnc-script=${LOCALBASE}/sbin/vpnc-script
USE_AUTOTOOLS= aclocal autoconf libtool
USE_GNOME= gnomehack pkgconfig
USE_GMAKE= yes
@@ -53,14 +53,10 @@ LIB_DEPENDS+= proxy.1:${PORTSDIR}/net/libproxy
post-patch:
@${REINPLACE_CMD} -e 's|libdir)/pkgconfig|prefix)/libdata/pkgconfig|' \
${WRKSRC}/Makefile.in ${WRKSRC}/Makefile.am
- @${REINPLACE_CMD} -e '/SUBDIRS += www/d' ${WRKSRC}/Makefile.am
- @${REINPLACE_CMD} -e 's|.{with_openssl}/libssl.a .{with_openssl}/libcrypto.a -ldl|-lssl -lcrypto|g' \
- ${WRKSRC}/configure.ac
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/openconnect.html ${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/TODO ${DOCSDIR}
.endif
diff --git a/security/openconnect/distinfo b/security/openconnect/distinfo
index 875a04286ab6..f8800e30f513 100644
--- a/security/openconnect/distinfo
+++ b/security/openconnect/distinfo
@@ -1,2 +1,2 @@
-SHA256 (openconnect-3.16.tar.gz) = 556c42b06c33e95db5fe1dc8a3b22f0fca1352c6fb0a432bd59d6178089597b6
-SIZE (openconnect-3.16.tar.gz) = 552359
+SHA256 (openconnect-3.20.tar.gz) = b92c5417fa0fd97899cafb79c930c285ec4ccde9e24550426536f93e4164e9fe
+SIZE (openconnect-3.20.tar.gz) = 576247
diff --git a/security/openconnect/files/patch-tun.c b/security/openconnect/files/patch-tun.c
deleted file mode 100644
index 53b489d2d697..000000000000
--- a/security/openconnect/files/patch-tun.c
+++ /dev/null
@@ -1,56 +0,0 @@
---- tun.c.orig 2011-11-24 08:18:34.000000000 -0800
-+++ tun.c 2012-03-12 22:46:30.000000000 -0700
-@@ -38,6 +38,9 @@
- #include <arpa/inet.h>
- #include <errno.h>
- #include <ctype.h>
-+#if defined(__FreeBSD__)
-+#include <sys/param.h> /* For __FreeBSD_version */
-+#endif
- #if defined(__sun__)
- #include <stropts.h>
- #include <sys/sockio.h>
-@@ -109,9 +112,43 @@
-
- addr.sin_family = AF_INET;
- addr.sin_addr.s_addr = inet_addr(vpninfo->vpn_addr);
-+
-+ /*
-+ * SIOCSIFADDR ioctl was dropped in FreeBSD 10.0
-+ */
-+#if defined(__FreeBSD__) && __FreeBSD_version > 1000004
-+ {
-+ struct ifaliasreq ifra;
-+ struct sockaddr_in *sin;
-+
-+ memset(&ifra, 0, sizeof(ifra));
-+ strncpy(ifra.ifra_name, vpninfo->ifname, sizeof(ifra.ifra_name) - 1);
-+
-+ /* Set source address. */
-+ sin = (struct sockaddr_in *)&(ifra.ifra_addr);
-+ memcpy(sin, &addr, sizeof(struct sockaddr_in));
-+ sin->sin_len = sizeof(*sin);
-+
-+ /* Set destination address. */
-+ sin = (struct sockaddr_in *)&(ifra.ifra_broadaddr);
-+ memcpy(sin, &addr, sizeof(struct sockaddr_in));
-+ sin->sin_len = sizeof(*sin);
-+
-+ /* Set mask address. */
-+ sin = (struct sockaddr_in *)&(ifra.ifra_mask);
-+ addr.sin_family = AF_INET;
-+ addr.sin_addr.s_addr = 0xffffffff;
-+ memcpy(sin, &addr, sizeof(struct sockaddr_in));
-+ sin->sin_len = sizeof(*sin);
-+
-+ if (ioctl(net_fd, SIOCAIFADDR, &ifra) < 0)
-+ perror(_("SIOCAIFADDR"));
-+ }
-+#else
- memcpy(&ifr.ifr_addr, &addr, sizeof(addr));
- if (ioctl(net_fd, SIOCSIFADDR, &ifr) < 0)
- perror(_("SIOCSIFADDR"));
-+#endif
- }
-
- ifr.ifr_mtu = vpninfo->mtu;
diff --git a/security/openconnect/pkg-message b/security/openconnect/pkg-message
deleted file mode 100644
index c2f831047d5b..000000000000
--- a/security/openconnect/pkg-message
+++ /dev/null
@@ -1,9 +0,0 @@
-Cisco's implementation of the DTLS protocol unfortunately does not
-comply with the relevant standards, and the OpenSSL in FreeBSD's
-base requires a patch to provide full interoperability. You will
-still be able to establish a tunnel, but all traffic will be
-transmitted via an HTTPS connection. This means that any packet
-loss on your link will result in a significant detriment to the
-speed of your VPN connection.
-
-More information is included in openconnect.html.