aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-17 00:45:35 +0800
committerbapt <bapt@FreeBSD.org>2013-09-17 00:45:35 +0800
commit8a97294176dc73b4561ed2402dc5453250075385 (patch)
tree62ec5ad5c85e69fd9755b85db994f8c7042a1fc0 /security
parentc2a9f33f2d93e1b5f33bb630e61a261db891265a (diff)
downloadfreebsd-ports-gnome-8a97294176dc73b4561ed2402dc5453250075385.tar.gz
freebsd-ports-gnome-8a97294176dc73b4561ed2402dc5453250075385.tar.zst
freebsd-ports-gnome-8a97294176dc73b4561ed2402dc5453250075385.zip
Convert to new perl framework
Convert USE_GMAKE to USES
Diffstat (limited to 'security')
-rw-r--r--security/fcheck/Makefile8
-rw-r--r--security/ftimes/Makefile2
-rw-r--r--security/gnomint/Makefile5
-rw-r--r--security/krb5-appl/Makefile4
-rw-r--r--security/lasso/Makefile2
-rw-r--r--security/openpgpsdk/Makefile16
-rw-r--r--security/openssl/Makefile13
-rw-r--r--security/vpnc/Makefile4
8 files changed, 19 insertions, 35 deletions
diff --git a/security/fcheck/Makefile b/security/fcheck/Makefile
index 636bdc718645..d1012488228c 100644
--- a/security/fcheck/Makefile
+++ b/security/fcheck/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: fcheck
-# Date created: 2008-01-31
-# Whom: Lars Engels <lme@FreeBSD.org>
-#
+# Created by: Lars Engels <lme@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= fcheck
PORTVERSION= 2.07.59
@@ -20,7 +16,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
PORTDOCS= *
PLIST_FILES= sbin/${PORTNAME} etc/${PORTNAME}.cfg.sample
NO_BUILD= YES
-USE_PERL5= YES
+USES= perl5
.include <bsd.port.pre.mk>
diff --git a/security/ftimes/Makefile b/security/ftimes/Makefile
index f89ab71e9dd8..26c14053cc41 100644
--- a/security/ftimes/Makefile
+++ b/security/ftimes/Makefile
@@ -14,7 +14,7 @@ LICENSE= BSD AL2 MIT
LICENSE_COMB= multi
GNU_CONFIGURE= yes
-USE_PERL5= yes
+USES= perl5
MAN1= ftimes.1
MAN3= FTimes::EadRoutines.3 FTimes::Properties.3
diff --git a/security/gnomint/Makefile b/security/gnomint/Makefile
index a281dc33f70d..632523beaa19 100644
--- a/security/gnomint/Makefile
+++ b/security/gnomint/Makefile
@@ -11,17 +11,14 @@ MAINTAINER= kevinz5000@gmail.com
COMMENT= X.509 Certification Authority management tool
LICENSE= GPLv3
-LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt \
gnutls:${PORTSDIR}/security/gnutls \
sqlite3:${PORTSDIR}/databases/sqlite3
GNU_CONFIGURE= yes
-USES= pkgconfig
-USE_GMAKE= yes
+USES= gmake perl5 pkgconfig
USE_GNOME= gconf2 gdkpixbuf2 glib20 gtk20
-USE_PERL5= yes
CFLAGS:= ${CFLAGS:C/-Werror//}
diff --git a/security/krb5-appl/Makefile b/security/krb5-appl/Makefile
index 82fff3925ab3..77052449f3e5 100644
--- a/security/krb5-appl/Makefile
+++ b/security/krb5-appl/Makefile
@@ -22,8 +22,8 @@ CONFLICTS= krb4-[0-9]* krb5-1.[0-7].* heimdal-[0-9]* srp-[0-9]*
LATEST_LINK= ${PORTNAME}-1
KERBEROSV_URL= http://web.mit.edu/kerberos/
USE_OPENSSL= yes
-USE_GMAKE= yes
-USE_PERL5_BUILD= yes
+USES= gmake perl5
+USE_PERL5= build
USE_LDCONFIG= yes
USE_CSTD= gnu89
USE_AUTOTOOLS= libtool autoheader autoconf
diff --git a/security/lasso/Makefile b/security/lasso/Makefile
index 7d04c7e2e4ef..143bd7c51b75 100644
--- a/security/lasso/Makefile
+++ b/security/lasso/Makefile
@@ -28,7 +28,7 @@ OPTIONS_DEFINE= PERL PHP PYTHON
.if !empty(PORT_OPTIONS:MPERL)
CONFIGURE_ARGS+= --enable-perl
PLIST_SUB+= WITH_PERL=""
-USE_PERL5= yes
+USES+= perl5
.else
CONFIGURE_ARGS+= --disable-perl
PLIST_SUB+= WITH_PERL="@comment "
diff --git a/security/openpgpsdk/Makefile b/security/openpgpsdk/Makefile
index 40bc914256d3..21049c57dd7d 100644
--- a/security/openpgpsdk/Makefile
+++ b/security/openpgpsdk/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: openpgpsdk
-# Date created: 2009-02-10
-# Whom: Martin Wilke <miwi@FreeBSD.org>
-#
+# Created by: Martin Wilke <miwi@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= openpgpsdk
PORTVERSION= 0.9
@@ -17,20 +13,14 @@ COMMENT= OpenPGP SDK
BUILD_DEPENDS= gpg2:${PORTSDIR}/security/gnupg
LIB_DEPENDS= cunit.1:${PORTSDIR}/devel/cunit
-USE_PERL5= yes
+USES= perl5
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --without-idea --with-cunit=${LOCALBASE}
PLIST_FILES= bin/openpgp lib/libops.a
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 700042
-BROKEN= does not build on 6.x.
-.endif
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/bin/openpgp ${PREFIX}/bin/
${INSTALL_DATA} ${WRKSRC}/lib/libops.a ${PREFIX}/lib/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index a2eaa1666195..5b89ac122505 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -48,12 +48,13 @@ MAKE_JOBS_UNSAFE= yes
NOPRECIOUSMAKEVARS= Too many _MLINKS for fetch
NOPRECIOUSSOFTMAKEVARS= Too many _MLINKS for fetch
-USE_PERL5_BUILD= yes
-MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
-MAKE_ENV+= LIBRPATH="${PREFIX}/lib"
-SUB_FILES= pkg-message
-OPENSSLDIR= ${PREFIX}/openssl
-MANPREFIX= ${PREFIX}
+USES= perl5
+USE_PERL5= build
+MAKE_ARGS+= WHOLE_ARCHIVE_FLAG=--whole-archive
+MAKE_ENV+= LIBRPATH="${PREFIX}/lib"
+SUB_FILES= pkg-message
+OPENSSLDIR= ${PREFIX}/openssl
+MANPREFIX= ${PREFIX}
MAN1= CA.pl.1 asn1parse.1 ca.1 ciphers.1 cms.1 crl.1 crl2pkcs7.1 dgst.1 \
dhparam.1 dsa.1 dsaparam.1 ec.1 ecparam.1 enc.1 errstr.1 gendsa.1 \
diff --git a/security/vpnc/Makefile b/security/vpnc/Makefile
index 79214ee4c9e4..5dcd3d84e63e 100644
--- a/security/vpnc/Makefile
+++ b/security/vpnc/Makefile
@@ -14,8 +14,8 @@ COMMENT= Client for Cisco 3000 VPN Concentrator
LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt
RUN_DEPENDS= vpnc-script:${PORTSDIR}/sysutils/vpnc-scripts
-USES= shebangfix gmake
-USE_PERL5_BUILD=yes
+USES= shebangfix gmake perl5
+USE_PERL5= build
USE_RC_SUBR= vpnc
ALL_TARGET= all