aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2018-05-28 05:11:37 +0800
committerantoine <antoine@FreeBSD.org>2018-05-28 05:11:37 +0800
commit8e66edc57e1def1ead4f0e17da279fda6cb418fa (patch)
tree8f990ac30d70bf24b49588befbcf36f3469f69b2 /security
parent7ba06d737b778cea06478982455bfb08d4a56917 (diff)
downloadfreebsd-ports-gnome-8e66edc57e1def1ead4f0e17da279fda6cb418fa.tar.gz
freebsd-ports-gnome-8e66edc57e1def1ead4f0e17da279fda6cb418fa.tar.zst
freebsd-ports-gnome-8e66edc57e1def1ead4f0e17da279fda6cb418fa.zip
Allow concurrent installation of py-artifacts
Diffstat (limited to 'security')
-rw-r--r--security/py-artifacts/Makefile6
-rw-r--r--security/py-plaso/Makefile3
2 files changed, 8 insertions, 1 deletions
diff --git a/security/py-artifacts/Makefile b/security/py-artifacts/Makefile
index 337d6b781ccb..ee153f6cca91 100644
--- a/security/py-artifacts/Makefile
+++ b/security/py-artifacts/Makefile
@@ -3,6 +3,7 @@
PORTNAME= artifacts
PORTVERSION= 20180505
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= CHEESESHOP \
https://github.com/ForensicArtifacts/artifacts/releases/download/${PORTVERSION}/
@@ -21,8 +22,11 @@ TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mock>=0:devel/py-mock@${FLAVOR} \
NO_ARCH= yes
USES= python
USE_LOCALE= en_US.UTF-8
-USE_PYTHON= distutils autoplist
+USE_PYTHON= distutils autoplist concurrent
DO_MAKE_TEST= ${SETENV} ${TEST_ENV} ${PYTHON_CMD}
TEST_TARGET= run_tests.py
+post-patch:
+ ${REINPLACE_CMD} "s,share/artifacts,${DATADIR_REL}," ${WRKSRC}/setup.py
+
.include <bsd.port.mk>
diff --git a/security/py-plaso/Makefile b/security/py-plaso/Makefile
index 1128b7b951c3..47b6e92b13bb 100644
--- a/security/py-plaso/Makefile
+++ b/security/py-plaso/Makefile
@@ -3,6 +3,7 @@
PORTNAME= plaso
PORTVERSION= 20180524
+PORTREVISION= 1
CATEGORIES= security python
MASTER_SITES= https://github.com/log2timeline/plaso/releases/download/${PORTVERSION}/ \
LOCAL/antoine
@@ -66,6 +67,8 @@ TEST_DEPENDS+= ca_root_nss>=0:security/ca_root_nss
post-patch:
${REINPLACE_CMD} "s,'5.5.1',None," ${WRKSRC}/plaso/dependencies.py
${REINPLACE_CMD} "/maximum_version: 5.5.1/d" ${WRKSRC}/dependencies.ini
+ ${REINPLACE_CMD} "s|'share', 'artifacts'|'share', '${PYTHON_PKGNAMEPREFIX}artifacts'|" \
+ ${WRKSRC}/plaso/cli/helpers/artifact_definitions.py
do-test:
@${TOUCH} ${TEST_WRKSRC}/utils/__init__.py