aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpat <pat@FreeBSD.org>2002-03-31 09:00:39 +0800
committerpat <pat@FreeBSD.org>2002-03-31 09:00:39 +0800
commit92fe871663f86c9038c301b0e4f69acd950db744 (patch)
tree4c098135003fbbdb1e955282c83753c297b28716 /security
parent8ce18d2ea5fe0695cfee940e8a3bf588a9fb6b8a (diff)
downloadfreebsd-ports-gnome-92fe871663f86c9038c301b0e4f69acd950db744.tar.gz
freebsd-ports-gnome-92fe871663f86c9038c301b0e4f69acd950db744.tar.zst
freebsd-ports-gnome-92fe871663f86c9038c301b0e4f69acd950db744.zip
Add option for jumbo patch kit and pass maintainership to submitter
PR: 36514 Submitted by: ago <a.go@wish.net>
Diffstat (limited to 'security')
-rw-r--r--security/fwtk/Makefile23
-rw-r--r--security/fwtk/distinfo1
-rw-r--r--security/fwtk/pkg-plist1
3 files changed, 23 insertions, 2 deletions
diff --git a/security/fwtk/Makefile b/security/fwtk/Makefile
index 06d6bafe0bf6..196ed3fe88ea 100644
--- a/security/fwtk/Makefile
+++ b/security/fwtk/Makefile
@@ -13,7 +13,13 @@ DISTNAME= ${PORTNAME}${PORTVERSION}
EXTRACT_SUFX= .tar.Z
DISTFILES= fwtk2.1${EXTRACT_SUFX} fwtk-doc-only${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+.if defined(WITH_JUMBO_PATCH)
+PATCHFILES= trg-jumbo-20001114.diff
+PATCH_SITES= http://www.fwtk.org/fwtk/patches/
+PATCH_DIST_STRIP= -p1
+.endif
+
+MAINTAINER= a.go@wish.net
RESTRICTED= "No form of redistribution is allowed"
@@ -40,7 +46,15 @@ MAN8+= x-gw.8
.if !exists(${DISTDIR}/fwtk2.1${EXTRACT_SUFX}) \
&& !exists(${DISTDIR}/fwtk-doc-only${EXTRACT_SUFX})
-IGNORE='Please read http://www.tis.com/research/software/fwtk_readme.html for details of how to obtain the FTWK source. Put the files fwtk2.1${EXTRACT_SUFX} and fwtk-doc-only${EXTRACT_SUFX} into the directory ${DISTDIR} and run make again.'
+IGNORE='Please read ftp://ftp.tislabs.com/pub/firewalls/toolkit/README for details of how to obtain the FTWK source. Put the files fwtk2.1${EXTRACT_SUFX} and fwtk-doc-only${EXTRACT_SUFX} into the directory ${DISTDIR} and run make again'
+.endif
+
+pre-patch:
+.if !defined(WITH_JUMBO_PATCH)
+ @${ECHO} "*****************************************************************************"
+ @${ECHO} "**** To enable the \"Jumbo\" patch kit, run 'make -DWITH_JUMBO_PATCH'"
+ @${ECHO} "**** For information about patches, read http://www.fwtk.org/fwtk/patches/"
+ @${ECHO} "*****************************************************************************"
.endif
pre-configure:
@@ -56,10 +70,15 @@ pre-configure:
post-install:
cd ${PREFIX}/libexec ; strip ${SBIN_BINS} ${LIBEXEC_BINS}
cd ${PREFIX}/libexec ; ${MV} ${SBIN_BINS} mqueue ../sbin
+ ${INSTALL_DATA} ${WRKSRC}/config/netperm-table \
+ ${PREFIX}/etc/netperm-table.sample
if [ ! -f ${PREFIX}/etc/netperm-table ]; then \
${INSTALL_DATA} ${WRKSRC}/config/netperm-table \
${PREFIX}/etc/netperm-table;\
fi
+.for file in ${LIBEXEC_BINS}
+ @${RM} -f ${PREFIX}/libexec/${file}.old
+.endfor
.for man in ${MAN3}
@${INSTALL_MAN} ${WRKSRC}/doc/man/${man} ${PREFIX}/man/man3
.endfor
diff --git a/security/fwtk/distinfo b/security/fwtk/distinfo
index 96e2c559aea3..d0b417d0e116 100644
--- a/security/fwtk/distinfo
+++ b/security/fwtk/distinfo
@@ -1,2 +1,3 @@
MD5 (fwtk2.1.tar.Z) = 936bf217fc271c54ef4b5ffca1e642db
MD5 (fwtk-doc-only.tar.Z) = 74ab67a3d224ba7ce0cfc2a39cb038cf
+MD5 (trg-jumbo-20001114.diff) = 32d8139ffc8826f451c4df80c5640d5a
diff --git a/security/fwtk/pkg-plist b/security/fwtk/pkg-plist
index 81876830d6a8..065cf81788d3 100644
--- a/security/fwtk/pkg-plist
+++ b/security/fwtk/pkg-plist
@@ -1,3 +1,4 @@
+@unexec if cmp -s %D/etc/netperm-table %D/etc/netperm-table.sample; then rm -f %D/etc/netperm-table; fi
etc/netperm-table.sample
libexec/authsrv
libexec/ftp-gw