aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2013-10-20 21:34:15 +0800
committerswills <swills@FreeBSD.org>2013-10-20 21:34:15 +0800
commit9ceeb79ea109720d505d91ecd3c72a163ec76583 (patch)
tree5d2caf4e84a7cb586c5958276b113c09f1afe7eb /security
parent37acd01c22f25015f802b72e4732dd3182f8991f (diff)
downloadfreebsd-ports-gnome-9ceeb79ea109720d505d91ecd3c72a163ec76583.tar.gz
freebsd-ports-gnome-9ceeb79ea109720d505d91ecd3c72a163ec76583.tar.zst
freebsd-ports-gnome-9ceeb79ea109720d505d91ecd3c72a163ec76583.zip
This module provides common interface to HMAC functionality. HMAC is a kind of
"Message Authentication Code" (MAC) algorithm whose standard is documented in RFC2104. Namely, a MAC provides a way to check the integrity of information transmitted over or stored in an unreliable medium, based on a secret key. Originally written by Daiki Ueno. Converted to a RubyGem by Geoffrey Grosenbach WWW: http://ruby-hmac.rubyforge.org/ PR: ports/182668 Submitted by: http://ruby-hmac.rubyforge.org/
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/rubygem-ruby-hmac/Makefile17
-rw-r--r--security/rubygem-ruby-hmac/distinfo2
-rw-r--r--security/rubygem-ruby-hmac/pkg-descr7
4 files changed, 27 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 9f21551cfad6..cdf365a3da1f 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -869,6 +869,7 @@
SUBDIR += rubygem-razorback-scriptNugget
SUBDIR += rubygem-rc4
SUBDIR += rubygem-roauth
+ SUBDIR += rubygem-ruby-hmac
SUBDIR += rubygem-twitter_oauth
SUBDIR += safesh
SUBDIR += saint
diff --git a/security/rubygem-ruby-hmac/Makefile b/security/rubygem-ruby-hmac/Makefile
new file mode 100644
index 000000000000..057807289b0e
--- /dev/null
+++ b/security/rubygem-ruby-hmac/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= ruby-hmac
+PORTVERSION= 0.4.0
+CATEGORIES= security rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Common interface to HMAC functionality
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+NO_STAGE= yes
+
+.include <bsd.port.mk>
diff --git a/security/rubygem-ruby-hmac/distinfo b/security/rubygem-ruby-hmac/distinfo
new file mode 100644
index 000000000000..511d212d0fe6
--- /dev/null
+++ b/security/rubygem-ruby-hmac/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/ruby-hmac-0.4.0.gem) = a4245ecf2cfb2036975b63dc37d41426727d8449617ff45daf0b3be402a9fe07
+SIZE (rubygem/ruby-hmac-0.4.0.gem) = 7168
diff --git a/security/rubygem-ruby-hmac/pkg-descr b/security/rubygem-ruby-hmac/pkg-descr
new file mode 100644
index 000000000000..e48d0fa25f22
--- /dev/null
+++ b/security/rubygem-ruby-hmac/pkg-descr
@@ -0,0 +1,7 @@
+This module provides common interface to HMAC functionality. HMAC is a kind of
+"Message Authentication Code" (MAC) algorithm whose standard is documented in
+RFC2104. Namely, a MAC provides a way to check the integrity of information
+transmitted over or stored in an unreliable medium, based on a secret key.
+Originally written by Daiki Ueno. Converted to a RubyGem by Geoffrey Grosenbach
+
+WWW: http://ruby-hmac.rubyforge.org/