aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2013-10-21 03:20:15 +0800
committerjhale <jhale@FreeBSD.org>2013-10-21 03:20:15 +0800
commitaa7ac53b1ea7dc9c006ee3d1ffbb8d1a9b94b2e3 (patch)
treefbc624ebebfbe7afce5736f025523e4649fa9967 /security
parentf6708d247696d714b56cc84a87c32288691d0dc1 (diff)
downloadfreebsd-ports-gnome-aa7ac53b1ea7dc9c006ee3d1ffbb8d1a9b94b2e3.tar.gz
freebsd-ports-gnome-aa7ac53b1ea7dc9c006ee3d1ffbb8d1a9b94b2e3.tar.zst
freebsd-ports-gnome-aa7ac53b1ea7dc9c006ee3d1ffbb8d1a9b94b2e3.zip
- Update security/gpgme to 1.4.3
- Use USE_GNOME= ltverhack to correct the library version number to what the author intended. This effectively rolls the version number backwards, but should prevent future unneccesary version bumps. - Support staging - Use options helpers - Use new LIB_DEPENDS syntax - Bump PORTREVISION on dependent ports
Diffstat (limited to 'security')
-rw-r--r--security/fwknop/Makefile1
-rw-r--r--security/gpa/Makefile1
-rw-r--r--security/gpgme/Makefile65
-rw-r--r--security/gpgme/distinfo8
-rw-r--r--security/gpgme/files/patch-src__engine-uiserver.c10
-rw-r--r--security/gpgme/pkg-plist4
-rw-r--r--security/openvas-libnasl/Makefile16
-rw-r--r--security/pecl-gnupg/Makefile3
-rw-r--r--security/py-pyme/Makefile4
-rw-r--r--security/ruby-gpgme/Makefile4
-rw-r--r--security/seahorse/Makefile2
11 files changed, 52 insertions, 66 deletions
diff --git a/security/fwknop/Makefile b/security/fwknop/Makefile
index 2529e75e60f8..011e7c9ccd52 100644
--- a/security/fwknop/Makefile
+++ b/security/fwknop/Makefile
@@ -3,6 +3,7 @@
PORTNAME= fwknop
PORTVERSION= 2.5.1
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://www.cipherdyne.org/fwknop/download/
diff --git a/security/gpa/Makefile b/security/gpa/Makefile
index 87dc1fc3318d..23f067ad63cd 100644
--- a/security/gpa/Makefile
+++ b/security/gpa/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gpa
PORTVERSION= 0.9.3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= gpa
diff --git a/security/gpgme/Makefile b/security/gpgme/Makefile
index 309c75977075..428e339198dd 100644
--- a/security/gpgme/Makefile
+++ b/security/gpgme/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gpgme
-PORTVERSION= 1.3.2
+PORTVERSION= 1.4.3
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_GNUPG}
MASTER_SITE_SUBDIR= gpgme
@@ -14,46 +14,45 @@ COMMENT= Library to make access to GnuPG easier
LICENSE= LGPL21
-LIB_DEPENDS= assuan.0:${PORTSDIR}/security/libassuan \
- gpg-error.0:${PORTSDIR}/security/libgpg-error
-
-OPTIONS_DEFINE= DOCS UISERVER
-OPTIONS_SINGLE= GNUPG
-OPTIONS_SINGLE_GNUPG= GNUPG1 GNUPG2
-OPTIONS_DEFAULT= GNUPG2
-
-GNUPG1_DESC= Build gpgme library for GnuPG 1.x
-GNUPG2_DESC= Build gpgme library for GnuPG 2.x
-UISERVER_DESC= GnuPG UI server support
+LIB_DEPENDS= libassuan.so:${PORTSDIR}/security/libassuan \
+ libgpg-error.so:${PORTSDIR}/security/libgpg-error
USE_BZIP2= yes
USE_AUTOTOOLS= libtool
-USE_GMAKE= yes
+USE_GNOME= ltverhack
+USES= gmake
USE_LDCONFIG= yes
CONFIGURE_ARGS= --includedir=${PREFIX}/include/gpgme \
--with-g13=no
INFO= gpgme
-PORTDOCS= AUTHORS ChangeLog COPYING COPYING.LESSER INSTALL \
- NEWS README THANKS TODO
+PORTDOCS= AUTHORS ChangeLog INSTALL NEWS README THANKS TODO
-NO_STAGE= yes
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= DOCS UISERVER
+OPTIONS_SINGLE= GNUPG
+OPTIONS_SINGLE_GNUPG= GNUPG1 GNUPG2
+OPTIONS_DEFAULT= GNUPG2 UISERVER
-.if ${PORT_OPTIONS:MGNUPG1}
-BUILD_DEPENDS+= gpgv:${PORTSDIR}/security/gnupg1
-RUN_DEPENDS+= gpgv:${PORTSDIR}/security/gnupg1
-CONFIGURE_ARGS+=--with-gpg=${LOCALBASE}/bin/gpg \
- --with-gpgsm=no \
- --with-gpgconf=no
-.endif
+GNUPG1_DESC= Build gpgme library for GnuPG 1.x
+GNUPG1_BUILD_DEPENDS= gpgv:${PORTSDIR}/security/gnupg1
+GNUPG1_RUN_DEPENDS= gpgv:${PORTSDIR}/security/gnupg1
+GNUPG1_CONFIGURE_ON= --with-gpg=${LOCALBASE}/bin/gpg \
+ --with-gpgconf=no \
+ --with-gpgsm=no
+
+GNUPG2_DESC= Build gpgme library for GnuPG 2.x
+GNUPG2_BUILD_DEPENDS= gpg2:${PORTSDIR}/security/gnupg
+GNUPG2_RUN_DEPENDS= gpg2:${PORTSDIR}/security/gnupg
+GNUPG2_CONFIGURE_ON= --with-gpg=${LOCALBASE}/bin/gpg2 \
+ --with-gpgconf=${LOCALBASE}/bin/gpgconf
+
+UISERVER_DESC= GnuPG UI server support
+UISERVER_CONFIGURE_ENABLE= fd-passing
+
+.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGNUPG2}
-BUILD_DEPENDS+= gpg2:${PORTSDIR}/security/gnupg
-RUN_DEPENDS+= gpg2:${PORTSDIR}/security/gnupg
-CONFIGURE_ARGS+=--with-gpg=${LOCALBASE}/bin/gpg2 \
- --with-gpgconf=${LOCALBASE}/bin/gpgconf
.if exists(${LOCALBASE}/bin/gpgsm)
CONFIGURE_ARGS+=--with-gpgsm=${LOCALBASE}/bin/gpgsm
.else
@@ -61,10 +60,6 @@ CONFIGURE_ARGS+=--with-gpgsm=no
.endif
.endif
-.if ${PORT_OPTIONS:MUISERVER}
-CONFIGURE_ARGS+=--enable-fd-passing
-.endif
-
verify: checksum
gpg --verify ${DISTDIR}/${DISTNAME}${EXTRACT_SUFX}.sig
@@ -78,9 +73,7 @@ post-patch:
${WRKSRC}/lang/cl/Makefile.in
post-install:
-.if ${PORT_OPTIONS:MDOCS}
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
-.endif
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/security/gpgme/distinfo b/security/gpgme/distinfo
index b4604b81a73b..4be0035fd9cb 100644
--- a/security/gpgme/distinfo
+++ b/security/gpgme/distinfo
@@ -1,4 +1,4 @@
-SHA256 (gpgme-1.3.2.tar.bz2) = cfd235663f1d1adc97abb38dd5e6d093bb7e155580f171f9ba0158feab69f875
-SIZE (gpgme-1.3.2.tar.bz2) = 867738
-SHA256 (gpgme-1.3.2.tar.bz2.sig) = 719b5899d07671b0ac17e7d88131ca11fd9a8ce504720ce4c789b67ba15bf2b2
-SIZE (gpgme-1.3.2.tar.bz2.sig) = 287
+SHA256 (gpgme-1.4.3.tar.bz2) = 2d1cc12411753752d9c5b9037e6fd3fd363517af720154768cc7b46b60120496
+SIZE (gpgme-1.4.3.tar.bz2) = 972497
+SHA256 (gpgme-1.4.3.tar.bz2.sig) = 5b8269678c1ec6a73ad56475f731c1247359167a921b1dc0ae3b1e8d38a9273c
+SIZE (gpgme-1.4.3.tar.bz2.sig) = 287
diff --git a/security/gpgme/files/patch-src__engine-uiserver.c b/security/gpgme/files/patch-src__engine-uiserver.c
deleted file mode 100644
index 69b18c1a2bf3..000000000000
--- a/security/gpgme/files/patch-src__engine-uiserver.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/engine-uiserver.c.orig 2012-05-03 20:50:11.000000000 -0400
-+++ ./src/engine-uiserver.c 2012-05-03 20:50:27.000000000 -0400
-@@ -49,7 +49,6 @@
- #include "data.h"
-
- #include "assuan.h"
--#include "status-table.h"
- #include "debug.h"
-
- #include "engine-backend.h"
diff --git a/security/gpgme/pkg-plist b/security/gpgme/pkg-plist
index 036252cddde9..f0623c6a78b8 100644
--- a/security/gpgme/pkg-plist
+++ b/security/gpgme/pkg-plist
@@ -6,11 +6,11 @@ lib/common-lisp/gpgme/gpgme.lisp
lib/libgpgme-pthread.a
lib/libgpgme-pthread.la
lib/libgpgme-pthread.so
-lib/libgpgme-pthread.so.19
+lib/libgpgme-pthread.so.11
lib/libgpgme.a
lib/libgpgme.la
lib/libgpgme.so
-lib/libgpgme.so.19
+lib/libgpgme.so.11
share/aclocal/gpgme.m4
@dirrm lib/common-lisp/gpgme
@dirrmtry lib/common-lisp
diff --git a/security/openvas-libnasl/Makefile b/security/openvas-libnasl/Makefile
index 30dff59a2b84..49f1ce883b2f 100644
--- a/security/openvas-libnasl/Makefile
+++ b/security/openvas-libnasl/Makefile
@@ -3,20 +3,20 @@
PORTNAME= openvas-libnasl
PORTVERSION= 2.0.1
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= security
MASTER_SITES= http://wald.intevation.org/frs/download.php/561/
MAINTAINER= ports@FreeBSD.org
COMMENT= NASL libraries for OpenVAS
-LIB_DEPENDS= gcrypt:${PORTSDIR}/security/libgcrypt \
- gnutls.26:${PORTSDIR}/security/gnutls \
- gpg-error.0:${PORTSDIR}/security/libgpg-error \
- gpgme.19:${PORTSDIR}/security/gpgme \
- openvas.2:${PORTSDIR}/security/openvas-libraries \
- openvas_hg.2:${PORTSDIR}/security/openvas-libraries \
- tasn1.5:${PORTSDIR}/security/libtasn1
+LIB_DEPENDS= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
+ libgnutls.so:${PORTSDIR}/security/gnutls \
+ libgpg-error.so:${PORTSDIR}/security/libgpg-error \
+ libgpgme.so:${PORTSDIR}/security/gpgme \
+ libopenvas.so.2:${PORTSDIR}/security/openvas-libraries \
+ libopenvas_hg.so.2:${PORTSDIR}/security/openvas-libraries \
+ libtasn1.so:${PORTSDIR}/security/libtasn1
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
diff --git a/security/pecl-gnupg/Makefile b/security/pecl-gnupg/Makefile
index d07940c51632..3b0618a80652 100644
--- a/security/pecl-gnupg/Makefile
+++ b/security/pecl-gnupg/Makefile
@@ -3,6 +3,7 @@
PORTNAME= gnupg
PORTVERSION= 1.3.3
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://pecl.php.net/get/
PKGNAMEPREFIX= pecl-
@@ -12,7 +13,7 @@ DIST_SUBDIR= PECL
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= PECL wrapper around the gpgme library
-LIB_DEPENDS= gpgme:${PORTSDIR}/security/gpgme
+LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme
CFLAGS+= -I${LOCALBASE}/include
CONFIGURE_ARGS= --with-gnupg=${LOCALBASE}/include/gpgme
diff --git a/security/py-pyme/Makefile b/security/py-pyme/Makefile
index ba40c6c7c5a1..ac907f96e4ac 100644
--- a/security/py-pyme/Makefile
+++ b/security/py-pyme/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pyme
PORTVERSION= 0.8.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security python
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -12,7 +12,7 @@ MAINTAINER= johans@FreeBSD.org
COMMENT= Python interface to GPGME library
BUILD_DEPENDS= swig1.3:${PORTSDIR}/devel/swig13
-LIB_DEPENDS= gpgme:${PORTSDIR}/security/gpgme
+LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme
USE_GMAKE= yes
USE_PYTHON= 2.5+
diff --git a/security/ruby-gpgme/Makefile b/security/ruby-gpgme/Makefile
index 20f62102c097..ad9a0dbf803d 100644
--- a/security/ruby-gpgme/Makefile
+++ b/security/ruby-gpgme/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gpgme
PORTVERSION= 1.0.8
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= security ruby
MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
MASTER_SITE_SUBDIR= ruby-gpgme
@@ -14,7 +14,7 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby interface to GnuPG Made Easy (GPGME)
-LIB_DEPENDS= gpgme.19:${PORTSDIR}/security/gpgme
+LIB_DEPENDS= libgpgme.so:${PORTSDIR}/security/gpgme
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/security/seahorse/Makefile b/security/seahorse/Makefile
index 9b2d3eb44a8d..73ea886dbd0b 100644
--- a/security/seahorse/Makefile
+++ b/security/seahorse/Makefile
@@ -4,7 +4,7 @@
PORTNAME= seahorse
PORTVERSION= 2.32.0
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= security gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2