aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorgirgen <girgen@FreeBSD.org>2013-07-29 22:49:11 +0800
committergirgen <girgen@FreeBSD.org>2013-07-29 22:49:11 +0800
commitaa8c3f531ae18cfed8195bb45485f4d084901c65 (patch)
treec3acb4c565593f40e4932465a813b642a1d443e9 /security
parent1fbc15da8caf5b6dab02ab14848106893a28450c (diff)
downloadfreebsd-ports-gnome-aa8c3f531ae18cfed8195bb45485f4d084901c65.tar.gz
freebsd-ports-gnome-aa8c3f531ae18cfed8195bb45485f4d084901c65.tar.zst
freebsd-ports-gnome-aa8c3f531ae18cfed8195bb45485f4d084901c65.zip
Move /var/cache/shibboleth to /var/db/shibboleth, since /var/cache has mode 750
and cannot be read by the www user. According to hier(7): db/ misc. automatically generated system-specific database files so /var/db seems like the best choice
Diffstat (limited to 'security')
-rw-r--r--security/shibboleth2-sp/Makefile6
-rw-r--r--security/shibboleth2-sp/files/patch-makefiles-docdir26
-rw-r--r--security/shibboleth2-sp/files/patch-shibboleth-spec17
-rw-r--r--security/shibboleth2-sp/files/patch-shibsp_base.h11
-rw-r--r--security/shibboleth2-sp/files/patch-shibsp_makefiles22
-rw-r--r--security/shibboleth2-sp/pkg-plist6
6 files changed, 68 insertions, 20 deletions
diff --git a/security/shibboleth2-sp/Makefile b/security/shibboleth2-sp/Makefile
index 0cd262121dfb..de9fd2ab5ea3 100644
--- a/security/shibboleth2-sp/Makefile
+++ b/security/shibboleth2-sp/Makefile
@@ -3,15 +3,15 @@
PORTNAME= shibboleth-sp
PORTVERSION= 2.5.2
+PORTREVISION= 1
CATEGORIES= security www
MASTER_SITES= http://shibboleth.net/downloads/service-provider/${PORTVERSION}/
MAINTAINER= girgen@FreeBSD.org
COMMENT= C++ Shibboleth Service Provider (Internet2) for Apache
-LIB_DEPENDS= saml.8:${PORTSDIR}/security/opensaml2
-
BUILD_DEPENDS= boost-libs>=0:${PORTSDIR}/devel/boost-libs
+LIB_DEPENDS= saml.8:${PORTSDIR}/security/opensaml2
MAKE_JOBS_SAFE= yes
USE_GMAKE= yes
@@ -53,7 +53,7 @@ CONFIGURE_ARGS+= --with-openssl=${OPENSSLBASE} --with-xmltooling=${LOCALBASE}
CONFIGURE_ARGS+= --disable-doxygen-doc
post-install:
- ${CHOWN} -R ${USERS}:${GROUPS} /var/cache/shibboleth ;\
+ ${CHOWN} -R ${USERS}:${GROUPS} /var/db/shibboleth ;\
${CHOWN} -R ${USERS}:${GROUPS} /var/log/shibboleth ;\
${CHOWN} -R ${USERS}:${WWWGRP} /var/run/shibboleth ;\
${CHMOD} -R u=rwx,g=rx,o= /var/run/shibboleth
diff --git a/security/shibboleth2-sp/files/patch-makefiles-docdir b/security/shibboleth2-sp/files/patch-makefiles-docdir
index aa62695f5a1d..7800802a03e4 100644
--- a/security/shibboleth2-sp/files/patch-makefiles-docdir
+++ b/security/shibboleth2-sp/files/patch-makefiles-docdir
@@ -1,5 +1,5 @@
--- doc/Makefile.am.orig 2012-07-23 22:08:29.000000000 +0200
-+++ doc/Makefile.am 2013-02-22 10:53:42.000000000 +0100
++++ doc/Makefile.am 2013-07-29 14:34:53.613422126 +0200
@@ -1,7 +1,7 @@
AUTOMAKE_OPTIONS = foreign
@@ -10,8 +10,8 @@
install-data-hook:
if test -d api ; then \
---- doc/Makefile.in.orig 2012-12-04 05:50:56.000000000 +0100
-+++ doc/Makefile.in 2013-02-22 10:53:42.000000000 +0100
+--- doc/Makefile.in.orig 2013-06-17 00:06:20.000000000 +0200
++++ doc/Makefile.in 2013-07-29 14:34:53.614421971 +0200
@@ -288,8 +288,8 @@
top_srcdir = @top_srcdir@
xs = @xs@
@@ -24,24 +24,30 @@
CREDITS.txt \
LICENSE.txt \
--- configs/Makefile.am.orig 2012-12-04 05:49:50.000000000 +0100
-+++ configs/Makefile.am 2013-02-22 10:53:42.000000000 +0100
-@@ -6,7 +6,7 @@
++++ configs/Makefile.am 2013-07-29 14:43:27.307424087 +0200
+@@ -6,9 +6,9 @@
pkglogdir = ${localstatedir}/log/@PACKAGE_NAME@
shirelogdir = ${localstatedir}/log/httpd
pkgxmldir = $(datadir)/xml/@PACKAGE_NAME@
-pkgwebdir = $(datadir)/@PACKAGE_NAME@
+pkgwebdir = $(datadir)/doc/@PACKAGE_NAME@
pkgrundir = $(localstatedir)/run/@PACKAGE_NAME@
- pkgcachedir = $(localstatedir)/cache/@PACKAGE_NAME@
+-pkgcachedir = $(localstatedir)/cache/@PACKAGE_NAME@
++pkgcachedir = $(localstatedir)/db/@PACKAGE_NAME@
pkgsysconfdir = $(sysconfdir)/@PACKAGE_NAME@
---- configs/Makefile.in.orig 2012-12-04 05:50:56.000000000 +0100
-+++ configs/Makefile.in 2013-02-22 10:53:42.000000000 +0100
-@@ -291,7 +291,7 @@
+ pkgsysconf_DATA = \
+ shibd-redhat \
+--- configs/Makefile.in.orig 2013-06-17 00:06:20.000000000 +0200
++++ configs/Makefile.in 2013-07-29 14:44:31.565419301 +0200
+@@ -291,9 +291,9 @@
pkglogdir = ${localstatedir}/log/@PACKAGE_NAME@
shirelogdir = ${localstatedir}/log/httpd
pkgxmldir = $(datadir)/xml/@PACKAGE_NAME@
-pkgwebdir = $(datadir)/@PACKAGE_NAME@
+pkgwebdir = $(datadir)/doc/@PACKAGE_NAME@
pkgrundir = $(localstatedir)/run/@PACKAGE_NAME@
- pkgcachedir = $(localstatedir)/cache/@PACKAGE_NAME@
+-pkgcachedir = $(localstatedir)/cache/@PACKAGE_NAME@
++pkgcachedir = $(localstatedir)/db/@PACKAGE_NAME@
pkgsysconfdir = $(sysconfdir)/@PACKAGE_NAME@
+ pkgsysconf_DATA = \
+ shibd-redhat \
diff --git a/security/shibboleth2-sp/files/patch-shibboleth-spec b/security/shibboleth2-sp/files/patch-shibboleth-spec
index 532bafccf508..3e621c4ffd61 100644
--- a/security/shibboleth2-sp/files/patch-shibboleth-spec
+++ b/security/shibboleth2-sp/files/patch-shibboleth-spec
@@ -1,6 +1,6 @@
---- shibboleth.spec.in.orig 2012-12-04 05:49:49.000000000 +0100
-+++ shibboleth.spec.in 2013-06-03 16:19:28.000000000 +0200
-@@ -58,7 +58,7 @@
+--- shibboleth.spec.in.orig 2013-06-16 21:43:47.000000000 +0200
++++ shibboleth.spec.in 2013-07-29 14:42:22.887422969 +0200
+@@ -59,7 +59,7 @@
%if "%{_vendor}" == "suse"
%define pkgdocdir %{_docdir}/shibboleth
%else
@@ -9,7 +9,7 @@
%endif
%description
-@@ -202,14 +202,6 @@
+@@ -203,14 +203,6 @@
/sbin/ldconfig
%endif
@@ -24,3 +24,12 @@
# Fix ownership of log files (even on new installs, if they're left from an older one).
%{__chown} %{runuser}:%{runuser} %{_localstatedir}/log/shibboleth/* 2>/dev/null || :
+@@ -304,7 +296,7 @@
+ %{_libdir}/shibboleth/*
+ %attr(0750,%{runuser},%{runuser}) %dir %{_localstatedir}/log/shibboleth
+ %attr(0755,%{runuser},%{runuser}) %dir %{_localstatedir}/run/shibboleth
+-%attr(0755,%{runuser},%{runuser}) %dir %{_localstatedir}/cache/shibboleth
++%attr(0755,%{runuser},%{runuser}) %dir %{_localstatedir}/db/shibboleth
+ %dir %{_datadir}/xml/shibboleth
+ %{_datadir}/xml/shibboleth/*
+ %dir %{_datadir}/shibboleth
diff --git a/security/shibboleth2-sp/files/patch-shibsp_base.h b/security/shibboleth2-sp/files/patch-shibsp_base.h
new file mode 100644
index 000000000000..54ff6f0db552
--- /dev/null
+++ b/security/shibboleth2-sp/files/patch-shibsp_base.h
@@ -0,0 +1,11 @@
+--- shibsp/base.h.orig 2013-07-29 14:46:37.905428862 +0200
++++ shibsp/base.h 2013-07-29 14:46:44.286416221 +0200
+@@ -127,7 +127,7 @@
+ #define SHIBSP_RUNDIR "var/run"
+
+ /** Cache directory for installation (used to resolve relative paths). */
+-#define SHIBSP_CACHEDIR "var/cache"
++#define SHIBSP_CACHEDIR "var/db"
+
+ /** XML directory for installation (used to resolve relative paths). */
+ #define SHIBSP_XMLDIR "share/xml"
diff --git a/security/shibboleth2-sp/files/patch-shibsp_makefiles b/security/shibboleth2-sp/files/patch-shibsp_makefiles
new file mode 100644
index 000000000000..49a8a9564fab
--- /dev/null
+++ b/security/shibboleth2-sp/files/patch-shibsp_makefiles
@@ -0,0 +1,22 @@
+--- shibsp/Makefile.am.orig 2013-07-29 16:01:08.000000000 +0200
++++ shibsp/Makefile.am 2013-07-29 16:01:19.000000000 +0200
+@@ -244,7 +244,7 @@
+ pkgxmldir = $(datadir)/xml/@PACKAGE_NAME@
+ logdir = ${localstatedir}/log
+ rundir = $(localstatedir)/run
+-cachedir = $(localstatedir)/cache
++cachedir = $(localstatedir)/db
+ xmldir = $(datadir)/xml
+
+ paths.h: ${srcdir}/paths.h.in Makefile ${top_builddir}/config.status
+--- shibsp/Makefile.in.orig 2013-07-29 16:01:08.000000000 +0200
++++ shibsp/Makefile.in 2013-07-29 16:01:29.000000000 +0200
+@@ -682,7 +682,7 @@
+ pkgxmldir = $(datadir)/xml/@PACKAGE_NAME@
+ logdir = ${localstatedir}/log
+ rundir = $(localstatedir)/run
+-cachedir = $(localstatedir)/cache
++cachedir = $(localstatedir)/db
+ xmldir = $(datadir)/xml
+ EXTRA_DIST = \
+ shibsp.vcxproj \
diff --git a/security/shibboleth2-sp/pkg-plist b/security/shibboleth2-sp/pkg-plist
index f6b908296aa7..85e34bfd4d58 100644
--- a/security/shibboleth2-sp/pkg-plist
+++ b/security/shibboleth2-sp/pkg-plist
@@ -166,14 +166,14 @@ share/doc/shibboleth/OPENSSL.LICENSE
share/doc/shibboleth/README.txt
share/doc/shibboleth/RELEASE.txt
share/doc/shibboleth/main.css
-@exec mkdir -p /var/cache/shibboleth
-@exec chown -R %%SHIBD_USER%%:%%SHIBD_GROUP%% /var/cache/shibboleth
+@exec mkdir -p /var/db/shibboleth
+@exec chown -R %%SHIBD_USER%%:%%SHIBD_GROUP%% /var/db/shibboleth
@exec mkdir -p /var/log/shibboleth
@exec chown -R %%SHIBD_USER%%:%%SHIBD_GROUP%% /var/log/shibboleth
@exec mkdir -p /var/run/shibboleth
@exec chown -R %%SHIBD_USER%%:%%WWWGRP%% /var/run/shibboleth
@exec chmod -R u=rwx,g=rx,o= /var/run/shibboleth
-@dirrmtry /var/cache/shibboleth
+@dirrmtry /var/db/shibboleth
@dirrmtry /var/run/shibboleth
@dirrmtry share/doc/shibboleth/api
@dirrmtry share/doc/shibboleth