aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorriggs <riggs@FreeBSD.org>2016-09-11 00:21:53 +0800
committerriggs <riggs@FreeBSD.org>2016-09-11 00:21:53 +0800
commitb7b2a96bd37cfec1b7a86902fa5711a37ee4d1bf (patch)
tree604ae053314da0e8a6f045d5dd15c07ddfcbd4e9 /security
parent5470468e2a89d52cfa0ada06add661450e5c6c26 (diff)
downloadfreebsd-ports-gnome-b7b2a96bd37cfec1b7a86902fa5711a37ee4d1bf.tar.gz
freebsd-ports-gnome-b7b2a96bd37cfec1b7a86902fa5711a37ee4d1bf.tar.zst
freebsd-ports-gnome-b7b2a96bd37cfec1b7a86902fa5711a37ee4d1bf.zip
Update to upstream version 0.3.0
Detailed maintainer log regarding breaking upstream changes: - The config filename has been changed from "config.sh" to "config" - The WELLKNOWN location has been changed upstream to "/var/www/letsencrypt" The port uses "%%PREFIX%%/www/letsencrypt" in accordance to hier(7). PR: 212485 Submitted by: sascha@root-login.org (maintainer)
Diffstat (limited to 'security')
-rw-r--r--security/letsencrypt.sh/Makefile31
-rw-r--r--security/letsencrypt.sh/distinfo6
-rw-r--r--security/letsencrypt.sh/files/000.letsencrypt.sh.in4
-rw-r--r--security/letsencrypt.sh/files/pkg-message.in8
4 files changed, 30 insertions, 19 deletions
diff --git a/security/letsencrypt.sh/Makefile b/security/letsencrypt.sh/Makefile
index 7513f37a9f1d..335ea1887b5d 100644
--- a/security/letsencrypt.sh/Makefile
+++ b/security/letsencrypt.sh/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= letsencrypt.sh
-PORTVERSION= 0.2.0
+PORTVERSION= 0.3.0
DISTVERSIONPREFIX= v
CATEGORIES= security
@@ -33,9 +33,10 @@ ZSH_RUN_DEPENDS= zsh:shells/zsh
PERIODIC_DIRS= etc/periodic/weekly
PERIODIC_FILES= 000.letsencrypt.sh
-PLIST_DIRS= %%ETCDIR%%/.acme-challenges
+PLIST_DIRS= %%ETCDIR%%/.acme-challenges \
+ www/letsencrypt
PLIST_FILES= bin/letsencrypt.sh \
- %%ETCDIR%%/config.sh.example \
+ %%ETCDIR%%/config.example \
%%ETCDIR%%/hook.sh.example \
%%ETCDIR%%/domains.txt.example \
${PERIODIC_DIRS}/000.letsencrypt.sh
@@ -44,28 +45,38 @@ PORTDOCS_PLIST_FILES= %%PORTDOCS%%%%DOCSDIR%%/README.md
SUB_FILES= 000.letsencrypt.sh pkg-message
SUB_LIST= PORTNAME=${PORTNAME}
PORTDOCS= README.md dns-verification.md domains_txt.md ecc.md hook_chain.md \
- import-from-official-client.md staging.md troubleshooting.md wellknown.md
+ import-from-official-client.md per-certificate-config.md staging.md \
+ troubleshooting.md wellknown.md
-SHEBANG_FILES= docs/examples/config.sh.example docs/examples/hook.sh.example letsencrypt.sh
+SHEBANG_FILES= docs/examples/hook.sh letsencrypt.sh
+
+post-patch:
+. for f in docs/examples/config letsencrypt.sh
+ ${REINPLACE_CMD} 's|/var/www/letsencrypt|${PREFIX}/www/letsencrypt|' \
+ ${WRKSRC}/${f}
+. endfor
post-patch-ZSH-on:
-. for p in docs/examples/config.sh.example docs/examples/hook.sh.example letsencrypt.sh
+. for p in docs/examples/config docs/examples/hook.sh letsencrypt.sh
${REINPLACE_CMD} '1 s/bash/zsh/' ${WRKSRC}/${p}
. endfor
do-install:
@${MKDIR} ${STAGEDIR}${ETCDIR}/.acme-challenges ${STAGEDIR}${PREFIX}/${PERIODIC_DIRS}
- ${INSTALL_DATA} ${WRKSRC}/docs/examples/config.sh.example ${STAGEDIR}${ETCDIR}/config.sh.example
- ${INSTALL_DATA} ${WRKSRC}/docs/examples/hook.sh.example ${STAGEDIR}${ETCDIR}/hook.sh.example
- ${INSTALL_DATA} ${WRKSRC}/docs/examples/domains.txt.example ${STAGEDIR}${ETCDIR}/domains.txt.example
+ ${INSTALL_DATA} ${WRKSRC}/docs/examples/config ${STAGEDIR}${ETCDIR}/config.example
+ ${INSTALL_DATA} ${WRKSRC}/docs/examples/hook.sh ${STAGEDIR}${ETCDIR}/hook.sh.example
+ ${INSTALL_DATA} ${WRKSRC}/docs/examples/domains.txt ${STAGEDIR}${ETCDIR}/domains.txt.example
${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
${INSTALL_SCRIPT} ${WRKDIR}/${PERIODIC_FILES} ${STAGEDIR}${PREFIX}/${PERIODIC_DIRS}/${PERIODIC_FILES}
${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_MAN} ${WRKSRC}/README.md ${STAGEDIR}${DOCSDIR}
. for d in dns-verification domains_txt ecc hook_chain import-from-official-client \
- staging troubleshooting wellknown
+ per-certificate-config staging troubleshooting wellknown
${INSTALL_MAN} ${WRKSRC}/docs/${d}.md ${STAGEDIR}${DOCSDIR}
. endfor
+post-stage:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/www/letsencrypt
+
.include <bsd.port.mk>
diff --git a/security/letsencrypt.sh/distinfo b/security/letsencrypt.sh/distinfo
index 45470c3f19c0..35e356dfb7c0 100644
--- a/security/letsencrypt.sh/distinfo
+++ b/security/letsencrypt.sh/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1463941305
-SHA256 (lukas2511-letsencrypt.sh-v0.2.0_GH0.tar.gz) = d6e25bbbfa14b87dea4999ecddfd441bbcdc1fd8b3160fa4c4a8ed412ee664e1
-SIZE (lukas2511-letsencrypt.sh-v0.2.0_GH0.tar.gz) = 19314
+TIMESTAMP = 1473333268
+SHA256 (lukas2511-letsencrypt.sh-v0.3.0_GH0.tar.gz) = c04ada782c93082e760c89122c9fdf68802c67c86a38b3fd5a83bb66dc0701d0
+SIZE (lukas2511-letsencrypt.sh-v0.3.0_GH0.tar.gz) = 21530
diff --git a/security/letsencrypt.sh/files/000.letsencrypt.sh.in b/security/letsencrypt.sh/files/000.letsencrypt.sh.in
index 4ad2b29c6796..f0c542837910 100644
--- a/security/letsencrypt.sh/files/000.letsencrypt.sh.in
+++ b/security/letsencrypt.sh/files/000.letsencrypt.sh.in
@@ -16,9 +16,9 @@ case "$weekly_letsencrypt_enable" in
if [ -z "$weekly_letsencrypt_user" ]
then
- %%PREFIX%%/bin/letsencrypt.sh -c
+ %%PREFIX%%/bin/letsencrypt.sh -c $weekly_letsencrypt_flags
else
- su -m "$weekly_letsencrypt_user" -c '%%PREFIX%%/bin/letsencrypt.sh -c'
+ su -m "$weekly_letsencrypt_user" -c "%%PREFIX%%/bin/letsencrypt.sh -c $daily_status_disks_df_flags"
fi
echo "Deploying Let's Encrypt certificates:"
diff --git a/security/letsencrypt.sh/files/pkg-message.in b/security/letsencrypt.sh/files/pkg-message.in
index f14cdcaadfc7..c888253524e1 100644
--- a/security/letsencrypt.sh/files/pkg-message.in
+++ b/security/letsencrypt.sh/files/pkg-message.in
@@ -3,10 +3,6 @@ To use this script you should copy the examples in
%%PREFIX%%/etc/%%PORTNAME%%/ and at least add a
domain and a contact mail address.
-You should also copy the openssl.cnf.sample file in
-%%PREFIX%%/openssl so you won't get warnings about
-it missing.
-
In order to run the script regularly to update
the certificates add this line to /etc/periodic.conf
@@ -17,6 +13,10 @@ Additionally the following parameters can be added to
To run the certification renenewal as a different user
weekly_letsencrypt_user="_letsencrypt"
+
To run a script after the renewal (as root)
weekly_letsencrypt_deployscript="%%PREFIX%%/etc/%%PORTNAME%%/deploy.sh"
+Additional flags for the periodic run go into
+weekly_letsencrypt_flags="-g"
+