aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2016-09-21 00:53:00 +0800
committerantoine <antoine@FreeBSD.org>2016-09-21 00:53:00 +0800
commitb9328acb2154b7ac7f7489e02d5bc3344761f5b2 (patch)
tree883feb0302b1e9b4b5b0c74d1d39170155f23e36 /security
parent36e04e8bdbfa4c80d10b7e69e643bdd43839c504 (diff)
downloadfreebsd-ports-gnome-b9328acb2154b7ac7f7489e02d5bc3344761f5b2.tar.gz
freebsd-ports-gnome-b9328acb2154b7ac7f7489e02d5bc3344761f5b2.tar.zst
freebsd-ports-gnome-b9328acb2154b7ac7f7489e02d5bc3344761f5b2.zip
New port: security/py-dfwinreg
dfWinReg, or Digital Forensics Windows Registry, is a Python module that provides read-only access to Windows Registry objects. WWW: https://github.com/log2timeline/dfwinreg
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-dfwinreg/Makefile28
-rw-r--r--security/py-dfwinreg/distinfo3
-rw-r--r--security/py-dfwinreg/pkg-descr4
4 files changed, 36 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 1e20f8fca17c..ba42a5ece46e 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -842,6 +842,7 @@
SUBDIR += py-cybox
SUBDIR += py-dfdatetime
SUBDIR += py-dfvfs
+ SUBDIR += py-dfwinreg
SUBDIR += py-ecdsa
SUBDIR += py-ed25519ll
SUBDIR += py-fail2ban
diff --git a/security/py-dfwinreg/Makefile b/security/py-dfwinreg/Makefile
new file mode 100644
index 000000000000..2a0d511a8437
--- /dev/null
+++ b/security/py-dfwinreg/Makefile
@@ -0,0 +1,28 @@
+# Created by: Antoine Brodin <antoine@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= dfwinreg
+PORTVERSION= 20160428
+CATEGORIES= security devel python
+MASTER_SITES= https://github.com/log2timeline/dfwinreg/releases/download/${PORTVERSION}/ \
+ CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= antoine@FreeBSD.org
+COMMENT= Digital Forensics Windows Registry
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+RUN_DEPENDS= libregf>=a:devel/libregf \
+ ${PYTHON_PKGNAMEPREFIX}construct>=0:devel/py-construct \
+ ${PYTHON_PKGNAMEPREFIX}dfdatetime>=0:security/py-dfdatetime
+
+NO_ARCH= yes
+USES= python
+USE_PYTHON= distutils autoplist
+
+do-test:
+ @(cd ${TEST_WRKSRC} && ${SETENV} ${TEST_ENV} ${PYTHON_CMD} run_tests.py)
+
+.include <bsd.port.mk>
diff --git a/security/py-dfwinreg/distinfo b/security/py-dfwinreg/distinfo
new file mode 100644
index 000000000000..d8b9a3fa02fa
--- /dev/null
+++ b/security/py-dfwinreg/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1474382638
+SHA256 (dfwinreg-20160428.tar.gz) = fb748e3e9fe20dba581bf6b12730635e990c7f3e43d26745be26002723ffcd58
+SIZE (dfwinreg-20160428.tar.gz) = 1214649
diff --git a/security/py-dfwinreg/pkg-descr b/security/py-dfwinreg/pkg-descr
new file mode 100644
index 000000000000..3a83c2c1f93d
--- /dev/null
+++ b/security/py-dfwinreg/pkg-descr
@@ -0,0 +1,4 @@
+dfWinReg, or Digital Forensics Windows Registry, is a Python module that
+provides read-only access to Windows Registry objects.
+
+WWW: https://github.com/log2timeline/dfwinreg