aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2006-09-07 10:19:12 +0800
committerkuriyama <kuriyama@FreeBSD.org>2006-09-07 10:19:12 +0800
commitc254f10176d7721df192baf1a4edb1f093f82ead (patch)
tree945a754b45fa272af477c3d3d7340694ceb5c303 /security
parent7a8a457c73622579d419f32759ef0068fa05c41c (diff)
downloadfreebsd-ports-gnome-c254f10176d7721df192baf1a4edb1f093f82ead.tar.gz
freebsd-ports-gnome-c254f10176d7721df192baf1a4edb1f093f82ead.tar.zst
freebsd-ports-gnome-c254f10176d7721df192baf1a4edb1f093f82ead.zip
- Fix WITH_LIBICONV to work correctly.
- Add WITH_USB to OPTIONS. PR: ports/101311 Submitted by: Helge Oldach <gnupgaug06@oldach.net>
Diffstat (limited to 'security')
-rw-r--r--security/gnupg/Makefile6
-rw-r--r--security/gnupg1/Makefile6
2 files changed, 10 insertions, 2 deletions
diff --git a/security/gnupg/Makefile b/security/gnupg/Makefile
index aced06b313a3..b636bca9684d 100644
--- a/security/gnupg/Makefile
+++ b/security/gnupg/Makefile
@@ -32,13 +32,16 @@ PORTDOCS= *
OPTIONS= LDAP "LDAP keyserver interface" off \
LIBICONV "use libiconv" off \
+ LIBUSB "use libusb" off \
SUID_GPG "install GPG with suid" off \
NLS "Native Language Support" on
.include <bsd.port.pre.mk>
-.if defined(WITH_LIBICONV) || exists(${PREFIX}/lib/libiconv.so)
+.if defined(WITH_LIBICONV)
USE_ICONV= yes
+.else
+CONFIGURE_ARGS+= --without-libiconv-prefix
.endif
.if defined(WITH_LIBUSB)
@@ -52,6 +55,7 @@ CONFIGURE_ARGS+= --without-libusb
USE_OPENLDAP= yes
PLIST_SUB+= WITH_LDAP=""
CONFIGURE_ARGS+= --with-ldap=${LOCALBASE}
+#CONFIGURE_ENV+= LDFLAGS="-L/usr/lib"
.else
PLIST_SUB+= WITH_LDAP="@comment "
CONFIGURE_ARGS+= --disable-ldap
diff --git a/security/gnupg1/Makefile b/security/gnupg1/Makefile
index aced06b313a3..b636bca9684d 100644
--- a/security/gnupg1/Makefile
+++ b/security/gnupg1/Makefile
@@ -32,13 +32,16 @@ PORTDOCS= *
OPTIONS= LDAP "LDAP keyserver interface" off \
LIBICONV "use libiconv" off \
+ LIBUSB "use libusb" off \
SUID_GPG "install GPG with suid" off \
NLS "Native Language Support" on
.include <bsd.port.pre.mk>
-.if defined(WITH_LIBICONV) || exists(${PREFIX}/lib/libiconv.so)
+.if defined(WITH_LIBICONV)
USE_ICONV= yes
+.else
+CONFIGURE_ARGS+= --without-libiconv-prefix
.endif
.if defined(WITH_LIBUSB)
@@ -52,6 +55,7 @@ CONFIGURE_ARGS+= --without-libusb
USE_OPENLDAP= yes
PLIST_SUB+= WITH_LDAP=""
CONFIGURE_ARGS+= --with-ldap=${LOCALBASE}
+#CONFIGURE_ENV+= LDFLAGS="-L/usr/lib"
.else
PLIST_SUB+= WITH_LDAP="@comment "
CONFIGURE_ARGS+= --disable-ldap