aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-05-09 09:22:07 +0800
committeredwin <edwin@FreeBSD.org>2003-05-09 09:22:07 +0800
commitc61930734fb77d26dc104af242d1ab5d1c282208 (patch)
tree38bcb0543292c79f234b8926561b125398881127 /security
parent7070422323156d7b3f06171bc44758ea786fe1ff (diff)
downloadfreebsd-ports-gnome-c61930734fb77d26dc104af242d1ab5d1c282208.tar.gz
freebsd-ports-gnome-c61930734fb77d26dc104af242d1ab5d1c282208.tar.zst
freebsd-ports-gnome-c61930734fb77d26dc104af242d1ab5d1c282208.zip
conditionalize dependencies on modules included in perl 5.8
Make dependencies on modules included in the perl 5.8 distribution conditional on the perl version installed. While I'm here, remove SITE_PERL and MAN(3)PREFIX. PR: ports/50589 Submitted by: Erwin Lansing <erwin@lansing.dk>
Diffstat (limited to 'security')
-rw-r--r--security/p5-Crypt-CBC/Makefile10
-rw-r--r--security/p5-Crypt-HCE_SHA/Makefile13
2 files changed, 15 insertions, 8 deletions
diff --git a/security/p5-Crypt-CBC/Makefile b/security/p5-Crypt-CBC/Makefile
index 89b660d66c90..1b90eca61278 100644
--- a/security/p5-Crypt-CBC/Makefile
+++ b/security/p5-Crypt-CBC/Makefile
@@ -15,12 +15,14 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl5 interface to Cipher Block Chaining with DES and IDEA
-RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
-
PERL_CONFIGURE= yes
MAN3= Crypt::CBC.3
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5
+.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/p5-Crypt-HCE_SHA/Makefile b/security/p5-Crypt-HCE_SHA/Makefile
index 7e7e31757ded..d77e4411f295 100644
--- a/security/p5-Crypt-HCE_SHA/Makefile
+++ b/security/p5-Crypt-HCE_SHA/Makefile
@@ -15,13 +15,18 @@ PKGNAMEPREFIX= p5-
MAINTAINER= ports@FreeBSD.org
COMMENT= Perl5 interface to one way hash chaining block cipher
-BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64 \
- ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Digest/SHA1.pm:${PORTSDIR}/security/p5-Digest-SHA1
RUN_DEPENDS= ${BUILD_DEPENDS}
PERL_CONFIGURE= yes
-MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
MAN3= Crypt::HCE_SHA.3
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500800
+BUILD_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+RUN_DEPENDS+= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/MIME/Base64.pm:${PORTSDIR}/converters/p5-MIME-Base64
+.endif
+
+.include <bsd.port.post.mk>