aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2014-03-14 17:04:57 +0800
committerehaupt <ehaupt@FreeBSD.org>2014-03-14 17:04:57 +0800
commitcc009617ac6857c8c6bf82a729f282e4bc3f9405 (patch)
treed7ce9da9d0023e192596fa5cc8454a132b62ed8f /security
parentc25020fe6b61a01e242be28aa48fe3cb931efdcb (diff)
downloadfreebsd-ports-gnome-cc009617ac6857c8c6bf82a729f282e4bc3f9405.tar.gz
freebsd-ports-gnome-cc009617ac6857c8c6bf82a729f282e4bc3f9405.tar.zst
freebsd-ports-gnome-cc009617ac6857c8c6bf82a729f282e4bc3f9405.zip
- Support staging
- Use shebangfix
Diffstat (limited to 'security')
-rw-r--r--security/ipfmeta/Makefile16
-rw-r--r--security/ipfmeta/pkg-plist7
2 files changed, 12 insertions, 11 deletions
diff --git a/security/ipfmeta/Makefile b/security/ipfmeta/Makefile
index 2d67fbdb7485..71f07a81b757 100644
--- a/security/ipfmeta/Makefile
+++ b/security/ipfmeta/Makefile
@@ -9,19 +9,19 @@ MASTER_SITES= http://www.sentia.org/downloads/
MAINTAINER= cy@FreeBSD.org
COMMENT= ipfmeta - use objects in IPfilter files
-USES= perl5
+USES= perl5 shebangfix
-MAN1= ipfmeta.1
POD2MAN?= pod2man
-NO_STAGE= yes
+SHEBANG_FILES= ipfmeta
+
do-build:
- @${POD2MAN} ${WRKSRC}/ipfmeta > ${WRKSRC}/${MAN1}
+ @${POD2MAN} ${WRKSRC}/ipfmeta > ${WRKSRC}/${PORTNAME}.1
do-install:
- ${INSTALL_MAN} ${WRKSRC}/${MAN1} ${MAN1PREFIX}/man/man1
- ${INSTALL_SCRIPT} ${WRKSRC}/ipfmeta ${PREFIX}/bin
- @${MKDIR} ${PREFIX}/share/ipfmeta
- ${INSTALL_DATA} ${WRKSRC}/ipf.* ${PREFIX}/share/ipfmeta
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_SCRIPT} ${WRKSRC}/ipfmeta ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/ipf.* ${STAGEDIR}${DATADIR}
.include <bsd.port.mk>
diff --git a/security/ipfmeta/pkg-plist b/security/ipfmeta/pkg-plist
index 57771d6c02bb..f67d7f9bf7b5 100644
--- a/security/ipfmeta/pkg-plist
+++ b/security/ipfmeta/pkg-plist
@@ -1,4 +1,5 @@
bin/ipfmeta
-share/ipfmeta/ipf.metarules
-share/ipfmeta/ipf.objs
-@dirrm share/ipfmeta
+man/man1/ipfmeta.1.gz
+%%DATADIR%%/ipf.metarules
+%%DATADIR%%/ipf.objs
+@dirrm %%DATADIR%%