aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-05-22 21:15:13 +0800
committermat <mat@FreeBSD.org>2018-05-22 21:15:13 +0800
commitcff6da1b7fcbd896785c044bbdfe462c9fb1a74c (patch)
treec832b87b776a5db072088687b910601d961726da /security
parent9304895709a6f8eba3df00bc5410b6f5dbe8382f (diff)
downloadfreebsd-ports-gnome-cff6da1b7fcbd896785c044bbdfe462c9fb1a74c.tar.gz
freebsd-ports-gnome-cff6da1b7fcbd896785c044bbdfe462c9fb1a74c.tar.zst
freebsd-ports-gnome-cff6da1b7fcbd896785c044bbdfe462c9fb1a74c.zip
Add PY_FLAVOR to Python module dependencies.
Sponsored by: Absolight
Diffstat (limited to 'security')
-rw-r--r--security/bro/Makefile4
-rw-r--r--security/revelation/Makefile2
-rw-r--r--security/sandsifter/Makefile2
3 files changed, 4 insertions, 4 deletions
diff --git a/security/bro/Makefile b/security/bro/Makefile
index d4056483c7a1..6d8ad61b760b 100644
--- a/security/bro/Makefile
+++ b/security/bro/Makefile
@@ -69,10 +69,10 @@ BROCTL_IMPLIES= BROCCOLI IPSUMDUMP
BROCCOLI_LIB_DEPENDS= libbroccoli.so:security/broccoli
BROCTL_BUILD_DEPENDS= ${LOCALBASE}/bin/bash:shells/bash \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3 \
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
swig3.0:devel/swig30
BROCTL_RUN_DEPENDS= ${LOCALBASE}/bin/bash:shells/bash \
- ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3
+ ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
BROCTL_CMAKE_BOOL= INSTALL_BROCTL
BROCTL_USE= LDCONFIG=yes
IPSUMDUMP_BUILD_DEPENDS=ipsumdump:net/ipsumdump
diff --git a/security/revelation/Makefile b/security/revelation/Makefile
index d6da5fe56ed4..7b741fdeb022 100644
--- a/security/revelation/Makefile
+++ b/security/revelation/Makefile
@@ -16,7 +16,7 @@ BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}dbus>0:devel/py-dbus@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}pycrypto>0:security/py-pycrypto@${PY_FLAVOR}
LIB_DEPENDS= libcrack.so:security/cracklib
RUN_DEPENDS:= ${BUILD_DEPENDS} \
- ${PYTHON_PKGNAMEPREFIX}cracklib>0:security/py-cracklib
+ ${PYTHON_PKGNAMEPREFIX}cracklib>0:security/py-cracklib@${PY_FLAVOR}
USES= desktop-file-utils gettext gmake pathfix pkgconfig python:2.7 \
shared-mime-info shebangfix tar:bzip2
diff --git a/security/sandsifter/Makefile b/security/sandsifter/Makefile
index 2ace1d711ce9..4b31adb7721a 100644
--- a/security/sandsifter/Makefile
+++ b/security/sandsifter/Makefile
@@ -14,7 +14,7 @@ ONLY_FOR_ARCHS= amd64 i386
ONLY_FOR_ARCHS_REASON=Designed for x86
BUILD_DEPENDS= ${LOCALBASE}/include/capstone/capstone.h:devel/capstone3
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}capstone>0:devel/py-capstone
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}capstone>0:devel/py-capstone@${PY_FLAVOR}
USES= gmake python localbase shebangfix