aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorerwin <erwin@FreeBSD.org>2006-07-14 23:45:24 +0800
committererwin <erwin@FreeBSD.org>2006-07-14 23:45:24 +0800
commitd15eeab0495341c1f7d06b6b7fff34e00f1897f3 (patch)
treea9f9159ecc9e9061fe20d5b1ae451e401ca13af2 /security
parentf86f069e5b6c85b36b2218c7b6a95f799b704d3f (diff)
downloadfreebsd-ports-gnome-d15eeab0495341c1f7d06b6b7fff34e00f1897f3.tar.gz
freebsd-ports-gnome-d15eeab0495341c1f7d06b6b7fff34e00f1897f3.tar.zst
freebsd-ports-gnome-d15eeab0495341c1f7d06b6b7fff34e00f1897f3.zip
This is a pure perl implementation of the new AES Rijndael. You want
to use Crypt::Rijndael where available. This implementation is really slow, but I am working on it. WWW: http://search.cpan.org/dist/Crypt-Rijndael_PP/ PR: ports/100262 Submitted by: Gea-Suan Lin <gslin at gslin.org>
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-Rijndael_PP/Makefile22
-rw-r--r--security/p5-Crypt-Rijndael_PP/distinfo3
-rw-r--r--security/p5-Crypt-Rijndael_PP/pkg-descr5
-rw-r--r--security/p5-Crypt-Rijndael_PP/pkg-plist7
5 files changed, 38 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index e243fa5825b4..e0def2a35aa2 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -368,6 +368,7 @@
SUBDIR += p5-Crypt-RandPasswd
SUBDIR += p5-Crypt-Random
SUBDIR += p5-Crypt-Rijndael
+ SUBDIR += p5-Crypt-Rijndael_PP
SUBDIR += p5-Crypt-SKey
SUBDIR += p5-Crypt-SSLeay
SUBDIR += p5-Crypt-Salt
diff --git a/security/p5-Crypt-Rijndael_PP/Makefile b/security/p5-Crypt-Rijndael_PP/Makefile
new file mode 100644
index 000000000000..47bf9901b455
--- /dev/null
+++ b/security/p5-Crypt-Rijndael_PP/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: p5-Crypt-Rijndael_PP
+# Date created: 2006-07-14
+# Whom: Gea-Suan Lin <gslin@gslin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-Rijndael_PP
+PORTVERSION= 0.04
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= gslin@gslin.org
+COMMENT= Perl implementation of Rijndael
+
+PERL_CONFIGURE= yes
+
+MAN3= Crypt::Rijndael_PP.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-Rijndael_PP/distinfo b/security/p5-Crypt-Rijndael_PP/distinfo
new file mode 100644
index 000000000000..ed318d86e0be
--- /dev/null
+++ b/security/p5-Crypt-Rijndael_PP/distinfo
@@ -0,0 +1,3 @@
+MD5 (Crypt-Rijndael_PP-0.04.tar.gz) = db8e06273eb49358ea2e7aa87dcdd319
+SHA256 (Crypt-Rijndael_PP-0.04.tar.gz) = c33c0d018622b6a171b3985c846751bbf9370df2bbeeb7014af6f3eb3490180e
+SIZE (Crypt-Rijndael_PP-0.04.tar.gz) = 31000
diff --git a/security/p5-Crypt-Rijndael_PP/pkg-descr b/security/p5-Crypt-Rijndael_PP/pkg-descr
new file mode 100644
index 000000000000..0315d03cc04e
--- /dev/null
+++ b/security/p5-Crypt-Rijndael_PP/pkg-descr
@@ -0,0 +1,5 @@
+This is a pure perl implementation of the new AES Rijndael. You want
+to use Crypt::Rijndael where available. This implementation is really
+slow, but I am working on it.
+
+WWW: http://search.cpan.org/dist/Crypt-Rijndael_PP/
diff --git a/security/p5-Crypt-Rijndael_PP/pkg-plist b/security/p5-Crypt-Rijndael_PP/pkg-plist
new file mode 100644
index 000000000000..2d13ce7348d2
--- /dev/null
+++ b/security/p5-Crypt-Rijndael_PP/pkg-plist
@@ -0,0 +1,7 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Rijndael_PP/.packlist
+%%SITE_PERL%%/Crypt/Rijndael_PP.pm
+%%SITE_PERL%%/Crypt/comp.pl
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt/Rijndael_PP
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Crypt
+@dirrmtry %%SITE_PERL%%/Crypt