aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorclsung <clsung@FreeBSD.org>2006-08-10 23:47:15 +0800
committerclsung <clsung@FreeBSD.org>2006-08-10 23:47:15 +0800
commite09989fda223e4006d8640c01dbc3b82be2c2c90 (patch)
tree7c58317eb0e003b1938f8ebca29a542e5cebc709 /security
parent0b2b7521b5a807e6729dd9ab872645f7ed982c45 (diff)
downloadfreebsd-ports-gnome-e09989fda223e4006d8640c01dbc3b82be2c2c90.tar.gz
freebsd-ports-gnome-e09989fda223e4006d8640c01dbc3b82be2c2c90.tar.zst
freebsd-ports-gnome-e09989fda223e4006d8640c01dbc3b82be2c2c90.zip
- ruby-crypt is a pure-ruby implementation of a number of popular
encryption algorithms.
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/ruby-crypt/Makefile27
-rw-r--r--security/ruby-crypt/distinfo3
-rw-r--r--security/ruby-crypt/pkg-descr10
-rw-r--r--security/ruby-crypt/pkg-plist10
5 files changed, 51 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index f1366b9b106d..a7c35b80b648 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -580,6 +580,7 @@
SUBDIR += ruby-aes
SUBDIR += ruby-blowfish
SUBDIR += ruby-cast_256
+ SUBDIR += ruby-crypt
SUBDIR += ruby-gpgme
SUBDIR += ruby-hmac
SUBDIR += ruby-mcrypt
diff --git a/security/ruby-crypt/Makefile b/security/ruby-crypt/Makefile
new file mode 100644
index 000000000000..a219e9fbc79e
--- /dev/null
+++ b/security/ruby-crypt/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: ruby-crypt
+# Date created: 2006-08-10
+# Whom: Cheng-Lung Sung <clsung@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= crypt
+PORTVERSION= 1.1.4
+CATEGORIES= security ruby
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= clsung@FreeBSD.org
+COMMENT= Pure-ruby implementation of popular encryption algorithms
+
+USE_RUBY= yes
+
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}
+
+do-install:
+ @cd ${WRKSRC}; ${RUBY} install.rb
+
+.include <bsd.port.mk>
diff --git a/security/ruby-crypt/distinfo b/security/ruby-crypt/distinfo
new file mode 100644
index 000000000000..733cd6feee4c
--- /dev/null
+++ b/security/ruby-crypt/distinfo
@@ -0,0 +1,3 @@
+MD5 (ruby/crypt-1.1.4.tar.gz) = 68e6bc4bdc952f5a7919f6bc4fdb1348
+SHA256 (ruby/crypt-1.1.4.tar.gz) = 92d6d5f391aba825f55c9c886ce6aeb4f5241822e3b45f8e80a3cd56242fc4fc
+SIZE (ruby/crypt-1.1.4.tar.gz) = 19824
diff --git a/security/ruby-crypt/pkg-descr b/security/ruby-crypt/pkg-descr
new file mode 100644
index 000000000000..7b0c897a7af0
--- /dev/null
+++ b/security/ruby-crypt/pkg-descr
@@ -0,0 +1,10 @@
+The Crypt library is a pure-ruby implementation of a number of
+popular encryption algorithms. Block cyphers currently available
+include Blowfish, GOST, IDEA, and Rijndael (AES).
+Cypher Block Chaining (CBC) has been implemented.
+Twofish, Serpent, and CAST256 are planned for release soon.
+
+Crypt is written entirely in ruby so deployment is simple -
+no platform concerns, no library dependencies, nothing to compile.
+
+WWW: http://crypt.rubyforge.org/
diff --git a/security/ruby-crypt/pkg-plist b/security/ruby-crypt/pkg-plist
new file mode 100644
index 000000000000..7e42137cc1a3
--- /dev/null
+++ b/security/ruby-crypt/pkg-plist
@@ -0,0 +1,10 @@
+%%RUBY_SITELIBDIR%%/crypt/blowfish.rb
+%%RUBY_SITELIBDIR%%/crypt/blowfish-tables.rb
+%%RUBY_SITELIBDIR%%/crypt/cbc.rb
+%%RUBY_SITELIBDIR%%/crypt/gost.rb
+%%RUBY_SITELIBDIR%%/crypt/idea.rb
+%%RUBY_SITELIBDIR%%/crypt/noise.rb
+%%RUBY_SITELIBDIR%%/crypt/rijndael-tables.rb
+%%RUBY_SITELIBDIR%%/crypt/rijndael.rb
+%%RUBY_SITELIBDIR%%/crypt/stringxor.rb
+@dirrm %%RUBY_SITELIBDIR%%/crypt