aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2007-08-08 00:46:22 +0800
committerume <ume@FreeBSD.org>2007-08-08 00:46:22 +0800
commite1f86e5b808e8c0a0e9a84e8bc21ff5e90c64acb (patch)
tree61294daf138c9b3a3deb2a6726aa3fe7721e76e4 /security
parentfb551e529640d7fbea47a2df117c46a12fe9ba1b (diff)
downloadfreebsd-ports-gnome-e1f86e5b808e8c0a0e9a84e8bc21ff5e90c64acb.tar.gz
freebsd-ports-gnome-e1f86e5b808e8c0a0e9a84e8bc21ff5e90c64acb.tar.zst
freebsd-ports-gnome-e1f86e5b808e8c0a0e9a84e8bc21ff5e90c64acb.zip
- Use OPTIONS.
- Obey the default BDB version defined in bsd.database.mk.
Diffstat (limited to 'security')
-rw-r--r--security/cyrus-sasl2-saslauthd/Makefile26
-rw-r--r--security/cyrus-sasl2/Makefile36
2 files changed, 28 insertions, 34 deletions
diff --git a/security/cyrus-sasl2-saslauthd/Makefile b/security/cyrus-sasl2-saslauthd/Makefile
index 8f6dd8445e41..babbca15e653 100644
--- a/security/cyrus-sasl2-saslauthd/Makefile
+++ b/security/cyrus-sasl2-saslauthd/Makefile
@@ -42,16 +42,14 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-rc4=openssl \
--with-saslauthd=${SASLAUTHD_RUNPATH}
-.if defined(WITH_BDB_VER)
-.if ${WITH_BDB_VER} == 4
-USE_BDB= 40
-.elif ${WITH_BDB_VER} != 3 && ${WITH_BDB_VER} != 41 && \
- ${WITH_BDB_VER} != 42 && ${WITH_BDB_VER} != 43 && \
- ${WITH_BDB_VER} != 44 && ${WITH_BDB_VER} != 45 && ${WITH_BDB_VER} != 46
-IGNORE= "cannot install: WITH_BDB_VER must be 3, 4, 41, 42, 43, 44, 45 or 46"
-.endif
-USE_BDB?= ${WITH_BDB_VER}
-BDB_SUFFIX?= ${WITH_BDB_VER}
+OPTIONS= BDB "Use Berkeley DB" off \
+ OPENLDAP "Use OpenLDAP" off \
+ HTTPFORM "Enable HTTP form authentication" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_BDB)
+USE_BDB= yes
CONFIGURE_ARGS+=--with-dblib=berkeley --with-bdb-libdir=${LOCALBASE}/lib \
--with-bdb-incdir=${BDB_INCLUDE_DIR} \
--with-bdb=${BDB_LIB_NAME}
@@ -59,14 +57,10 @@ CONFIGURE_ARGS+=--with-dblib=berkeley --with-bdb-libdir=${LOCALBASE}/lib \
CONFIGURE_ARGS+=--with-dblib=ndbm
.endif
+.if defined(WITH_OPENLDAP)
.if defined(WITH_OPENLDAP_VER)
-WITH_OPENLDAP= yes
WANT_OPENLDAP_VER= ${WITH_OPENLDAP_VER}
.endif
-.if defined(WITH_OPENLDAP)
-.if defined(WANT_OPENLDAP_VER) && ${WANT_OPENLDAP_VER} == 12
-BROKEN= "this port requires OpenLDAP >= 2.0"
-.endif
USE_OPENLDAP= yes
CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
.endif
@@ -75,8 +69,6 @@ CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}
CONFIGURE_ARGS+=--enable-httpform
.endif
-.include <bsd.port.pre.mk>
-
.if !defined(WITHOUT_GSSAPI) && defined(KRB5_HOME) && exists(${KRB5_HOME}/lib/libgssapi_krb5.so)
CONFIGURE_ARGS+=--enable-gssapi=${KRB5_HOME} --with-gss_impl=mit
.elif !defined(WITHOUT_GSSAPI) && defined(HEIMDAL_HOME) && exists(${HEIMDAL_HOME}/lib/libgssapi.a)
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index 7c109cb2ad3c..d5b23b5f91ff 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -54,15 +54,25 @@ CONFIGURE_ARGS= --sysconfdir=${PREFIX}/etc \
--with-rc4=openssl \
--with-saslauthd=${SASLAUTHD_RUNPATH}
-.if defined(WITH_BDB_VER)
-.if ${WITH_BDB_VER} == 4
-USE_BDB= 40
-.elif ${WITH_BDB_VER} != 3 && ${WITH_BDB_VER} != 41 && \
- ${WITH_BDB_VER} != 42 && ${WITH_BDB_VER} != 43 && \
- ${WITH_BDB_VER} != 44 && ${WITH_BDB_VER} != 45 && ${WITH_BDB_VER} != 46
-IGNORE= "cannot install: WITH_BDB_VER must be 3, 4, 41, 42, 43, 44, 45 or 46"
-.endif
-USE_BDB?= ${WITH_BDB_VER}
+OPTIONS= BDB "Use Berkeley DB" off \
+ MYSQL "Use MySQL" off \
+ PGSQL "Use PostgreSQL" off \
+ SQLITE "Use SQLite" off \
+ DEV_URANDOM "Use /dev/urandom" off \
+ ALWAYSTRUE "Enable the alwaystrue password verifier" off \
+ KEEP_DB_OPEN "Keep handle to Berkeley DB open" off \
+ AUTHDAEMOND "Enable use of authdaemon" on \
+ LOGIN "Enable LOGIN authentication" on \
+ PLAIN "Enable PLAIN authentication" on \
+ CRAM "Enable CRAM-MD5 authentication" on \
+ DIGEST "Enable DIGEST-MD5 authentication" on \
+ OTP "Enable OTP authentication" on \
+ NTLM "Enable NTLM authentication" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_BDB)
+USE_BDB= yes
CONFIGURE_ARGS+=--with-dblib=berkeley --with-bdb-libdir=${LOCALBASE}/lib \
--with-bdb-incdir=${BDB_INCLUDE_DIR} \
--with-bdb=${BDB_LIB_NAME}
@@ -72,12 +82,6 @@ CONFIGURE_ARGS+=--with-dblib=ndbm
SASLDB_NAME= sasldb2.db
.endif
-.if defined(WITH_MYSQL_VER)
-WITH_MYSQL= yes
-.if ${WITH_MYSQL_VER} == 3
-WANT_MYSQL_VER= 323
-.endif
-.endif
.if defined(WITH_MYSQL)
USE_MYSQL= yes
CONFIGURE_ARGS+=--with-mysql=${LOCALBASE}
@@ -154,8 +158,6 @@ NTLM= "@comment "
CONFIGURE_ARGS+=--enable-ntlm
.endif
-.include <bsd.port.pre.mk>
-
.if ${ARCH} == "amd64"
CPPFLAGS+= -fPIC
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}"