aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorjase <jase@FreeBSD.org>2014-10-28 05:48:42 +0800
committerjase <jase@FreeBSD.org>2014-10-28 05:48:42 +0800
commite4186055eb3dfcf242ff0d5ce8653b2c5ea70055 (patch)
tree2797cd15b6738003f8ed72cfa4259b09eadc2204 /security
parent1777684068fc882188b1ed1413a04d05f60d6dfe (diff)
downloadfreebsd-ports-gnome-e4186055eb3dfcf242ff0d5ce8653b2c5ea70055.tar.gz
freebsd-ports-gnome-e4186055eb3dfcf242ff0d5ce8653b2c5ea70055.tar.zst
freebsd-ports-gnome-e4186055eb3dfcf242ff0d5ce8653b2c5ea70055.zip
security/polarssl: Update to 1.2.12
While I am here: - Remove fetch wrapper as it is no longer required - Strip library shared object - Remove @dirrm* from pkg-plist Changes: https://raw.github.com/polarssl/polarssl/polarssl-1.2.12/ChangeLog
Diffstat (limited to 'security')
-rw-r--r--security/polarssl/Makefile18
-rw-r--r--security/polarssl/distinfo4
-rwxr-xr-xsecurity/polarssl/files/fetchwrapper.sh41
-rw-r--r--security/polarssl/files/patch-library-Makefile6
-rw-r--r--security/polarssl/pkg-plist4
5 files changed, 11 insertions, 62 deletions
diff --git a/security/polarssl/Makefile b/security/polarssl/Makefile
index b18909033282..df3c0ebca22c 100644
--- a/security/polarssl/Makefile
+++ b/security/polarssl/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= polarssl
-PORTVERSION= 1.2.10
+PORTVERSION= 1.2.12
DISTVERSIONSUFFIX= -gpl
CATEGORIES= security devel
MASTER_SITES= http://polarssl.org/download/
@@ -11,10 +11,6 @@ COMMENT= Open Source embedded SSL/TLS cryptographic library
LICENSE= GPLv2
-# bypass the HTML "now downloading..." splash site, code below
-# .include <bsd.port.pre.mk>
-URL_SUFFIX= ?do=yes
-FETCH_ARGS= -pRro ${DISTFILES}
ALL_TARGET= no_test
USES= gmake tar:tgz
@@ -37,8 +33,9 @@ BINFILES= aescrypt2 benchmark dh_client dh_genprime dh_server hello \
do-install:
@cd ${WRKSRC}/include && ${COPYTREE_SHARE} ${PORTNAME} ${STAGEDIR}${PREFIX}/include "! -name *.orig"
${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.a ${STAGEDIR}${PREFIX}/lib/
- ${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.so ${STAGEDIR}${PREFIX}/lib/libpolarssl.so.0
- cd ${STAGEDIR}${PREFIX}/lib/ && ${LN} -sf libpolarssl.so.0 libpolarssl.so
+ ${INSTALL_DATA} ${WRKSRC}/library/libpolarssl.so ${STAGEDIR}${PREFIX}/lib/libpolarssl.so.5
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libpolarssl.so.5
+ cd ${STAGEDIR}${PREFIX}/lib/ && ${LN} -sf libpolarssl.so.5 libpolarssl.so
.for i in ${BINFILES}
${INSTALL_PROGRAM} ${WRKSRC}/programs/*/${i} ${STAGEDIR}${PREFIX}/bin/polarssl_${i}
.endfor
@@ -55,13 +52,8 @@ post-install:
.endfor
.endif
-.include <bsd.port.pre.mk>
-
-FETCH_CMD= ${SH} ${FILESDIR}/fetchwrapper.sh \
- ${URL_SUFFIX} ${FETCH_BINARY} ${FETCH_ARGS}
-
.if ${ARCH} == "powerpc"
BROKEN= Does not compile on powerpc
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/polarssl/distinfo b/security/polarssl/distinfo
index 880044cb0396..529d088010c8 100644
--- a/security/polarssl/distinfo
+++ b/security/polarssl/distinfo
@@ -1,2 +1,2 @@
-SHA256 (polarssl-1.2.10-gpl.tgz) = b45a06b2fdeb0833970e6fb69bc331f2757a1b7e85537b02c1f169434ed888fa
-SIZE (polarssl-1.2.10-gpl.tgz) = 999515
+SHA256 (polarssl-1.2.12-gpl.tgz) = 63dd60e78d25c438648607bb177b063dcf5fbf3ced9ee794fcb165d101940131
+SIZE (polarssl-1.2.12-gpl.tgz) = 1021400
diff --git a/security/polarssl/files/fetchwrapper.sh b/security/polarssl/files/fetchwrapper.sh
deleted file mode 100755
index dcbe42ced2b6..000000000000
--- a/security/polarssl/files/fetchwrapper.sh
+++ /dev/null
@@ -1,41 +0,0 @@
-#!/bin/sh
-
-# $FreeBSD$
-
-# This script tacks the first argument onto each URL found in the list,
-# discards and then executes the list.
-
-# URL matching is simplistic, a URL is what matches *tp://* (so file:///
-# is not matched).
-
-# For instance, calling:
-# fetchwrapper.sh '?do=yes' /usr/bin/fetch -pPr http://example.org/file
-# will execute:
-# /usr/bin/fetch -pPr http://example.org/file?do=yes
-
-# The intention is to work around download splash screens on web servers.
-
-# (C) Copyright 2013 by Matthias Andree.
-# Licensed under the 2-clause BSD license.
-
-if [ $# -lt 3 ] ; then
- echo >&2 "Usage: $0 URLsuffix fetch-command [options] URL [post-options]"
- exit 1
-fi
-
-patcharray() {
- # based on Rich Felker's "Working with arrays",
- # http://www.etalabs.net/sh_tricks.html
- for i do
- case "$i" in *tp://*) j=$suffix ;; *) j= ;; esac
- printf %s%s\\n "$i" "$j" | sed -e "s/'/'\\\\''/g;1s/^/'/;\$s/\$/' \\\\/"
- done
- echo " "
-}
-
-suffix="$1" ; shift
-args=$(patcharray "$@")
-eval "set -- $args"
-
-set -x
-exec "$@"
diff --git a/security/polarssl/files/patch-library-Makefile b/security/polarssl/files/patch-library-Makefile
index 75b1dca1cc03..09f0b642b731 100644
--- a/security/polarssl/files/patch-library-Makefile
+++ b/security/polarssl/files/patch-library-Makefile
@@ -1,5 +1,5 @@
---- library/Makefile.orig 2012-11-26 19:20:30.821850410 +0000
-+++ library/Makefile 2012-11-26 19:21:01.534380354 +0000
+--- library/Makefile.orig 2014-10-24 09:42:52.000000000 +0100
++++ library/Makefile 2014-10-27 20:13:26.522466123 +0000
@@ -18,9 +18,7 @@
# CFLAGS += -D_BSD_EXTENSION
@@ -8,7 +8,7 @@
CFLAGS += -fPIC
-endif
- SONAME=libpolarssl.so.0
+ SONAME=libpolarssl.so.5
@@ -53,11 +51,7 @@
diff --git a/security/polarssl/pkg-plist b/security/polarssl/pkg-plist
index d0f84fc4408b..a5f8f2194952 100644
--- a/security/polarssl/pkg-plist
+++ b/security/polarssl/pkg-plist
@@ -65,8 +65,6 @@ include/polarssl/x509write.h
include/polarssl/xtea.h
lib/libpolarssl.a
lib/libpolarssl.so
-lib/libpolarssl.so.0
+lib/libpolarssl.so.5
%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
%%PORTDOCS%%%%DOCSDIR%%/README
-%%PORTDOCS%%@dirrmtry %%DOCSDIR%%
-@dirrmtry include/polarssl