aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2005-07-11 03:15:12 +0800
committerdinoex <dinoex@FreeBSD.org>2005-07-11 03:15:12 +0800
commitf772a28c6dc204c560ea1e3f7bc4b039be33d6ba (patch)
tree57620bb30d2afaffa3d2dca12bca5075f6267b3f /security
parent60ec3fe6ef80975b2e5a1e4aa165c1d93beb2504 (diff)
downloadfreebsd-ports-gnome-f772a28c6dc204c560ea1e3f7bc4b039be33d6ba.tar.gz
freebsd-ports-gnome-f772a28c6dc204c560ea1e3f7bc4b039be33d6ba.tar.zst
freebsd-ports-gnome-f772a28c6dc204c560ea1e3f7bc4b039be33d6ba.zip
- update to 0.9.8 for WITH_OPENSSL_BETA=yes
Diffstat (limited to 'security')
-rw-r--r--security/openssl/Makefile50
-rw-r--r--security/openssl/distinfo2
-rw-r--r--security/openssl/files-beta/hw_cryptodev.c.patch-aes_256210
-rw-r--r--security/openssl/files-beta/hw_cryptodev.c.patch-cloning37
-rw-r--r--security/openssl/files-beta/patch-Configure41
-rw-r--r--security/openssl/files-beta/patch-ad11
-rw-r--r--security/openssl/files-beta/patch-ak11
-rw-r--r--security/openssl/files-beta/patch-config13
-rw-r--r--security/openssl/files-beta/patch-crypto-dso-Makefile14
-rw-r--r--security/openssl/files-beta/patch-doc-crypto-des_modes.pod11
-rw-r--r--security/openssl/pkg-plist22
11 files changed, 417 insertions, 5 deletions
diff --git a/security/openssl/Makefile b/security/openssl/Makefile
index 9e34ec455781..51b4741694da 100644
--- a/security/openssl/Makefile
+++ b/security/openssl/Makefile
@@ -6,13 +6,18 @@
#
PORTNAME= openssl
-.if defined(OPENSSL_SNAPSHOT)
-PORTVERSION= 0.9.7
+.if defined(WITH_OPENSSL_SNAPSHOT)
+PORTVERSION= 0.9.8
PORTREVISION!= date -v-1d +%Y%m%d
.else
+.if defined(WITH_OPENSSL_BETA)
+PORTVERSION= 0.9.8
+PORTREVISION?= 0
+.else
PORTVERSION= 0.9.7g
PORTREVISION?= 0
.endif
+.endif
CATEGORIES= security devel
MASTER_SITES= http://www.openssl.org/%SUBDIR%/ \
ftp://ftp.openssl.org/%SUBDIR%/ \
@@ -29,7 +34,7 @@ COMMENT= SSL and crypto library
.error You have `USE_OPENSSL' variable defined either in environment or in make(1) arguments. Please undefine and try again.
.endif
-.if defined(OPENSSL_SNAPSHOT)
+.if defined(WITH_OPENSSL_SNAPSHOT)
MASTER_SITE_SUBDIR2= snapshot
DISTNAME2= ${PORTNAME}-${PORTVERSION}-stable-SNAP-${PORTREVISION}
NO_CHECKSUM= yes
@@ -38,18 +43,26 @@ MASTER_SITE_SUBDIR2= source
DISTNAME2= ${PORTNAME}-${PORTVERSION}
.endif
+.if defined(WITH_OPENSSL_BETA) || defined(WITH_OPENSSL_SNAPSHOT)
.if defined(WITH_OPENSSL_BETA)
BETA_SUFFIX= -beta
CONFLICTS?= openssl-0.*
+.endif
OPENSSL_SHLIBVER?= 4
NO_LATEST_LINK= yes
+PATCHDIR= ${MASTERDIR}/files-beta
+PLIST_SUB+= OPENSSL_BETA=""
+PLIST_SUB+= OPENSSL_STABLE="@comment "
.else
CONFLICTS?= openssl-beta-0.*
OPENSSL_SHLIBVER?= 3
+PLIST_SUB+= OPENSSL_BETA="@comment "
+PLIST_SUB+= OPENSSL_STABLE=""
.endif
MAKE_ENV+= MANPREFIX=${MANPREFIX}
NOPRECIOUSMAKEVARS= Too many _MLINKS for fetch
+NOPRECIOUSSOFTMAKEVARS= Too many _MLINKS for fetch
USE_REINPLACE= yes
USE_PERL5_BUILD= yes
CFLAGS+= -Wl,-rpath,${LOCALBASE}/lib
@@ -847,6 +860,29 @@ MLINKS= dgst.1 md4.1 \
ui_compat.3 des_read_pw_string.3 \
des_modes.7 Modes_of_DES.7
+.if defined(WITH_OPENSSL_BETA) || defined(WITH_OPENSSL_SNAPSHOT)
+MAN1+= ec.1 ecparam.1
+MAN3+= ASN1_generate_nconf.3 BN_BLINDING_new.3 ERR_set_mark.3 \
+ ecdsa.3 OPENSSL_Applink.3 OPENSSL_ia32cap.3 x509.3
+MAN5+= x509v3_config.5
+MLINKS+= \
+ ASN1_generate_nconf.3 ASN1_generate_v3.3 \
+ BN_BLINDING_new.3 BN_BLINDING_convert.3 \
+ BN_BLINDING_new.3 BN_BLINDING_free.3 \
+ BN_BLINDING_new.3 BN_BLINDING_update.3 \
+ BN_BLINDING_new.3 BN_BLINDING_invert.3 \
+ BN_BLINDING_new.3 BN_BLINDING_convert_ex.3 \
+ BN_BLINDING_new.3 BN_BLINDING_invert_ex.3 \
+ BN_BLINDING_new.3 BN_BLINDING_get_thread_id.3 \
+ BN_BLINDING_new.3 BN_BLINDING_set_thread_id.3 \
+ BN_BLINDING_new.3 BN_BLINDING_get_flags.3 \
+ BN_BLINDING_new.3 BN_BLINDING_set_flags.3 \
+ BN_BLINDING_new.3 BN_BLINDING_create_param.3 \
+ ERR_set_mark.3 ERR_pop_to_mark.3
+.else
+MAN3+= SN1_generate_nconf.3
+.endif
+
.include <bsd.port.pre.mk>
.if ${PORTOBJFORMAT} == "aout"
@@ -902,6 +938,13 @@ do-configure:
PTHREAD_CFLAGS=${PTHREAD_CFLAGS} PTHREAD_LIBS=${PTHREAD_LIBS} \
./config --prefix=${PREFIX} --openssldir=${OPENSSLDIR} \
-L${PREFIX}/lib ${EXTRACONFIGURE}
+.if defined(WITH_OPENSSL_BETA)
+ @${REINPLACE_CMD} \
+ -e 's|^MANDIR=.*$$|MANDIR=$$(MANPREFIX)/man|' \
+ -e 's|lib/pkgconfig|libdata/pkgconfig|g' \
+ -e 's|LIBVERSION=[^ ]* |LIBVERSION=$(OPENSSL_SHLIBVER) |' \
+ ${WRKSRC}/Makefile
+.else
@${REINPLACE_CMD} \
-e 's|^FIPS_DES_ENC=|#FIPS_DES_ENC=|' \
-e 's|^FIPS_SHA1_ASM_OBJ=|#FIPS_SHA1_ASM_OBJ=|' \
@@ -909,6 +952,7 @@ do-configure:
-e 's|^SHARED_LIBS_LINK_EXTS=.*$$|SHARED_LIBS_LINK_EXTS=.so|' \
-e 's|^SHLIBDIRS= fips|SHLIBDIRS=|' \
${WRKSRC}/Makefile
+.endif
post-install:
.if !defined(NOSHARED)
diff --git a/security/openssl/distinfo b/security/openssl/distinfo
index 754b86d11879..053e90919874 100644
--- a/security/openssl/distinfo
+++ b/security/openssl/distinfo
@@ -1,2 +1,4 @@
MD5 (openssl-0.9.7g.tar.gz) = 991615f73338a571b6a1be7d74906934
SIZE (openssl-0.9.7g.tar.gz) = 3132217
+MD5 (openssl-0.9.8.tar.gz) = 9da21071596a124acde6080552deac16
+SIZE (openssl-0.9.8.tar.gz) = 3259550
diff --git a/security/openssl/files-beta/hw_cryptodev.c.patch-aes_256 b/security/openssl/files-beta/hw_cryptodev.c.patch-aes_256
new file mode 100644
index 000000000000..e4efffa21530
--- /dev/null
+++ b/security/openssl/files-beta/hw_cryptodev.c.patch-aes_256
@@ -0,0 +1,210 @@
+===================================================================
+RCS file: crypto/engine/hw_cryptodev.c,v
+retrieving revision 1.17
+retrieving revision 1.18
+diff -u -p -r1.17 -r1.18
+--- crypto/engine/hw_cryptodev.c 2003/06/03 15:57:44 1.17
++++ crypto/engine/hw_cryptodev.c 2003/08/07 16:27:47 1.18
+@@ -68,14 +68,19 @@ struct dev_crypto_state {
+ int d_fd;
+ };
+
++struct dev_crypto_cipher {
++ int c_id;
++ int c_nid;
++ int c_ivmax;
++ int c_keylen;
++};
++
+ static u_int32_t cryptodev_asymfeat = 0;
+
+ static int get_asym_dev_crypto(void);
+ static int open_dev_crypto(void);
+ static int get_dev_crypto(void);
+-static int cryptodev_max_iv(int cipher);
+-static int cryptodev_key_length_valid(int cipher, int len);
+-static int cipher_nid_to_cryptodev(int nid);
++static struct dev_crypto_cipher *cipher_nid_to_cryptodev(int nid);
+ static int get_cryptodev_ciphers(const int **cnids);
+ static int get_cryptodev_digests(const int **cnids);
+ static int cryptodev_usable_ciphers(const int **nids);
+@@ -122,15 +127,12 @@ static const ENGINE_CMD_DEFN cryptodev_d
+ { 0, NULL, NULL, 0 }
+ };
+
+-static struct {
+- int id;
+- int nid;
+- int ivmax;
+- int keylen;
+-} ciphers[] = {
++static struct dev_crypto_cipher ciphers[] = {
+ { CRYPTO_DES_CBC, NID_des_cbc, 8, 8, },
+ { CRYPTO_3DES_CBC, NID_des_ede3_cbc, 8, 24, },
+ { CRYPTO_AES_CBC, NID_aes_128_cbc, 16, 16, },
++ { CRYPTO_AES_CBC, NID_aes_192_cbc, 16, 24, },
++ { CRYPTO_AES_CBC, NID_aes_256_cbc, 16, 32, },
+ { CRYPTO_BLF_CBC, NID_bf_cbc, 8, 16, },
+ { CRYPTO_CAST_CBC, NID_cast5_cbc, 8, 16, },
+ { CRYPTO_SKIPJACK_CBC, NID_undef, 0, 0, },
+@@ -200,48 +202,16 @@ get_asym_dev_crypto(void)
+ return fd;
+ }
+
+-/*
+- * XXXX this needs to be set for each alg - and determined from
+- * a running card.
+- */
+-static int
+-cryptodev_max_iv(int cipher)
+-{
+- int i;
+-
+- for (i = 0; ciphers[i].id; i++)
+- if (ciphers[i].id == cipher)
+- return (ciphers[i].ivmax);
+- return (0);
+-}
+-
+-/*
+- * XXXX this needs to be set for each alg - and determined from
+- * a running card. For now, fake it out - but most of these
+- * for real devices should return 1 for the supported key
+- * sizes the device can handle.
+- */
+-static int
+-cryptodev_key_length_valid(int cipher, int len)
+-{
+- int i;
+-
+- for (i = 0; ciphers[i].id; i++)
+- if (ciphers[i].id == cipher)
+- return (ciphers[i].keylen == len);
+- return (0);
+-}
+-
+ /* convert libcrypto nids to cryptodev */
+-static int
++static struct dev_crypto_cipher *
+ cipher_nid_to_cryptodev(int nid)
+ {
+ int i;
+
+- for (i = 0; ciphers[i].id; i++)
+- if (ciphers[i].nid == nid)
+- return (ciphers[i].id);
+- return (0);
++ for (i = 0; ciphers[i].c_id; i++)
++ if (ciphers[i].c_nid == nid)
++ return (&ciphers[i]);
++ return (NULL);
+ }
+
+ /*
+@@ -264,15 +234,15 @@ get_cryptodev_ciphers(const int **cnids)
+ memset(&sess, 0, sizeof(sess));
+ sess.key = (caddr_t)"123456781234567812345678";
+
+- for (i = 0; ciphers[i].id && count < CRYPTO_ALGORITHM_MAX; i++) {
+- if (ciphers[i].nid == NID_undef)
++ for (i = 0; ciphers[i].c_id && count < CRYPTO_ALGORITHM_MAX; i++) {
++ if (ciphers[i].c_nid == NID_undef)
+ continue;
+- sess.cipher = ciphers[i].id;
+- sess.keylen = ciphers[i].keylen;
++ sess.cipher = ciphers[i].c_id;
++ sess.keylen = ciphers[i].c_keylen;
+ sess.mac = 0;
+ if (ioctl(fd, CIOCGSESSION, &sess) != -1 &&
+ ioctl(fd, CIOCFSESSION, &sess.ses) != -1)
+- nids[count++] = ciphers[i].nid;
++ nids[count++] = ciphers[i].c_nid;
+ }
+ close(fd);
+
+@@ -425,15 +395,15 @@ cryptodev_init_key(EVP_CIPHER_CTX *ctx,
+ {
+ struct dev_crypto_state *state = ctx->cipher_data;
+ struct session_op *sess = &state->d_sess;
+- int cipher;
++ struct dev_crypto_cipher *cipher;
+
+- if ((cipher = cipher_nid_to_cryptodev(ctx->cipher->nid)) == NID_undef)
++ if ((cipher = cipher_nid_to_cryptodev(ctx->cipher->nid)) == NULL)
+ return (0);
+
+- if (ctx->cipher->iv_len > cryptodev_max_iv(cipher))
++ if (ctx->cipher->iv_len > cipher->c_ivmax)
+ return (0);
+
+- if (!cryptodev_key_length_valid(cipher, ctx->key_len))
++ if (ctx->key_len != cipher->c_keylen)
+ return (0);
+
+ memset(sess, 0, sizeof(struct session_op));
+@@ -443,7 +413,7 @@ cryptodev_init_key(EVP_CIPHER_CTX *ctx,
+
+ sess->key = (unsigned char *)key;
+ sess->keylen = ctx->key_len;
+- sess->cipher = cipher;
++ sess->cipher = cipher->c_id;
+
+ if (ioctl(state->d_fd, CIOCGSESSION, sess) == -1) {
+ close(state->d_fd);
+@@ -548,7 +518,7 @@ const EVP_CIPHER cryptodev_cast_cbc = {
+ NULL
+ };
+
+-const EVP_CIPHER cryptodev_aes_cbc = {
++const EVP_CIPHER cryptodev_aes_128_cbc = {
+ NID_aes_128_cbc,
+ 16, 16, 16,
+ EVP_CIPH_CBC_MODE,
+@@ -561,6 +531,32 @@ const EVP_CIPHER cryptodev_aes_cbc = {
+ NULL
+ };
+
++const EVP_CIPHER cryptodev_aes_192_cbc = {
++ NID_aes_192_cbc,
++ 16, 24, 16,
++ EVP_CIPH_CBC_MODE,
++ cryptodev_init_key,
++ cryptodev_cipher,
++ cryptodev_cleanup,
++ sizeof(struct dev_crypto_state),
++ EVP_CIPHER_set_asn1_iv,
++ EVP_CIPHER_get_asn1_iv,
++ NULL
++};
++
++const EVP_CIPHER cryptodev_aes_256_cbc = {
++ NID_aes_256_cbc,
++ 16, 32, 16,
++ EVP_CIPH_CBC_MODE,
++ cryptodev_init_key,
++ cryptodev_cipher,
++ cryptodev_cleanup,
++ sizeof(struct dev_crypto_state),
++ EVP_CIPHER_set_asn1_iv,
++ EVP_CIPHER_get_asn1_iv,
++ NULL
++};
++
+ /*
+ * Registered by the ENGINE when used to find out how to deal with
+ * a particular NID in the ENGINE. this says what we'll do at the
+@@ -587,7 +583,13 @@ cryptodev_engine_ciphers(ENGINE *e, cons
+ *cipher = &cryptodev_cast_cbc;
+ break;
+ case NID_aes_128_cbc:
+- *cipher = &cryptodev_aes_cbc;
++ *cipher = &cryptodev_aes_128_cbc;
++ break;
++ case NID_aes_192_cbc:
++ *cipher = &cryptodev_aes_192_cbc;
++ break;
++ case NID_aes_256_cbc:
++ *cipher = &cryptodev_aes_256_cbc;
+ break;
+ default:
+ *cipher = NULL;
diff --git a/security/openssl/files-beta/hw_cryptodev.c.patch-cloning b/security/openssl/files-beta/hw_cryptodev.c.patch-cloning
new file mode 100644
index 000000000000..82c159a32528
--- /dev/null
+++ b/security/openssl/files-beta/hw_cryptodev.c.patch-cloning
@@ -0,0 +1,37 @@
+Index: crypto/engine/hw_cryptodev.c
+===================================================================
+RCS file: /home/ncvs/src/crypto/openssl/crypto/engine/hw_cryptodev.c,v
+retrieving revision 1.1.1.3
+diff -u -r1.1.1.3 hw_cryptodev.c
+--- crypto/engine/hw_cryptodev.c 17 Mar 2004 15:44:46 -0000 1.1.1.3
++++ crypto/engine/hw_cryptodev.c 18 Jan 2005 12:27:17 -0000
+@@ -180,6 +180,10 @@
+ return (-1);
+ if (ioctl(fd, CRIOGET, &retfd) == -1)
+ return (-1);
++ if (retfd == -1)
++ retfd = fd;
++ else
++ close(fd);
+
+ /* close on exec */
+ if (fcntl(retfd, F_SETFD, 1) == -1) {
+Index: crypto/evp/openbsd_hw.c
+===================================================================
+RCS file: /home/ncvs/src/crypto/openssl/crypto/evp/openbsd_hw.c,v
+retrieving revision 1.1.1.1
+diff -u -r1.1.1.1 openbsd_hw.c
+--- crypto/evp/openbsd_hw.c 28 Jan 2003 21:24:39 -0000 1.1.1.1
++++ crypto/evp/openbsd_hw.c 18 Jan 2005 12:26:45 -0000
+@@ -109,7 +109,10 @@
+ dev_failed=1;
+ return 0;
+ }
+- close(cryptodev_fd);
++ if (fd == -1)
++ fd = cryptodev_fd;
++ else
++ close(cryptodev_fd);
+ }
+ assert(ses);
+ memset(ses,'\0',sizeof *ses);
diff --git a/security/openssl/files-beta/patch-Configure b/security/openssl/files-beta/patch-Configure
new file mode 100644
index 000000000000..20c69c572153
--- /dev/null
+++ b/security/openssl/files-beta/patch-Configure
@@ -0,0 +1,41 @@
+--- Configure.orig Tue Jul 5 01:24:11 2005
++++ Configure Sun Jul 10 13:37:03 2005
+@@ -130,7 +130,7 @@
+ # which has to be accompanied by explicit -D_THREAD_SAFE and
+ # sometimes -D_REENTRANT. FreeBSD 5.x expands it as -lc_r, which
+ # seems to be sufficient?
+-my $BSDthreads="-pthread -D_THREAD_SAFE -D_REENTRANT";
++my $BSDthreads="$ENV{'PTHREAD_LIBS'} -D_REENTRANT $ENV{'PTHREAD_CFLAGS'}";
+
+ #config-string $cc : $cflags : $unistd : $thread_cflag : $sys_id : $lflags : $bn_ops : $cpuid_obj : $bn_obj : $des_obj : $aes_obj : $bf_obj : $md5_obj : $sha1_obj : $cast_obj : $rc4_obj : $rmd160_obj : $rc5_obj : $dso_scheme : $shared_target : $shared_cflag : $shared_ldflag : $shared_extension : $ranlib : $arflags
+
+@@ -355,19 +355,20 @@
+ "linux-alpha+bwx-ccc","ccc:-fast -readonly_strings -DL_ENDIAN -DTERMIO::-D_REENTRANT:::SIXTY_FOUR_BIT_LONG RC4_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC1 DES_UNROLL:${no_asm}",
+
+ #### *BSD [do see comment about ${BSDthreads} above!]
+-"BSD-generic32","gcc:-DTERMIOS -O3 -fomit-frame-pointer -Wall::${BSDthreads}:::BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL:${no_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+-"BSD-x86", "gcc:-DL_ENDIAN -DTERMIOS -O3 -fomit-frame-pointer -Wall::${BSDthreads}:::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_out_asm}:dlfcn:bsd-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+-"BSD-x86-elf", "gcc:-DL_ENDIAN -DTERMIOS -O3 -fomit-frame-pointer -Wall::${BSDthreads}:::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:bsd-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+-"debug-BSD-x86-elf", "gcc:-DL_ENDIAN -DTERMIOS -O3 -Wall -g::${BSDthreads}:::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:bsd-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+-"BSD-sparcv8", "gcc:-DB_ENDIAN -DTERMIOS -O3 -mv8 -Wall::${BSDthreads}:::BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL::sparcv8.o:des_enc-sparc.o fcrypt_b.o:::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
++"BSD-generic32","$ENV{'CC'}:-DTERMIOS -O3 -fomit-frame-pointer -Wall $ENV{'CFLAGS'}::${BSDthreads}:::BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL:${no_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIBVER)",
++"BSD-x86", "$ENV{'CC'}:-DL_ENDIAN -DTERMIOS -O3 -fomit-frame-pointer -Wall $ENV{'CFLAGS'}::${BSDthreads}:::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_out_asm}:dlfcn:bsd-shared:-fPIC::.so.\$(SHLIBVER)",
++"BSD-x86-elf", "$ENV{'CC'}:-DL_ENDIAN -DTERMIOS -O3 -fomit-frame-pointer -Wall::${BSDthreads}:::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:bsd-shared:-fPIC::.so.\$(SHLIBVER)",
++"debug-BSD-x86-elf", "$ENV{CC}:-DL_ENDIAN -DTERMIOS -O3 -Wall $ENV{'CFLAGS'} -g::${BSDthreads}:::BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:bsd-shared:-fPIC::.so.\$(SHLIBVER)",
++"BSD-sparcv8", "$ENV{'CC'}:-DB_ENDIAN -DTERMIOS -O3 -mv8 -Wall $ENV{'CFLAGS'}::${BSDthreads}:::BN_LLONG RC2_CHAR RC4_INDEX DES_INT DES_UNROLL::sparcv8.o:des_enc-sparc.o fcrypt_b.o:::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIBVER)",
+
+-"BSD-generic64","gcc:-DTERMIOS -O3 -Wall::${BSDthreads}:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_UNROLL:${no_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
++"BSD-generic64","$ENV{'CC'}:-DTERMIOS -O3 -Wall $ENV{'CFLAGS'}::${BSDthreads}:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_UNROLL:${no_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIBVER)",
+ # -DMD32_REG_T=int doesn't actually belong in sparc64 target, it
+ # simply *happens* to work around a compiler bug in gcc 3.3.3,
+ # triggered by RIPEMD160 code.
+-"BSD-sparc64", "gcc:-DB_ENDIAN -DTERMIOS -O3 -DMD32_REG_T=int -Wall::${BSDthreads}:::SIXTY_FOUR_BIT_LONG RC2_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC2 BF_PTR:::des_enc-sparc.o fcrypt_b.o:::md5-sparcv9.o::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+-"BSD-ia64", "gcc:-DL_ENDIAN -DTERMIOS -O3 -Wall::${BSDthreads}:::SIXTY_FOUR_BIT_LONG RC4_CHUNK:${ia64_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+-"BSD-x86_64", "gcc:-DL_ENDIAN -DTERMIOS -O3 -DMD32_REG_T=int -Wall::${BSDthreads}:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_UNROLL:${x86_64_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
++"BSD-sparc64", "$ENV{'CC'}:-DB_ENDIAN -DTERMIOS -O3 -DMD32_REG_T=int -Wall $ENV{'CFLAGS'}::${BSDthreads}:::SIXTY_FOUR_BIT_LONG RC2_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC2 BF_PTR:${no_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIBVER)",
++"BSD-ia64", "$ENV{'CC'}:-DL_ENDIAN -DTERMIOS -O3 -Wall $ENV{'CFLAGS'}::${BSDthreads}:::SIXTY_FOUR_BIT_LONG RC4_CHUNK:${ia64_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIBVER)",
++"BSD-x86_64", "$ENV{'CC'}:-DL_ENDIAN -DTERMIOS -O3 -DMD32_REG_T=int -Wall $ENV{'CFLAGS'}::${BSDthreads}:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_UNROLL:${x86_64_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIBVER)",
++"BSD-alpha", "$ENV{'CC'}:-DL_ENDIAN -DTERMIOS -O3 -Wall $ENV{'CFLAGS'}::${BSDthreads}:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_UNROLL DES_RISC1:${no_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIBVER)",
+
+ "bsdi-elf-gcc", "gcc:-DPERL5 -DL_ENDIAN -fomit-frame-pointer -O3 -march=i486 -Wall::(unknown)::-ldl:BN_LLONG ${x86_gcc_des} ${x86_gcc_opts}:${x86_elf_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
+
diff --git a/security/openssl/files-beta/patch-ad b/security/openssl/files-beta/patch-ad
new file mode 100644
index 000000000000..cd606a304160
--- /dev/null
+++ b/security/openssl/files-beta/patch-ad
@@ -0,0 +1,11 @@
+--- crypto/md5/md5.c.orig Thu Apr 9 07:59:29 1998
++++ crypto/md5/md5.c Sun Dec 27 18:44:33 1998
+@@ -94,7 +94,7 @@
+ err++;
+ continue;
+ }
+- printf("MD5(%s)= ",argv[i]);
++ printf("MD5 (%s) = ",argv[i]);
+ do_fp(IN);
+ fclose(IN);
+ }
diff --git a/security/openssl/files-beta/patch-ak b/security/openssl/files-beta/patch-ak
new file mode 100644
index 000000000000..77e810e497c6
--- /dev/null
+++ b/security/openssl/files-beta/patch-ak
@@ -0,0 +1,11 @@
+--- apps/Makefile.orig Tue Aug 10 11:09:07 2004
++++ apps/Makefile Tue Oct 26 07:00:51 2004
+@@ -112,7 +112,7 @@
+ done
+ @cp openssl.cnf $(INSTALL_PREFIX)$(OPENSSLDIR)/openssl.cnf.new; \
+ chmod 644 $(INSTALL_PREFIX)$(OPENSSLDIR)/openssl.cnf.new; \
+- mv -f $(INSTALL_PREFIX)$(OPENSSLDIR)/openssl.cnf.new $(INSTALL_PREFIX)$(OPENSSLDIR)/openssl.cnf
++ mv -f $(INSTALL_PREFIX)$(OPENSSLDIR)/openssl.cnf.new $(INSTALL_PREFIX)$(OPENSSLDIR)/openssl.cnf.sample
+
+ tags:
+ ctags $(SRC)
diff --git a/security/openssl/files-beta/patch-config b/security/openssl/files-beta/patch-config
new file mode 100644
index 000000000000..59cd1ec27192
--- /dev/null
+++ b/security/openssl/files-beta/patch-config
@@ -0,0 +1,13 @@
+--- config.orig Sun Jun 26 20:10:20 2005
++++ config Sun Jul 10 14:46:38 2005
+@@ -654,8 +654,8 @@
+ *-*-sunos4) OUT="sunos-$CC" ;;
+
+ *86*-*-bsdi4) OUT="BSD-x86-elf"; options="$options no-sse2 -ldl" ;;
+- alpha*-*-*bsd*) OUT="BSD-generic64; options="$options -DL_ENDIAN" ;;
+- powerpc64-*-*bsd*) OUT="BSD-generic64; options="$options -DB_ENDIAN" ;;
++ alpha*-*-*bsd*) OUT="BSD-alpha" ;;
++ powerpc64-*-*bsd*) OUT="BSD-generic64"; options="$options -DB_ENDIAN" ;;
+ sparc64-*-*bsd*) OUT="BSD-sparc64" ;;
+ ia64-*-*bsd*) OUT="BSD-ia64" ;;
+ amd64-*-*bsd*) OUT="BSD-x86_64" ;;
diff --git a/security/openssl/files-beta/patch-crypto-dso-Makefile b/security/openssl/files-beta/patch-crypto-dso-Makefile
new file mode 100644
index 000000000000..b27e728396b8
--- /dev/null
+++ b/security/openssl/files-beta/patch-crypto-dso-Makefile
@@ -0,0 +1,14 @@
+--- crypto/dso/Makefile.orig Tue May 11 14:45:17 2004
++++ crypto/dso/Makefile Fri Nov 5 05:37:11 2004
+@@ -23,9 +23,9 @@
+
+ LIB=$(TOP)/libcrypto.a
+ LIBSRC= dso_dl.c dso_dlfcn.c dso_err.c dso_lib.c dso_null.c \
+- dso_openssl.c dso_win32.c dso_vms.c
++ dso_openssl.c
+ LIBOBJ= dso_dl.o dso_dlfcn.o dso_err.o dso_lib.o dso_null.o \
+- dso_openssl.o dso_win32.o dso_vms.o
++ dso_openssl.o
+
+ SRC= $(LIBSRC)
+
diff --git a/security/openssl/files-beta/patch-doc-crypto-des_modes.pod b/security/openssl/files-beta/patch-doc-crypto-des_modes.pod
new file mode 100644
index 000000000000..3584dda10a12
--- /dev/null
+++ b/security/openssl/files-beta/patch-doc-crypto-des_modes.pod
@@ -0,0 +1,11 @@
+--- doc/crypto/des_modes.pod.orig Tue Mar 5 16:30:13 2002
++++ doc/crypto/des_modes.pod Tue Sep 30 18:58:27 2003
+@@ -2,7 +2,7 @@
+
+ =head1 NAME
+
+-Modes of DES - the variants of DES and other crypto algorithms of OpenSSL
++Modes_of_DES - the variants of DES and other crypto algorithms of OpenSSL
+
+ =head1 DESCRIPTION
+
diff --git a/security/openssl/pkg-plist b/security/openssl/pkg-plist
index dff7948f6d5a..86006d19914e 100644
--- a/security/openssl/pkg-plist
+++ b/security/openssl/pkg-plist
@@ -18,9 +18,12 @@ include/openssl/des_old.h
include/openssl/dh.h
include/openssl/dsa.h
include/openssl/dso.h
+%%OPENSSL_BETA%%include/openssl/dtls1.h
include/openssl/e_os2.h
include/openssl/ebcdic.h
include/openssl/ec.h
+%%OPENSSL_BETA%%include/openssl/ecdsa.h
+%%OPENSSL_BETA%%include/openssl/ecdh.h
include/openssl/engine.h
include/openssl/err.h
include/openssl/evp.h
@@ -32,7 +35,7 @@ include/openssl/lhash.h
include/openssl/md2.h
include/openssl/md4.h
include/openssl/md5.h
-include/openssl/mdc2.h
+%%OPENSSL_STABLE%%include/openssl/mdc2.h
include/openssl/ocsp.h
include/openssl/obj_mac.h
include/openssl/objects.h
@@ -43,10 +46,12 @@ include/openssl/pem.h
include/openssl/pem2.h
include/openssl/pkcs12.h
include/openssl/pkcs7.h
+%%OPENSSL_BETA%%include/openssl/pqueue.h
+%%OPENSSL_BETA%%include/openssl/pq_compat.h
include/openssl/rand.h
include/openssl/rc2.h
include/openssl/rc4.h
-include/openssl/rc5.h
+%%OPENSSL_STABLE%%include/openssl/rc5.h
include/openssl/ripemd.h
include/openssl/rsa.h
include/openssl/safestack.h
@@ -56,6 +61,7 @@ include/openssl/ssl2.h
include/openssl/ssl23.h
include/openssl/ssl3.h
include/openssl/stack.h
+%%OPENSSL_BETA%%include/openssl/store.h
include/openssl/symhacks.h
include/openssl/tls1.h
include/openssl/tmdiff.h
@@ -65,13 +71,25 @@ include/openssl/ui_compat.h
include/openssl/x509.h
include/openssl/x509_vfy.h
include/openssl/x509v3.h
+%%OPENSSL_BETA%%lib/engines/lib4758cca.so
+%%OPENSSL_BETA%%lib/engines/libaep.so
+%%OPENSSL_BETA%%lib/engines/libatalla.so
+%%OPENSSL_BETA%%lib/engines/libchil.so
+%%OPENSSL_BETA%%lib/engines/libcswift.so
+%%OPENSSL_BETA%%lib/engines/libgmp.so
+%%OPENSSL_BETA%%lib/engines/libnuron.so
+%%OPENSSL_BETA%%lib/engines/libsureware.so
+%%OPENSSL_BETA%%lib/engines/libubsec.so
lib/libcrypto.a
%%SHARED%%lib/libcrypto.so
%%SHARED%%lib/libcrypto.so.%%SHLIBVER%%
lib/libssl.a
%%SHARED%%lib/libssl.so
%%SHARED%%lib/libssl.so.%%SHLIBVER%%
+%%OPENSSL_BETA%%libdata/pkgconfig/libcrypto.pc
libdata/pkgconfig/openssl.pc
+%%OPENSSL_BETA%%libdata/pkgconfig/libssl.pc
+%%OPENSSL_BETA%%@dirrm lib/engines
%%NOBASE%%openssl/misc/CA.pl
%%NOBASE%%openssl/misc/CA.sh
%%NOBASE%%openssl/misc/c_hash