aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorkuriyama <kuriyama@FreeBSD.org>2000-07-04 10:44:57 +0800
committerkuriyama <kuriyama@FreeBSD.org>2000-07-04 10:44:57 +0800
commit0a13c4454f8a60b75db96cb1c377ff778030e908 (patch)
tree990587aa13d2cfe2aafb630396b30e5806174e38 /security
parent7a548e71554b64efd6ff635526cba8994b622666 (diff)
downloadfreebsd-ports-gnome-0a13c4454f8a60b75db96cb1c377ff778030e908.tar.gz
freebsd-ports-gnome-0a13c4454f8a60b75db96cb1c377ff778030e908.tar.zst
freebsd-ports-gnome-0a13c4454f8a60b75db96cb1c377ff778030e908.zip
Fix workaround for USA_RESIDENT=YES condition.
Submitted by: dirk.meyer@dinoex.sub.org (maintainer) PR: ports/19608
Diffstat (limited to 'security')
-rw-r--r--security/gnupg-idea/Makefile24
-rw-r--r--security/gnupg-idea/pkg-comment2
2 files changed, 17 insertions, 9 deletions
diff --git a/security/gnupg-idea/Makefile b/security/gnupg-idea/Makefile
index b4ca7ddc8393..65c1c4eb11a4 100644
--- a/security/gnupg-idea/Makefile
+++ b/security/gnupg-idea/Makefile
@@ -25,18 +25,14 @@ pre-fetch:
@${ECHO_MSG} You must set variable USA_RESIDENT to YES, if you are USA resident
@${ECHO_MSG} or to NO, if you aren\'t USA resident to build this package
@${FALSE}
-.endif
+
+.include <bsd.port.mk>
+
+.elif defined(USA_RESIDENT)
.if ${USA_RESIDENT} == NO
DISTFILES= rsa.c idea.c
CONTRIB= rsa idea
-#EXTRACT_ONLY=
-.else
-do-fetch:
- @${ECHO_MSG}
- @${ECHO_MSG} rsaref not yet supported
- @${FALSE}
-.endif
.include <bsd.port.pre.mk>
@@ -58,3 +54,15 @@ do-install:
.endfor
.include <bsd.port.post.mk>
+
+.else
+pre-fetch:
+ @${ECHO_MSG}
+ @${ECHO_MSG} rsaref is not supported in this port
+ @${FALSE}
+
+.include <bsd.port.mk>
+
+.endif
+
+.endif
diff --git a/security/gnupg-idea/pkg-comment b/security/gnupg-idea/pkg-comment
index a42b94b4e0af..c13a56e27bd3 100644
--- a/security/gnupg-idea/pkg-comment
+++ b/security/gnupg-idea/pkg-comment
@@ -1 +1 @@
-gnupg extensions: rsa idea
+Extensions gnupg: rsa idea