aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-05-08 14:51:54 +0800
committerijliao <ijliao@FreeBSD.org>2002-05-08 14:51:54 +0800
commit0e8a2826207116ae08646250cc65d71c2cc60688 (patch)
tree9a3ab3cc180f0e92bd2c5b6c51b1217fb8afb441 /security
parent395759379d38c09f33f2035d57fca8677ac85e62 (diff)
downloadfreebsd-ports-gnome-0e8a2826207116ae08646250cc65d71c2cc60688.tar.gz
freebsd-ports-gnome-0e8a2826207116ae08646250cc65d71c2cc60688.tar.zst
freebsd-ports-gnome-0e8a2826207116ae08646250cc65d71c2cc60688.zip
add hashish 0.4b
A file and string hashing utility
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/hashish/Makefile34
-rw-r--r--security/hashish/distinfo1
-rw-r--r--security/hashish/pkg-comment1
-rw-r--r--security/hashish/pkg-descr4
-rw-r--r--security/hashish/pkg-plist1
6 files changed, 42 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index ddb5e17ac343..bc5c01c9250a 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -61,6 +61,7 @@
SUBDIR += gpgme
SUBDIR += gtk-knocker
SUBDIR += gtkportscan
+ SUBDIR += hashish
SUBDIR += heimdal
SUBDIR += hlfl
SUBDIR += hping
diff --git a/security/hashish/Makefile b/security/hashish/Makefile
new file mode 100644
index 000000000000..5369a5792c3c
--- /dev/null
+++ b/security/hashish/Makefile
@@ -0,0 +1,34 @@
+# ex:ts=8
+# Ports collection makefile for: hashish
+# Date Created: May 7, 2002
+# Whom: ijliao
+#
+# $FreeBSD$
+#
+
+PORTNAME= hashish
+PORTVERSION= 0.4b
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
+ http://www4.ncsu.edu/~jllovela/
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-beta-0.4-src
+
+MAINTAINER= ports@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libcryptopp.a:${PORTSDIR}/security/cryptopp
+LIB_DEPENDS= wx_gtk:${PORTSDIR}/x11-toolkits/wxgtk-devel
+
+WRKSRC= ${WRKDIR}/Hashish
+CFLAGS+= -I${LOCALBASE}/include
+USE_GMAKE= yes
+
+post-patch:
+ @${PERL} -pi -e "s,^CXXFLAGS =,CXXFLAGS+=,g ; \
+ s,^LBLIBS =,LBLIBS = -L${LOCALBASE}/lib,g" ${WRKSRC}/Makefile
+ @${PERL} -pi -e "s,crypto/,cryptopp/,g" ${WRKSRC}/src/main.cpp
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/hashish ${PREFIX}/bin
+
+.include <bsd.port.mk>
diff --git a/security/hashish/distinfo b/security/hashish/distinfo
new file mode 100644
index 000000000000..2510b0493c6d
--- /dev/null
+++ b/security/hashish/distinfo
@@ -0,0 +1 @@
+MD5 (hashish-beta-0.4-src.tar.gz) = 318a2ee1490e2cb35a8420e574356159
diff --git a/security/hashish/pkg-comment b/security/hashish/pkg-comment
new file mode 100644
index 000000000000..2d569e849db4
--- /dev/null
+++ b/security/hashish/pkg-comment
@@ -0,0 +1 @@
+A file and string hashing utility
diff --git a/security/hashish/pkg-descr b/security/hashish/pkg-descr
new file mode 100644
index 000000000000..45887e5f7257
--- /dev/null
+++ b/security/hashish/pkg-descr
@@ -0,0 +1,4 @@
+Hashish is a file and string hashing utility that computes cryptograhpic
+hashes. It is cross platform and includes a gui front end.
+
+WWW: http://hashish.sourceforge.net/
diff --git a/security/hashish/pkg-plist b/security/hashish/pkg-plist
new file mode 100644
index 000000000000..2fbc673401a6
--- /dev/null
+++ b/security/hashish/pkg-plist
@@ -0,0 +1 @@
+bin/hashish