aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2011-07-26 04:03:10 +0800
committermandree <mandree@FreeBSD.org>2011-07-26 04:03:10 +0800
commit1641a21be2298ea616b4efcce9cc83bbb152ff2b (patch)
treeba0f040a6f2d703fc2532ebcf35aa8dda836aec6 /security
parent1925459b1f48faec146526018a3ee2be7e8e78f3 (diff)
downloadfreebsd-ports-gnome-1641a21be2298ea616b4efcce9cc83bbb152ff2b.tar.gz
freebsd-ports-gnome-1641a21be2298ea616b4efcce9cc83bbb152ff2b.tar.zst
freebsd-ports-gnome-1641a21be2298ea616b4efcce9cc83bbb152ff2b.zip
Move LICENSE= up into a block of its own to silence portlint.
Remove the lzo/lzo2 version switch now that we only have lzo2. Approved by: ecrist@secure-computing.net (maintainer)
Diffstat (limited to 'security')
-rw-r--r--security/openvpn-devel/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/security/openvpn-devel/Makefile b/security/openvpn-devel/Makefile
index a92926064c97..24e69fce04f9 100644
--- a/security/openvpn-devel/Makefile
+++ b/security/openvpn-devel/Makefile
@@ -15,9 +15,10 @@ PKGNAMESUFFIX= -devel
MAINTAINER= ecrist@secure-computing.net
COMMENT= Secure IP/Ethernet tunnel daemon
-WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX}
LICENSE= GPLv2
+WRKSRC= ${WRKDIR}/${PORTNAME}${PKGNAMESUFFIX}
+
CONFLICTS= openvpn-2.0* openvpn-beta-[0-9]*
GNU_CONFIGURE= yes
@@ -27,6 +28,8 @@ CONFIGURE_ARGS= --with-lzo-lib=${LOCALBASE}/lib \
--disable-depr-random-resolv
INSTALL_TARGET= install mandir=${MANPREFIX}/man
+LIB_DEPENDS+= lzo2.2:${PORTSDIR}/archivers/lzo2
+
MAN8= openvpn.8
OPTIONS= PW_SAVE "Interactive passwords may be read from a file" off \
@@ -56,16 +59,6 @@ pre-fetch:
@${ECHO} ""
.endif
-# NOTE: there is no way to explicitly specify the LZO version to OpenVPN,
-# if LZO2 and LZO1 are installed, OpenVPN will pick LZO2.
-# So depend on LZO1 only if it's already there and LZO2 isn't.
-# PACKAGE_BUILDING will also force LZO2.
-.if exists(${LOCALBASE}/lib/liblzo2.so.2) || !exists(${LOCALBASE}/lib/liblzo.so.1) || defined(PACKAGE_BUILDING)
-LIB_DEPENDS+= lzo2.2:${PORTSDIR}/archivers/lzo2
-.else
-LIB_DEPENDS+= lzo.1:${PORTSDIR}/archivers/lzo
-.endif
-
.if defined(WITH_PW_SAVE)
CONFIGURE_ARGS+= --enable-password-save
.endif