aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorswills <swills@FreeBSD.org>2011-07-04 09:30:57 +0800
committerswills <swills@FreeBSD.org>2011-07-04 09:30:57 +0800
commit2a5a907a0538a9a35289cb7120250c1bc2cff4f8 (patch)
tree6606421431dceb51f64eace3dc4d094091ef2e78 /security
parent7941cbc2c51ecb74c82f90a75ee1f1966556ec4f (diff)
downloadfreebsd-ports-gnome-2a5a907a0538a9a35289cb7120250c1bc2cff4f8.tar.gz
freebsd-ports-gnome-2a5a907a0538a9a35289cb7120250c1bc2cff4f8.tar.zst
freebsd-ports-gnome-2a5a907a0538a9a35289cb7120250c1bc2cff4f8.zip
- Deprecate ports that don't work with Ruby 1.9 (volunteers welcome)
Approved by: ruby@ (pgollucci)
Diffstat (limited to 'security')
-rw-r--r--security/ruby-aes/Makefile3
-rw-r--r--security/ruby-blowfish/Makefile3
-rw-r--r--security/ruby-cast_256/Makefile3
-rw-r--r--security/ruby-mcrypt/Makefile3
-rw-r--r--security/ruby-pam/Makefile3
5 files changed, 15 insertions, 0 deletions
diff --git a/security/ruby-aes/Makefile b/security/ruby-aes/Makefile
index 8cd6ca20c38a..a9477e359f61 100644
--- a/security/ruby-aes/Makefile
+++ b/security/ruby-aes/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby extension library which implements AES (Rijndael) encryption
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/security/ruby-blowfish/Makefile b/security/ruby-blowfish/Makefile
index 8541bd96e7a2..1146b47dadc2 100644
--- a/security/ruby-blowfish/Makefile
+++ b/security/ruby-blowfish/Makefile
@@ -17,6 +17,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby interface to the Blowfish cipher
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_OPENSSL= yes
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/security/ruby-cast_256/Makefile b/security/ruby-cast_256/Makefile
index 4a243f2a2009..02718ec232d5 100644
--- a/security/ruby-cast_256/Makefile
+++ b/security/ruby-cast_256/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby extension library which implements CAST-256 encryption
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_ZIP= yes
USE_RUBY= yes
diff --git a/security/ruby-mcrypt/Makefile b/security/ruby-mcrypt/Makefile
index 1268d24881ce..f046eeda807f 100644
--- a/security/ruby-mcrypt/Makefile
+++ b/security/ruby-mcrypt/Makefile
@@ -17,6 +17,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= A Ruby interface to the mcrypt library
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
LIB_DEPENDS= mcrypt.8:${PORTSDIR}/security/libmcrypt/
USE_RUBY= yes
diff --git a/security/ruby-pam/Makefile b/security/ruby-pam/Makefile
index 9febd4f4146d..653f5047a685 100644
--- a/security/ruby-pam/Makefile
+++ b/security/ruby-pam/Makefile
@@ -16,6 +16,9 @@ DIST_SUBDIR= ruby
MAINTAINER= ruby@FreeBSD.org
COMMENT= Ruby extension to use PAM library
+DEPRECATED= Doesn't work with Ruby 1.9
+EXPIRATION_DATE= 2011-08-03
+
USE_RUBY= yes
USE_RUBY_EXTCONF= yes