aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-01-04 07:26:47 +0800
committerwill <will@FreeBSD.org>2001-01-04 07:26:47 +0800
commit8a9848a879307d8f7905de889b34a75adec4ae53 (patch)
treec5bf59d73ab8b1f67105d7c1e009925217b9b684 /security
parentb3d8c00d379e9784da3e239091c3ee42aa1bedf4 (diff)
downloadfreebsd-ports-gnome-8a9848a879307d8f7905de889b34a75adec4ae53.tar.gz
freebsd-ports-gnome-8a9848a879307d8f7905de889b34a75adec4ae53.tar.zst
freebsd-ports-gnome-8a9848a879307d8f7905de889b34a75adec4ae53.zip
Add p5-Crypt-TripleDES 0.24, perl module implementing the Triple-DES
cipher.
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Crypt-TripleDES/Makefile23
-rw-r--r--security/p5-Crypt-TripleDES/distinfo1
-rw-r--r--security/p5-Crypt-TripleDES/pkg-comment1
-rw-r--r--security/p5-Crypt-TripleDES/pkg-descr4
-rw-r--r--security/p5-Crypt-TripleDES/pkg-plist4
6 files changed, 34 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 992346d1bb6a..4218035aaa7c 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -81,6 +81,7 @@
SUBDIR += p5-Crypt-IDEA
SUBDIR += p5-Crypt-Rijndael
SUBDIR += p5-Crypt-SSLeay
+ SUBDIR += p5-Crypt-TripleDES
SUBDIR += p5-Digest-MD5
SUBDIR += p5-GnuPG-Interface
SUBDIR += p5-IO-Socket-SSL
diff --git a/security/p5-Crypt-TripleDES/Makefile b/security/p5-Crypt-TripleDES/Makefile
new file mode 100644
index 000000000000..1fe1d23a597d
--- /dev/null
+++ b/security/p5-Crypt-TripleDES/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: Crypt-TripleDES
+# Date created: Wed Jan 3 16:20:30 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Crypt-TripleDES
+PORTVERSION= 0.24
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Crypt
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Crypt::TripleDES.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Crypt-TripleDES/distinfo b/security/p5-Crypt-TripleDES/distinfo
new file mode 100644
index 000000000000..7e85d62a7fbe
--- /dev/null
+++ b/security/p5-Crypt-TripleDES/distinfo
@@ -0,0 +1 @@
+MD5 (Crypt-TripleDES-0.24.tar.gz) = 90b562175a8f6c5f6bc3eacaddffbcde
diff --git a/security/p5-Crypt-TripleDES/pkg-comment b/security/p5-Crypt-TripleDES/pkg-comment
new file mode 100644
index 000000000000..701799076cc7
--- /dev/null
+++ b/security/p5-Crypt-TripleDES/pkg-comment
@@ -0,0 +1 @@
+Perl module implementing the Triple-DES cipher
diff --git a/security/p5-Crypt-TripleDES/pkg-descr b/security/p5-Crypt-TripleDES/pkg-descr
new file mode 100644
index 000000000000..d990bc0d1aae
--- /dev/null
+++ b/security/p5-Crypt-TripleDES/pkg-descr
@@ -0,0 +1,4 @@
+Crypt::TripleDES is a perl module implementing the Triple-DES (3DES)
+cipher. It is used via the crypt3() function.
+
+--will
diff --git a/security/p5-Crypt-TripleDES/pkg-plist b/security/p5-Crypt-TripleDES/pkg-plist
new file mode 100644
index 000000000000..a809fabd920a
--- /dev/null
+++ b/security/p5-Crypt-TripleDES/pkg-plist
@@ -0,0 +1,4 @@
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/PPDES.pm
+lib/perl5/site_perl/%%PERL_VER%%/Crypt/TripleDES.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/TripleDES/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Crypt/TripleDES