aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorsunpoet <sunpoet@FreeBSD.org>2011-10-03 10:52:02 +0800
committersunpoet <sunpoet@FreeBSD.org>2011-10-03 10:52:02 +0800
commit9d3e3a8d26df7abbbc61b59e76856a4c6d66c36b (patch)
treeed238ca0190825ed0df6ced7178c1fb53c1e3a4d /security
parent39fe6edf58764c875f87e4104286660a5055ed62 (diff)
downloadfreebsd-ports-gnome-9d3e3a8d26df7abbbc61b59e76856a4c6d66c36b.tar.gz
freebsd-ports-gnome-9d3e3a8d26df7abbbc61b59e76856a4c6d66c36b.tar.zst
freebsd-ports-gnome-9d3e3a8d26df7abbbc61b59e76856a4c6d66c36b.zip
- Add p5-App-Genpass 2.10
If you've ever needed to create 10 (or even 10,000) passwords on the fly with varying preferences (lowercase, uppercase, no confusing characters, special characters, minimum length, etc.), you know it can become a pretty pesky task. This module makes it possible to create flexible and secure passwords, quickly and easily. WWW: http://search.cpan.org/dist/App-Genpass/
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-App-Genpass/Makefile40
-rw-r--r--security/p5-App-Genpass/distinfo2
-rw-r--r--security/p5-App-Genpass/pkg-descr8
-rw-r--r--security/p5-App-Genpass/pkg-plist6
5 files changed, 57 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index a9382514bdb1..1c24e40945d7 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -351,6 +351,7 @@
SUBDIR += outguess
SUBDIR += p11-kit
SUBDIR += p5-Apache-Htpasswd
+ SUBDIR += p5-App-Genpass
SUBDIR += p5-Auth-YubikeyDecrypter
SUBDIR += p5-AuthCAS
SUBDIR += p5-Authen-Bitcard
diff --git a/security/p5-App-Genpass/Makefile b/security/p5-App-Genpass/Makefile
new file mode 100644
index 000000000000..cc2115a06246
--- /dev/null
+++ b/security/p5-App-Genpass/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: p5-App-Genpass
+# Date created: 2011-10-03
+# Whom: Sunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= App-Genpass
+PORTVERSION= 2.10
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= sunpoet@FreeBSD.org
+COMMENT= Quickly and easily create secure passwords
+
+BUILD_DEPENDS= p5-Config-Any>=0:${PORTSDIR}/devel/p5-Config-Any \
+ p5-File-HomeDir>=0:${PORTSDIR}/devel/p5-File-HomeDir \
+ p5-List-AllUtils>=0:${PORTSDIR}/devel/p5-List-AllUtils \
+ p5-Mouse>=0:${PORTSDIR}/devel/p5-Mouse \
+ p5-MouseX-ConfigFromFile>=0:${PORTSDIR}/devel/p5-MouseX-ConfigFromFile \
+ p5-MouseX-Getopt>=0:${PORTSDIR}/devel/p5-MouseX-Getopt \
+ p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
+ p5-namespace-autoclean>=0:${PORTSDIR}/devel/p5-namespace-autoclean \
+ p5-namespace-clean>=0.20:${PORTSDIR}/devel/p5-namespace-clean
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+TEST_DEPENDS= p5-List-MoreUtils>=0:${PORTSDIR}/lang/p5-List-MoreUtils \
+ p5-Test-Deep>=0:${PORTSDIR}/devel/p5-Test-Deep
+
+PERL_CONFIGURE= yes
+REINPLACE_ARGS= -i ''
+
+MAN1= genpass.1
+MAN3= App::Genpass.3
+
+post-patch:
+ @${REINPLACE_CMD} -e '1 s|.*|#!${PERL}|' ${WRKSRC}/bin/genpass
+
+.include <bsd.port.mk>
diff --git a/security/p5-App-Genpass/distinfo b/security/p5-App-Genpass/distinfo
new file mode 100644
index 000000000000..f41797ec1baf
--- /dev/null
+++ b/security/p5-App-Genpass/distinfo
@@ -0,0 +1,2 @@
+SHA256 (App-Genpass-2.10.tar.gz) = 4aeb0c0b8735b258a48fe1240029dc050b6428455921427c0eb4df4a5c99a28e
+SIZE (App-Genpass-2.10.tar.gz) = 19380
diff --git a/security/p5-App-Genpass/pkg-descr b/security/p5-App-Genpass/pkg-descr
new file mode 100644
index 000000000000..580b46354942
--- /dev/null
+++ b/security/p5-App-Genpass/pkg-descr
@@ -0,0 +1,8 @@
+If you've ever needed to create 10 (or even 10,000) passwords on the fly with
+varying preferences (lowercase, uppercase, no confusing characters, special
+characters, minimum length, etc.), you know it can become a pretty pesky task.
+
+This module makes it possible to create flexible and secure passwords, quickly
+and easily.
+
+WWW: http://search.cpan.org/dist/App-Genpass/
diff --git a/security/p5-App-Genpass/pkg-plist b/security/p5-App-Genpass/pkg-plist
new file mode 100644
index 000000000000..f8d5ea4141df
--- /dev/null
+++ b/security/p5-App-Genpass/pkg-plist
@@ -0,0 +1,6 @@
+bin/genpass
+%%SITE_PERL%%/App/Genpass.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/App/Genpass/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/App/Genpass
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/App
+@dirrmtry %%SITE_PERL%%/App