aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authornectar <nectar@FreeBSD.org>2001-04-20 00:47:38 +0800
committernectar <nectar@FreeBSD.org>2001-04-20 00:47:38 +0800
commitac08a5235ef40eb19d713e88aeb920ce90576b75 (patch)
tree150b33b31da57bb6de77d8b0d10cedfc997d3bd7 /security
parent91a7186a7b96319cb6121c80bc32c0bff287da5d (diff)
downloadfreebsd-ports-gnome-ac08a5235ef40eb19d713e88aeb920ce90576b75.tar.gz
freebsd-ports-gnome-ac08a5235ef40eb19d713e88aeb920ce90576b75.tar.zst
freebsd-ports-gnome-ac08a5235ef40eb19d713e88aeb920ce90576b75.zip
Fix an uninitialized pointer dereference in krb5_rd_cred.
Diffstat (limited to 'security')
-rw-r--r--security/heimdal/Makefile1
-rw-r--r--security/heimdal/files/patch-cq10
2 files changed, 11 insertions, 0 deletions
diff --git a/security/heimdal/Makefile b/security/heimdal/Makefile
index 36518258c415..b607de59cc80 100644
--- a/security/heimdal/Makefile
+++ b/security/heimdal/Makefile
@@ -7,6 +7,7 @@
PORTNAME= heimdal
PORTVERSION= 0.3e
+PORTREVISION= 1
CATEGORIES= security ipv6
MASTER_SITES= ftp://ftp.pdc.kth.se/pub/heimdal/src/ \
ftp://ftp.replay.com/pub/replay/crypto/APPS/kerberos/heimdal/ \
diff --git a/security/heimdal/files/patch-cq b/security/heimdal/files/patch-cq
new file mode 100644
index 000000000000..c15e71806b7e
--- /dev/null
+++ b/security/heimdal/files/patch-cq
@@ -0,0 +1,10 @@
+--- lib/krb5/rd_cred.c.orig Tue Apr 17 16:03:58 2001
++++ lib/krb5/rd_cred.c Tue Apr 17 16:05:16 2001
+@@ -50,6 +50,7 @@
+ krb5_crypto crypto;
+ int i;
+
++ *ret_creds = NULL;
+ ret = decode_KRB_CRED(in_data->data, in_data->length,
+ &cred, &len);
+ if(ret)