aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorscrappy <scrappy@FreeBSD.org>2000-10-28 08:23:12 +0800
committerscrappy <scrappy@FreeBSD.org>2000-10-28 08:23:12 +0800
commitc1c9c510815cdcf9fd0dfada11add45c3dfe6a7d (patch)
tree749d50b7f4cf2b6cd6fde2bea2e4f6651518ef40 /security
parent1b6630e4322d9d242de22dea091dde372cdefb33 (diff)
downloadfreebsd-ports-gnome-c1c9c510815cdcf9fd0dfada11add45c3dfe6a7d.tar.gz
freebsd-ports-gnome-c1c9c510815cdcf9fd0dfada11add45c3dfe6a7d.tar.zst
freebsd-ports-gnome-c1c9c510815cdcf9fd0dfada11add45c3dfe6a7d.zip
IO::Socket::SSL is a class implementing an object oriented
interface to SSL sockets. The class is a descendent of IO::Socket::INET and provides a subset of the base class's interface methods.
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-IO-Socket-SSL/Makefile29
-rw-r--r--security/p5-IO-Socket-SSL/distinfo1
-rw-r--r--security/p5-IO-Socket-SSL/pkg-comment1
-rw-r--r--security/p5-IO-Socket-SSL/pkg-descr4
-rw-r--r--security/p5-IO-Socket-SSL/pkg-plist3
6 files changed, 39 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index a988f88d5361..a97d6ccaf433 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -70,6 +70,7 @@
SUBDIR += p5-Crypt-IDEA
SUBDIR += p5-Digest-MD5
SUBDIR += p5-GnuPG-Interface
+ SUBDIR += p5-IO-Socket-SSL
SUBDIR += p5-MD5
SUBDIR += p5-Net-SSLeay
SUBDIR += p5-PGP
diff --git a/security/p5-IO-Socket-SSL/Makefile b/security/p5-IO-Socket-SSL/Makefile
new file mode 100644
index 000000000000..f49c2ba3e10f
--- /dev/null
+++ b/security/p5-IO-Socket-SSL/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: p5-IO-Socket-SSL
+# Date created: October 27th 2000
+# Whom: Marc G. Fournier <scrappy@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= IO-Socket-SSL
+PORTVERSION= 0.75
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= IO
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= scrappy@FreeBSD.org
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/Net/SSLeay.pm:${PORTSDIR}/security/p5-Net-SSLeay
+
+RESTRICTED= "Crypto; export-controlled"
+
+USE_PERL5= yes
+
+$MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+$MAN3= IO::Socket::SSL.3
+
+do-configure:
+ @ cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/security/p5-IO-Socket-SSL/distinfo b/security/p5-IO-Socket-SSL/distinfo
new file mode 100644
index 000000000000..5323764ad937
--- /dev/null
+++ b/security/p5-IO-Socket-SSL/distinfo
@@ -0,0 +1 @@
+MD5 (IO-Socket-SSL-0.75.tar.gz) = 222d1cd2da03f8e93e7283975b5ac173
diff --git a/security/p5-IO-Socket-SSL/pkg-comment b/security/p5-IO-Socket-SSL/pkg-comment
new file mode 100644
index 000000000000..2c90f3e8bb98
--- /dev/null
+++ b/security/p5-IO-Socket-SSL/pkg-comment
@@ -0,0 +1 @@
+Perl5 interface to SSL sockets
diff --git a/security/p5-IO-Socket-SSL/pkg-descr b/security/p5-IO-Socket-SSL/pkg-descr
new file mode 100644
index 000000000000..22c9fc221c05
--- /dev/null
+++ b/security/p5-IO-Socket-SSL/pkg-descr
@@ -0,0 +1,4 @@
+IO::Socket::SSL is a class implementing an object oriented
+interface to SSL sockets. The class is a descendent of
+IO::Socket::INET and provides a subset of the base class's
+interface methods.
diff --git a/security/p5-IO-Socket-SSL/pkg-plist b/security/p5-IO-Socket-SSL/pkg-plist
new file mode 100644
index 000000000000..6bafbeaed36c
--- /dev/null
+++ b/security/p5-IO-Socket-SSL/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/IO/Socket/SSL.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Socket/SSL/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/IO/Socket/SSL