aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorrm <rm@FreeBSD.org>2012-12-02 21:11:25 +0800
committerrm <rm@FreeBSD.org>2012-12-02 21:11:25 +0800
commitfc7328baf9bfbd20ba6f36945063e3e48e25bbb9 (patch)
treedf306c4313f48cb90ae1fb75862e7bb35b9f23ce /security
parent7e2496d5f7bacbb430301aeb054259b591984c8d (diff)
downloadfreebsd-ports-gnome-fc7328baf9bfbd20ba6f36945063e3e48e25bbb9.tar.gz
freebsd-ports-gnome-fc7328baf9bfbd20ba6f36945063e3e48e25bbb9.tar.zst
freebsd-ports-gnome-fc7328baf9bfbd20ba6f36945063e3e48e25bbb9.zip
- pass maintainership to submitter
- add license (GPLv2) - add desktop icon and make .desktop file - update WWW while here: - trim Makefile header - remove Author filed from pkg-descr PR: 173978 Submitted by: nemysis <nemysis@gmx.ch> Feature safe: yes
Diffstat (limited to 'security')
-rw-r--r--security/secpanel/Makefile30
-rw-r--r--security/secpanel/distinfo6
-rw-r--r--security/secpanel/pkg-descr3
-rw-r--r--security/secpanel/pkg-plist3
4 files changed, 26 insertions, 16 deletions
diff --git a/security/secpanel/Makefile b/security/secpanel/Makefile
index bc8afcd58b9f..f2b9594e6d47 100644
--- a/security/secpanel/Makefile
+++ b/security/secpanel/Makefile
@@ -1,20 +1,23 @@
-# New ports collection makefile for: secpanel
-# Date created: 11 June 2001
-# Whom: Pete Fritchman <petef@databits.net>
-#
+# Created by: Pete Fritchman <petef@databits.net>
# $FreeBSD$
-#
PORTNAME= secpanel
PORTVERSION= 0.6.1
+PORTREVISION= 1
PORTEPOCH= 1
CATEGORIES= security tcl tk
-MASTER_SITES= SF/${PORTNAME}
-EXTRACT_SUFX= .tgz
-
-MAINTAINER= ports@FreeBSD.org
+MASTER_SITES= SF/${PORTNAME} \
+ SF/nemysisfreebsdp/:icons
+DISTFILES= ${PORTNAME}-${PORTVERSION}.tgz \
+ ${PORTNAME}.png:icons
+DIST_SUBDIR= ${PORTNAME}
+EXTRACT_ONLY= ${PORTNAME}-${PORTVERSION}.tgz
+
+MAINTAINER= nemysis@gmx.ch
COMMENT= GUI for managing and running ssh and related utilities
+LICENSE= GPLv2
+
RUN_DEPENDS= ssh-askpass:${PORTSDIR}/security/openssh-askpass
WRKSRC= ${WRKDIR}/usr/local
@@ -22,14 +25,19 @@ NO_BUILD= yes
USE_TK_WRAPPER= yes
+DESKTOP_ENTRIES="SecPanel" "${COMMENT}" "${PORTNAME}" \
+ "${PORTNAME}" "Application;System;" ${FALSE}
+
post-patch:
@${REINPLACE_CMD} \
- -e 's!\[file dirname \[info script\]\]/../lib/secpanel!${DATADIR}!' \
+ -e 's|\[file dirname \[info script\]\]/../lib/secpanel|${DATADIR}|' \
${WRKSRC}/bin/secpanel
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/bin/secpanel ${PREFIX}/bin
- @(cd ${WRKSRC}/lib/secpanel && ${COPYTREE_SHARE} . ${DATADIR})
+ @(cd ${WRKSRC}/lib/secpanel && ${COPYTREE_SHARE} \* ${DATADIR})
@${CHMOD} u+rw ${DATADIR}/default.config
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/${PORTNAME}.png ${PREFIX}/share/pixmaps
+
.include <bsd.port.mk>
diff --git a/security/secpanel/distinfo b/security/secpanel/distinfo
index 7a149cf1dd35..3b63628879f6 100644
--- a/security/secpanel/distinfo
+++ b/security/secpanel/distinfo
@@ -1,2 +1,4 @@
-SHA256 (secpanel-0.6.1.tgz) = d70a0e7fe3f0d64b4fd6e9d9bd726999e72b367705e28a2980d94a5d45e1bbb7
-SIZE (secpanel-0.6.1.tgz) = 51417
+SHA256 (secpanel/secpanel-0.6.1.tgz) = d70a0e7fe3f0d64b4fd6e9d9bd726999e72b367705e28a2980d94a5d45e1bbb7
+SIZE (secpanel/secpanel-0.6.1.tgz) = 51417
+SHA256 (secpanel/secpanel.png) = f2950c8ba2cb4059330ec9e27b4e2df6bf1c9613843afca9defbf18326da4f22
+SIZE (secpanel/secpanel.png) = 1543
diff --git a/security/secpanel/pkg-descr b/security/secpanel/pkg-descr
index 87c79d1a4c1c..45e67b3e041e 100644
--- a/security/secpanel/pkg-descr
+++ b/security/secpanel/pkg-descr
@@ -3,5 +3,4 @@ and SCP (Secure Copy) connections. Nearly all connection-parameters
are adjusted by one mouseclick (compression, port-forwarding, etc.).
It also manages the SSH-agent.
-Author: Steffen Leich <steffen.leich _at_ gmail.com>
-WWW: http://secpanel.net/
+WWW: http://themediahost.de/secpanel/
diff --git a/security/secpanel/pkg-plist b/security/secpanel/pkg-plist
index f0425a8741fc..0c40774e88be 100644
--- a/security/secpanel/pkg-plist
+++ b/security/secpanel/pkg-plist
@@ -1,4 +1,5 @@
bin/secpanel
+share/pixmaps/secpanel.png
%%DATADIR%%/convert_history.tcl
%%DATADIR%%/convert_profile.tcl
%%DATADIR%%/default.config
@@ -16,7 +17,7 @@ bin/secpanel
%%DATADIR%%/images/swinback_gr.gif
%%DATADIR%%/secpanel.wait
%%DATADIR%%/secpanel_remoteconf.sh
-%%DATADIR%%/termdefs.txt
%%DATADIR%%/spdistkey
+%%DATADIR%%/termdefs.txt
@dirrm %%DATADIR%%/images
@dirrm %%DATADIR%%