aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2007-09-09 08:26:25 +0800
committeredwin <edwin@FreeBSD.org>2007-09-09 08:26:25 +0800
commit10a3b84ef83b48820f504f31065ca44188263b3c (patch)
tree1131794e03bcebdbda8d5cc76b720b8b527e182f /security
parentef98f54cf9bfa0050d96786132a572f37b2f50d1 (diff)
downloadfreebsd-ports-gnome-10a3b84ef83b48820f504f31065ca44188263b3c.tar.gz
freebsd-ports-gnome-10a3b84ef83b48820f504f31065ca44188263b3c.tar.zst
freebsd-ports-gnome-10a3b84ef83b48820f504f31065ca44188263b3c.zip
Add fix for compilation problems as suggested at
http://point-at-infinity.org/ssss/ Noticed by: YAPHR
Diffstat (limited to 'security')
-rw-r--r--security/ssss/Makefile1
-rw-r--r--security/ssss/files/patch-ssss.c11
2 files changed, 12 insertions, 0 deletions
diff --git a/security/ssss/Makefile b/security/ssss/Makefile
index d476477fa286..28e72ba74b2f 100644
--- a/security/ssss/Makefile
+++ b/security/ssss/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ssss
PORTVERSION= 0.5
+PORTREVISION= 1
CATEGORIES= security
MASTER_SITES= http://point-at-infinity.org/ssss/
diff --git a/security/ssss/files/patch-ssss.c b/security/ssss/files/patch-ssss.c
new file mode 100644
index 000000000000..5ff2714c3a23
--- /dev/null
+++ b/security/ssss/files/patch-ssss.c
@@ -0,0 +1,11 @@
+--- ssss.c.orig Sun Sep 9 10:24:42 2007
++++ ssss.c Sun Sep 9 10:24:48 2007
+@@ -348,7 +348,7 @@
+ #define MPZ_SWAP(A, B) \
+ do { mpz_set(h, A); mpz_set(A, B); mpz_set(B, h); } while(0)
+
+-int restore_secret(int n, mpz_t (*A)[n], mpz_t b[])
++int restore_secret(int n, void *A, mpz_t b[])
+ {
+ mpz_t (*AA)[n] = (mpz_t (*)[n])A;
+ int i, j, k, found;