aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoraz <az@FreeBSD.org>2013-08-05 23:05:29 +0800
committeraz <az@FreeBSD.org>2013-08-05 23:05:29 +0800
commit12549b30c2eef8132a2851d6f17e8c45a3491872 (patch)
tree6094da914716107bca7d35889c1b8aab5e6097c7 /security
parent7e71988ad884bca5467171d41d1f68fd7040697b (diff)
downloadfreebsd-ports-gnome-12549b30c2eef8132a2851d6f17e8c45a3491872.tar.gz
freebsd-ports-gnome-12549b30c2eef8132a2851d6f17e8c45a3491872.tar.zst
freebsd-ports-gnome-12549b30c2eef8132a2851d6f17e8c45a3491872.zip
- Convert to new perl framework
- Trim Makefile header Approved by: tobez@ (maintainer)
Diffstat (limited to 'security')
-rw-r--r--security/p5-Authen-Htpasswd/Makefile9
-rw-r--r--security/p5-Crypt-ECB/Makefile9
-rw-r--r--security/p5-Crypt-OpenPGP/Makefile3
-rw-r--r--security/p5-Crypt-PassGen/Makefile3
4 files changed, 10 insertions, 14 deletions
diff --git a/security/p5-Authen-Htpasswd/Makefile b/security/p5-Authen-Htpasswd/Makefile
index acf0c65225e6..38e03a575a11 100644
--- a/security/p5-Authen-Htpasswd/Makefile
+++ b/security/p5-Authen-Htpasswd/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: security/p5-Authen-Htpasswd
-# Date created: 11 November 2005
-# Whom: Anton Berezin <tobez@FreeBSD.org>
-#
+# Created by: Anton Berezin <tobez@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= Authen-Htpasswd
PORTVERSION= 0.171
@@ -22,7 +18,8 @@ COMMON_DEPENDS= p5-IO-LockedFile>=0:${PORTSDIR}/devel/p5-IO-LockedFile \
BUILD_DEPENDS= ${COMMON_DEPENDS}
RUN_DEPENDS= ${COMMON_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Authen::Htpasswd.3 \
Authen::Htpasswd::User.3 \
diff --git a/security/p5-Crypt-ECB/Makefile b/security/p5-Crypt-ECB/Makefile
index fc41228a0989..0be1dd51c886 100644
--- a/security/p5-Crypt-ECB/Makefile
+++ b/security/p5-Crypt-ECB/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Crypt-ECB
-# Date created: Wed Jan 3 16:09:46 2001
-# Whom: will
-#
+# Created by: will
# $FreeBSD$
-#
PORTNAME= Crypt-ECB
PORTVERSION= 1.45
@@ -14,7 +10,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Perl module implementing the ECB encryption algorithm
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::ECB.3
diff --git a/security/p5-Crypt-OpenPGP/Makefile b/security/p5-Crypt-OpenPGP/Makefile
index 6861ea0cb74d..7744af0686c0 100644
--- a/security/p5-Crypt-OpenPGP/Makefile
+++ b/security/p5-Crypt-OpenPGP/Makefile
@@ -27,7 +27,8 @@ RUN_DEPENDS= \
p5-libwww>=0:${PORTSDIR}/www/p5-libwww \
p5-URI>=0:${PORTSDIR}/net/p5-URI
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::OpenPGP::ErrorHandler.3 Crypt::OpenPGP::Key.3 \
Crypt::OpenPGP::CFB.3 Crypt::OpenPGP::SKSessionKey.3 \
diff --git a/security/p5-Crypt-PassGen/Makefile b/security/p5-Crypt-PassGen/Makefile
index 305abca83960..e54f5daef750 100644
--- a/security/p5-Crypt-PassGen/Makefile
+++ b/security/p5-Crypt-PassGen/Makefile
@@ -9,7 +9,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= tobez@FreeBSD.org
COMMENT= Crypt::PassGen - Generate a random password that looks like a real word
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= Crypt::PassGen.3