aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-09-26 22:36:23 +0800
committerkwm <kwm@FreeBSD.org>2015-09-26 22:36:23 +0800
commit26e024bbdbff43dece4e929f6104deec587ed50b (patch)
tree6e57fabcf96c9308178f83f5236aab5d8f1b0127 /security
parent4f5ebbd6dcc224be3e1964f0cd8ec898e31d3b69 (diff)
downloadfreebsd-ports-gnome-26e024bbdbff43dece4e929f6104deec587ed50b.tar.gz
freebsd-ports-gnome-26e024bbdbff43dece4e929f6104deec587ed50b.tar.zst
freebsd-ports-gnome-26e024bbdbff43dece4e929f6104deec587ed50b.zip
Update gstreamer1 ports to 1.6.0.
* gstreamer1-libav now uses ffmpeg from ports. * New ports: * gstreamer1-validate: Tools to detect if elements are not behaving as expected, mainly aimed at developers, or advanced debugging. * gstreamer1-rtsp-server: Base foundation for building a rtsp server ontop of GStreamer * Bunch of new plugins like: mpg123, rsvg, libde265, openh264, x265 and dtls. Release announcement: http://lists.freedesktop.org/archives/gstreamer-announce/2015-September/000357.html Obtained from: gnome devel repo
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/gstreamer1-plugins-dtls/Makefile18
2 files changed, 19 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index df4e04a8cfe9..a0572ee47edf 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -171,6 +171,7 @@
SUBDIR += gsasl
SUBDIR += gsfv
SUBDIR += gss
+ SUBDIR += gstreamer1-plugins-dtls
SUBDIR += gtk-knocker
SUBDIR += gtkpasman
SUBDIR += gwee
diff --git a/security/gstreamer1-plugins-dtls/Makefile b/security/gstreamer1-plugins-dtls/Makefile
new file mode 100644
index 000000000000..3a25177abdcb
--- /dev/null
+++ b/security/gstreamer1-plugins-dtls/Makefile
@@ -0,0 +1,18 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= security
+
+COMMENT= Gstreamer Datagram TLS (dtls) plugin
+
+GST_PLUGIN= dtls
+DIST= bad
+
+# we don't have a way to specify this in ${MASTERDIR}/Makefile.common
+USE_OPENSSL= yes
+CONFIGURE_ENV= DTLS_CFLAGS="-I${OPENSSLINC}" \
+ DTLS_LIBS="-L${OPENSSLLIB} -lcrypto -lssl"
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+
+.include "${MASTERDIR}/Makefile"