aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorgarga <garga@FreeBSD.org>2010-01-28 00:56:35 +0800
committergarga <garga@FreeBSD.org>2010-01-28 00:56:35 +0800
commit3fc8bde8886a44b70801edfbd748dcf33db344de (patch)
tree5c8c8d0d9b77050942bc9f80fecca4e91b2bd718 /security
parent33fc9f9c03e49fe9661160c375ca9321ea4d5a7b (diff)
downloadfreebsd-ports-gnome-3fc8bde8886a44b70801edfbd748dcf33db344de.tar.gz
freebsd-ports-gnome-3fc8bde8886a44b70801edfbd748dcf33db344de.tar.zst
freebsd-ports-gnome-3fc8bde8886a44b70801edfbd748dcf33db344de.zip
Execute a "make check" at post-build target, add libcheck as a dependency for it
Diffstat (limited to 'security')
-rw-r--r--security/clamav/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/security/clamav/Makefile b/security/clamav/Makefile
index 2eedf83eae5c..e42654611ac1 100644
--- a/security/clamav/Makefile
+++ b/security/clamav/Makefile
@@ -13,6 +13,8 @@ MASTER_SITES= SF
MAINTAINER= garga@FreeBSD.org
COMMENT= Command line virus scanner written entirely in C
+BUILD_DEPENDS= ${LOCALBASE}/include/check.h:${PORTSDIR}/devel/libcheck
+
OPTIONS= ARC "Enable arch archives support" On \
ARJ "Enable arj archives support" On \
LHA "Enable lha archives support" On \
@@ -47,6 +49,7 @@ CONFIGURE_ARGS= --libdir=${PREFIX}/lib \
--enable-bigstack \
--enable-readdir_r \
--enable-gethostbyname_r \
+ --enable-check \
--disable-dependency-tracking
CPPFLAGS+= -I${LOCALBASE}/include \
${PTHREAD_CFLAGS}
@@ -172,6 +175,9 @@ post-patch:
@${REINPLACE_CMD} -e 's|0x100000000|0x100000000ULL|g' \
${WRKSRC}/libclamunrar/unrar.c
+post-build:
+ @${MAKE} -C ${WRKSRC} check
+
pre-su-install:
@${SETENV} PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} PRE-INSTALL