aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2001-08-23 23:43:45 +0800
committerpetef <petef@FreeBSD.org>2001-08-23 23:43:45 +0800
commit5d3cee2daf1af234cef8468f329619cc10c99da0 (patch)
tree50dd36291eb5b77cf401eb3686b7baec7dd39f2c /security
parent219c943bd85c32b0978c6bbaa68d2aaab6d4bfd5 (diff)
downloadfreebsd-ports-gnome-5d3cee2daf1af234cef8468f329619cc10c99da0.tar.gz
freebsd-ports-gnome-5d3cee2daf1af234cef8468f329619cc10c99da0.tar.zst
freebsd-ports-gnome-5d3cee2daf1af234cef8468f329619cc10c99da0.zip
add p5-GPG 0.06
A Perl interface to GnuPG PR: 29658 Reviewed by: ade
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-GPG/Makefile28
-rw-r--r--security/p5-GPG/distinfo1
-rw-r--r--security/p5-GPG/pkg-comment1
-rw-r--r--security/p5-GPG/pkg-descr9
-rw-r--r--security/p5-GPG/pkg-plist3
6 files changed, 43 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index fdeabd90b0ba..b7c60d10fd75 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -118,6 +118,7 @@
SUBDIR += p5-Digest-MD2
SUBDIR += p5-Digest-MD5
SUBDIR += p5-Digest-SHA1
+ SUBDIR += p5-GPG
SUBDIR += p5-GnuPG-Interface
SUBDIR += p5-IO-Socket-SSL
SUBDIR += p5-MD5
diff --git a/security/p5-GPG/Makefile b/security/p5-GPG/Makefile
new file mode 100644
index 000000000000..495a345acb0c
--- /dev/null
+++ b/security/p5-GPG/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-GPG
+# Date created: 12 August 2001
+# Whom: petef
+#
+# $FreeBSD$
+#
+
+PORTNAME= GPG
+PORTVERSION= 0.06
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../../../authors/id/M/MI/MILES
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= petef@FreeBSD.org
+
+BUILD_DEPENDS= gpg:${PORTSDIR}/security/gnupg
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3PREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= GPG.3
+
+post-patch:
+ @${PERL} -pi -e 's,/usr/local,${LOCALBASE},' ${WRKSRC}/Makefile.PL
+
+.include <bsd.port.mk>
diff --git a/security/p5-GPG/distinfo b/security/p5-GPG/distinfo
new file mode 100644
index 000000000000..185de87d5db0
--- /dev/null
+++ b/security/p5-GPG/distinfo
@@ -0,0 +1 @@
+MD5 (GPG-0.06.tar.gz) = be78c7a9f0235bcd7d3d1391c8900cf6
diff --git a/security/p5-GPG/pkg-comment b/security/p5-GPG/pkg-comment
new file mode 100644
index 000000000000..ab38c14b82a4
--- /dev/null
+++ b/security/p5-GPG/pkg-comment
@@ -0,0 +1 @@
+A Perl interface to GnuPG
diff --git a/security/p5-GPG/pkg-descr b/security/p5-GPG/pkg-descr
new file mode 100644
index 000000000000..1a4009774f1c
--- /dev/null
+++ b/security/p5-GPG/pkg-descr
@@ -0,0 +1,9 @@
+GPG.pm is a Perl5 interface for using GnuPG. GPG works with $scalar
+(string), as opposed to the existing Perl5 modules (GnuPG.pm and
+GnuPG::Interface, which communicate with gnupg through filehandles
+or filenames).
+
+WWW: http://gpg.sourceforge.net/
+
+- Pete
+petef@FreeBSD.org
diff --git a/security/p5-GPG/pkg-plist b/security/p5-GPG/pkg-plist
new file mode 100644
index 000000000000..760ed2fe5c4e
--- /dev/null
+++ b/security/p5-GPG/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/GPG.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GPG/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/GPG