aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2003-09-27 09:01:08 +0800
committeredwin <edwin@FreeBSD.org>2003-09-27 09:01:08 +0800
commit66ad15aa9aa13d5cb48ca63a291e580966588856 (patch)
tree17d69b2c11abc331666ac7969bc3a84b07bba8ff /security
parent93fca8f6fe943e5bf9abe0b1e5aadad1db8b6551 (diff)
downloadfreebsd-ports-gnome-66ad15aa9aa13d5cb48ca63a291e580966588856.tar.gz
freebsd-ports-gnome-66ad15aa9aa13d5cb48ca63a291e580966588856.tar.zst
freebsd-ports-gnome-66ad15aa9aa13d5cb48ca63a291e580966588856.zip
KATO mega patch
- ECHO -> ECHO_MSG For some ports: - pre-fetch -> pre-everything - ECHO -> ECHO_CMD PR: ports/56820-56858 Submitted by: KATO Tsuguru <tkato@prontomail.com>
Diffstat (limited to 'security')
-rw-r--r--security/amavisd/Makefile6
-rw-r--r--security/p5-PGP-Sign/Makefile10
-rw-r--r--security/ssh/Makefile4
3 files changed, 10 insertions, 10 deletions
diff --git a/security/amavisd/Makefile b/security/amavisd/Makefile
index d2f61def113b..f39ac11c1587 100644
--- a/security/amavisd/Makefile
+++ b/security/amavisd/Makefile
@@ -86,9 +86,9 @@ post-install:
.for FILE in FAQ INSTALL README README.exim README.milter README.postfix README.qmail README.scanners README.sendmail doc/amavis.html doc/amavis.m4 doc/amavis.png doc/amavis.txt
${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
.endfor
- @${ECHO} "==============================================================================="
- @${ECHO} "Please read ${DOCSDIR}/README.${MTA}"
- @${ECHO} "==============================================================================="
+ @${ECHO_MSG} "==============================================================================="
+ @${ECHO_MSG} "Please read ${DOCSDIR}/README.${MTA}"
+ @${ECHO_MSG} "==============================================================================="
.endif
.include <bsd.port.mk>
diff --git a/security/p5-PGP-Sign/Makefile b/security/p5-PGP-Sign/Makefile
index e61dcf25265f..0e62136c8aa1 100644
--- a/security/p5-PGP-Sign/Makefile
+++ b/security/p5-PGP-Sign/Makefile
@@ -39,28 +39,28 @@ DEFAULTPGP= PGP2
RUN_DEPENDS= pgp:${PORTSDIR}/security/pgp
PGPSTYLE?= PGP2
.ifndef PGP
-PGP!= which pgp || ${ECHO} ${PREFIX}/bin/pgp
+PGP!= which pgp || ${ECHO_CMD} ${PREFIX}/bin/pgp
.endif
.elif (${DEFAULTPGP} == PGP5 )
RUN_DEPENDS= pgps:${PORTSDIR}/security/pgp5
PGPSTYLE?= PGP5
.ifndef PGPS
-PGPS!= which pgps || ${ECHO} ${PREFIX}/bin/pgps
+PGPS!= which pgps || ${ECHO_CMD} ${PREFIX}/bin/pgps
.endif
.ifndef PGPV
-PGPV!= which pgpv || ${ECHO} ${PREFIX}/bin/pgpv
+PGPV!= which pgpv || ${ECHO_CMD} ${PREFIX}/bin/pgpv
.endif
.elif (${DEFAULTPGP} == PGP6)
RUN_DEPENDS= pgp:${PORTSDIR}/security/pgp6
PGPSTYLE?= PGP6
.ifndef PGP
-PGP!= which pgp || ${ECHO} ${PREFIX}/bin/pgp
+PGP!= which pgp || ${ECHO_CMD} ${PREFIX}/bin/pgp
.endif
.elif (${DEFAULTPGP} == GPG)
RUN_DEPENDS= gpg:${PORTSDIR}/security/gnupg
PGPSTYLE?= GPG
.ifndef PGP
-PGP!= which gpg || ${ECHO} ${PREFIX}/bin/gpg
+PGP!= which gpg || ${ECHO_CMD} ${PREFIX}/bin/gpg
.endif
.else
.error Unsupported DEFAULTPGP value. See the Makefile for a list of acceptable values.
diff --git a/security/ssh/Makefile b/security/ssh/Makefile
index 4dd71f5405d6..7d2e70d21139 100644
--- a/security/ssh/Makefile
+++ b/security/ssh/Makefile
@@ -89,12 +89,12 @@ pre-patch:
post-install:
@if [ ! -f ${PREFIX}/etc/ssh_host_key ]; then \
- ${ECHO} "Generating a secret host key..."; \
+ ${ECHO_MSG} "Generating a secret host key..."; \
${PREFIX}/bin/ssh-keygen -f ${PREFIX}/etc/ssh_host_key -N ""; \
fi; \
if [ "`grep ssh /etc/inetd.conf|grep -v ^#ssh`" = "" ]; then \
if [ ! -f ${PREFIX}/etc/rc.d/sshd.sh ]; then \
- ${ECHO} "Installing ${PREFIX}/etc/rc.d/sshd.sh startup file."; \
+ ${ECHO_MSG} "Installing ${PREFIX}/etc/rc.d/sshd.sh startup file."; \
${SED} -e 's+!!PREFIX!!+${PREFIX}+g' ${FILESDIR}/sshd.sh \
> ${PREFIX}/etc/rc.d/sshd.sh; \
${CHMOD} 751 ${PREFIX}/etc/rc.d/sshd.sh; \