aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorache <ache@FreeBSD.org>2001-10-16 00:32:06 +0800
committerache <ache@FreeBSD.org>2001-10-16 00:32:06 +0800
commit8c94981b2ec360654c2ae4d7e534422afbdcd5a4 (patch)
tree06661c10b1273b26d0970420cfbea9a0f733cfa5 /security
parent190df7ce0476bd2b70246d66f518ca29efe5b4ae (diff)
downloadfreebsd-ports-gnome-8c94981b2ec360654c2ae4d7e534422afbdcd5a4.tar.gz
freebsd-ports-gnome-8c94981b2ec360654c2ae4d7e534422afbdcd5a4.tar.zst
freebsd-ports-gnome-8c94981b2ec360654c2ae4d7e534422afbdcd5a4.zip
Fix permissions, sendmail dislike group-writeable dirs
Diffstat (limited to 'security')
-rw-r--r--security/drweb/Makefile2
-rw-r--r--security/drweb/scripts/post-install4
2 files changed, 3 insertions, 3 deletions
diff --git a/security/drweb/Makefile b/security/drweb/Makefile
index bd70e2427ec1..104fd55e2109 100644
--- a/security/drweb/Makefile
+++ b/security/drweb/Makefile
@@ -20,7 +20,7 @@ NO_BUILD= YES
# Needed for update.pl
RUN_DEPENDS= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}/${PERL_ARCH}/String/CRC32.pm:${PORTSDIR}/devel/p5-String-CRC32
-SCRIPTS_ENV+= BINOWN=${BINOWN}
+SCRIPTS_ENV+= BINOWN=${BINOWN} BINGRP=${BINGRP}
DRWEB_PREFIX= ${PREFIX}/${PORTNAME}
diff --git a/security/drweb/scripts/post-install b/security/drweb/scripts/post-install
index 359ca82a221b..796b644ce5f3 100644
--- a/security/drweb/scripts/post-install
+++ b/security/drweb/scripts/post-install
@@ -28,6 +28,6 @@ if ! grep -q drweb /etc/crontab; then
echo ""
fi
[ "$ex" = "1" ] && exit 1
-install -dv -m 0775 -o ${BINOWN} -g drweb ${PREFIX}/drweb/run
-install -dv -m 0770 -o ${BINOWN} -g drweb ${PREFIX}/drweb/infected.!!!
+install -dv -m 0755 -o drweb -g ${BINGRP} ${PREFIX}/drweb/run
+install -dv -m 0700 -o drweb -g ${BINGRP} ${PREFIX}/drweb/infected.!!!
exit 0