aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorarved <arved@FreeBSD.org>2010-02-07 02:02:40 +0800
committerarved <arved@FreeBSD.org>2010-02-07 02:02:40 +0800
commitbb5f948dd1b692a8e6031d06fba535fd332e7c31 (patch)
tree41db05a41d32eaed22a26410129068689a814a9e /security
parent2ecb3187d3c44c461f1b124455c5d6e43ba311d3 (diff)
downloadfreebsd-ports-gnome-bb5f948dd1b692a8e6031d06fba535fd332e7c31.tar.gz
freebsd-ports-gnome-bb5f948dd1b692a8e6031d06fba535fd332e7c31.tar.zst
freebsd-ports-gnome-bb5f948dd1b692a8e6031d06fba535fd332e7c31.zip
Fix an unitialized variable, which may cause a warning message
Submitted by: Kevin Dorne Obtained from: Gentoo http://bugs.gentoo.org/260308
Diffstat (limited to 'security')
-rw-r--r--security/ssh_askpass_gtk2/Makefile2
-rw-r--r--security/ssh_askpass_gtk2/files/patch-ssh_askpass_fullscreen.c20
2 files changed, 21 insertions, 1 deletions
diff --git a/security/ssh_askpass_gtk2/Makefile b/security/ssh_askpass_gtk2/Makefile
index 7760d2a745a5..b01cdfd08ea3 100644
--- a/security/ssh_askpass_gtk2/Makefile
+++ b/security/ssh_askpass_gtk2/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ssh_askpass_gtk2
PORTVERSION= 0.4
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= security
MASTER_SITES= http://www.cgabriel.org/download/ssh-askpass-fullscreen/
DISTNAME= ssh-askpass-fullscreen-${PORTVERSION}
diff --git a/security/ssh_askpass_gtk2/files/patch-ssh_askpass_fullscreen.c b/security/ssh_askpass_gtk2/files/patch-ssh_askpass_fullscreen.c
new file mode 100644
index 000000000000..1fdbf1878602
--- /dev/null
+++ b/security/ssh_askpass_gtk2/files/patch-ssh_askpass_fullscreen.c
@@ -0,0 +1,20 @@
+--- ssh-askpass-fullscreen.c.orig 2006-01-16 04:49:38.000000000 -0800
++++ ssh-askpass-fullscreen.c 2010-02-04 22:30:32.000000000 -0800
+@@ -44,7 +44,7 @@
+ #include <gtk/gtk.h>
+
+ /* XPM */
+-static char *ocean_stripes[] = {
++static const char *ocean_stripes[] = {
+ /* columns rows colors chars-per-pixel */
+ "64 64 3 1",
+ " c #A0A9C1",
+@@ -247,7 +247,7 @@
+ GdkColor color;
+ gchar *str;
+ GdkGrabStatus status;
+- int grab_tries;
++ int grab_tries = 0;
+ const char *failed;
+
+ grab_server = (getenv("GNOME_SSH_ASKPASS_GRAB_SERVER") != NULL);