aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2010-01-13 01:54:03 +0800
committeritetcu <itetcu@FreeBSD.org>2010-01-13 01:54:03 +0800
commitbd998aa5bb5076faf5d4999d3a37dadd6af6a03e (patch)
treed7175e6ad802392f44cc0ab4034854d9b808b377 /security
parent28d94592a875d99c34dad4e68c6b331e91a6a3a4 (diff)
downloadfreebsd-ports-gnome-bd998aa5bb5076faf5d4999d3a37dadd6af6a03e.tar.gz
freebsd-ports-gnome-bd998aa5bb5076faf5d4999d3a37dadd6af6a03e.tar.zst
freebsd-ports-gnome-bd998aa5bb5076faf5d4999d3a37dadd6af6a03e.zip
- update to 2.1.0
- bumpo PORTEPOCH, sigh PR: 139841 Submitted by: Niels Heinen
Diffstat (limited to 'security')
-rw-r--r--security/nikto/Makefile26
-rw-r--r--security/nikto/distinfo6
-rw-r--r--security/nikto/pkg-plist33
3 files changed, 47 insertions, 18 deletions
diff --git a/security/nikto/Makefile b/security/nikto/Makefile
index a846b70955fa..ed57b6ade066 100644
--- a/security/nikto/Makefile
+++ b/security/nikto/Makefile
@@ -8,7 +8,8 @@
#
PORTNAME= nikto
-PORTVERSION= 2.03
+PORTVERSION= 2.1.0
+PORTEPOCH= 1
CATEGORIES= security www
MASTER_SITES= http://www.cirt.net/${PORTNAME}/ \
http://www.mirrors.wiretapped.net/security/vulnerability-assessment/${PORTNAME}/ \
@@ -17,12 +18,12 @@ MASTER_SITES= http://www.cirt.net/${PORTNAME}/ \
MAINTAINER= itetcu@FreeBSD.org
COMMENT= Web and CGI vulnerability scanner with SSL support
+MAN1= nikto.1
+
USE_BZIP2= yes
USE_PERL5_RUN= yes
NO_BUILD= yes
-WRKSRC= ${WRKDIR}/${PORTNAME}
-
PORTDOCS= CHANGES.txt LICENSE.txt nikto_manual.html
OPTIONS+= SSLEAY "Use NET::SSLeay for ssl scanning" on
@@ -40,27 +41,28 @@ RUN_DEPENEDS+= nmap:${PORTSDIR}/security/nmap
post-patch:
@${REINPLACE_CMD} -e "s|/usr/local/bin/perl|${PERL}|" ${WRKSRC}/nikto.pl
- @${REINPLACE_CMD} -Ee "s,(config.txt),${PREFIX}/etc/nikto.conf," ${WRKSRC}/nikto.pl
+ @${REINPLACE_CMD} -e "s|/etc/nikto.conf|${PREFIX}/etc/nikto.conf|" ${WRKSRC}/nikto.pl
@${REINPLACE_CMD} -Ee "s|/usr/bin/nmap|${LOCALBASE}/bin/nmap|g" \
-e "s|# (EXECDIR=)/usr/local/nikto|\1${DATADIR}|g" \
- ${WRKSRC}/config.txt
- @${REINPLACE_CMD} "s/config.txt/nikto.conf/g" ${WRKSRC}/plugins/* ${WRKSRC}/docs/*
- @${REINPLACE_CMD} -e 's:\$NIKTO{plugindir}/../docs/CHANGES.txt:\$NIKTO{plugindir}/../../doc/nikto/CHANGES.txt:' \
- -e 's:\$NIKTO{plugindir}/../CHANGES.txt:\$NIKTO{plugindir}/../../doc/nikto/CHANGES.txt:' \
+ ${WRKSRC}/nikto.conf
+ @${REINPLACE_CMD} -e 's:\$NIKTO{plugindir}/../docs/CHANGES.txt:\$NIKTO{plugindir}/../../docs/nikto/CHANGES.txt:' \
+ -e 's:\$NIKTO{plugindir}/../CHANGES.txt:\$NIKTO{plugindir}/../../docs/nikto/CHANGES.txt:' \
${WRKSRC}/plugins/nikto_core.plugin
+ @${RM} ${WRKSRC}/plugins/*.bak
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/nikto.pl ${PREFIX}/bin/nikto
- ${INSTALL_DATA} ${WRKSRC}/config.txt ${PREFIX}/etc/nikto.conf.sample
+ ${INSTALL_DATA} ${WRKSRC}/nikto.conf ${PREFIX}/etc/nikto.conf.sample
+ ${INSTALL_MAN} ${WRKSRC}/docs/nikto.1 ${PREFIX}/man/man1/
[ -f ${PREFIX}/etc/nikto.conf ] || \
- ${INSTALL_DATA} ${WRKSRC}/config.txt ${PREFIX}/etc/nikto.conf
+ ${INSTALL_DATA} ${WRKSRC}/nikto.conf ${PREFIX}/etc/nikto.conf
@${MKDIR} ${DATADIR}
@${MKDIR} ${DATADIR}/plugins
+ @${MKDIR} ${DATADIR}/templates
${INSTALL_DATA} ${WRKSRC}/plugins/LW2.pm ${DATADIR}/plugins
- @${RM} ${WRKSRC}/plugins/db_*.bak
${INSTALL_DATA} ${WRKSRC}/plugins/db_* ${DATADIR}/plugins
- ${INSTALL_DATA} ${WRKSRC}/plugins/nikto_plugin_order.txt ${DATADIR}/plugins
${INSTALL_DATA} ${WRKSRC}/plugins/*.plugin ${DATADIR}/plugins
+ ${INSTALL_DATA} ${WRKSRC}/templates/*.tmpl ${DATADIR}/templates
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
. for i in ${PORTDOCS}
diff --git a/security/nikto/distinfo b/security/nikto/distinfo
index b135f218d099..b70e35fe2dc4 100644
--- a/security/nikto/distinfo
+++ b/security/nikto/distinfo
@@ -1,3 +1,3 @@
-MD5 (nikto-2.03.tar.bz2) = 8f286a7943b12a341088f005f832d087
-SHA256 (nikto-2.03.tar.bz2) = 61b78434560c5c311f38c47e7e6816012c9c83a3cfdf4a978ceaaf34718a3b73
-SIZE (nikto-2.03.tar.bz2) = 399643
+MD5 (nikto-2.1.0.tar.bz2) = ce971262e14f5ac1ff634b86366bdaa8
+SHA256 (nikto-2.1.0.tar.bz2) = 8883cc91ed5831c05ac18929a7a93907229ab9836313c2bf9e47e33f3a4e45b5
+SIZE (nikto-2.1.0.tar.bz2) = 230536
diff --git a/security/nikto/pkg-plist b/security/nikto/pkg-plist
index 8274989459e2..c362acd5ef56 100644
--- a/security/nikto/pkg-plist
+++ b/security/nikto/pkg-plist
@@ -4,29 +4,56 @@ etc/nikto.conf.sample
@exec [ -f %B/nikto.conf ] || cp %B/%f %B/nikto.conf
%%DATADIR%%/plugins/LW2.pm
%%DATADIR%%/plugins/db_404_strings
+%%DATADIR%%/plugins/db_embedded
%%DATADIR%%/plugins/db_favicon
+%%DATADIR%%/plugins/db_headers
+%%DATADIR%%/plugins/db_httpoptions
+%%DATADIR%%/plugins/db_multiple_index
%%DATADIR%%/plugins/db_outdated
%%DATADIR%%/plugins/db_realms
%%DATADIR%%/plugins/db_server_msgs
+%%DATADIR%%/plugins/db_subdomains
%%DATADIR%%/plugins/db_tests
%%DATADIR%%/plugins/db_variables
%%DATADIR%%/plugins/nikto_apache_expect_xss.plugin
%%DATADIR%%/plugins/nikto_apacheusers.plugin
%%DATADIR%%/plugins/nikto_cgi.plugin
%%DATADIR%%/plugins/nikto_core.plugin
+%%DATADIR%%/plugins/nikto_dictionary_attack.plugin
+%%DATADIR%%/plugins/nikto_embedded.plugin
%%DATADIR%%/plugins/nikto_favicon.plugin
%%DATADIR%%/plugins/nikto_headers.plugin
%%DATADIR%%/plugins/nikto_httpoptions.plugin
%%DATADIR%%/plugins/nikto_msgs.plugin
+%%DATADIR%%/plugins/nikto_multiple_index.plugin
%%DATADIR%%/plugins/nikto_mutate.plugin
%%DATADIR%%/plugins/nikto_outdated.plugin
%%DATADIR%%/plugins/nikto_passfiles.plugin
-%%DATADIR%%/plugins/nikto_plugin_order.txt
%%DATADIR%%/plugins/nikto_put_del_test.plugin
-%%DATADIR%%/plugins/nikto_reports.plugin
+%%DATADIR%%/plugins/nikto_report_csv.plugin
+%%DATADIR%%/plugins/nikto_report_html.plugin
+%%DATADIR%%/plugins/nikto_report_text.plugin
+%%DATADIR%%/plugins/nikto_report_xml.plugin
%%DATADIR%%/plugins/nikto_robots.plugin
%%DATADIR%%/plugins/nikto_single.plugin
+%%DATADIR%%/plugins/nikto_subdomain.plugin
+%%DATADIR%%/plugins/nikto_tests.plugin
%%DATADIR%%/plugins/nikto_user_enum_apache.plugin
-%%DATADIR%%/plugins/nikto_user_enum_cgiwrap.plugin
+%%DATADIR%%/templates/htm_close.tmpl
+%%DATADIR%%/templates/htm_end.tmpl
+%%DATADIR%%/templates/htm_host_head.tmpl
+%%DATADIR%%/templates/htm_host_im.tmpl
+%%DATADIR%%/templates/htm_host_item.tmpl
+%%DATADIR%%/templates/htm_start.tmpl
+%%DATADIR%%/templates/htm_stop.tmpl
+%%DATADIR%%/templates/htm_summary.tmpl
+%%DATADIR%%/templates/xml_close.tmpl
+%%DATADIR%%/templates/xml_end.tmpl
+%%DATADIR%%/templates/xml_host_head.tmpl
+%%DATADIR%%/templates/xml_host_im.tmpl
+%%DATADIR%%/templates/xml_host_item.tmpl
+%%DATADIR%%/templates/xml_start.tmpl
+%%DATADIR%%/templates/xml_summary.tmpl
+@dirrm %%DATADIR%%/templates
@dirrm %%DATADIR%%/plugins
@dirrm %%DATADIR%%