aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-12-04 23:22:34 +0800
committerrakuco <rakuco@FreeBSD.org>2015-12-04 23:22:34 +0800
commitcba7fb3a11285e74e36932c7be4eb51be9471989 (patch)
treec7ede3ba9c883c5b95c62153671898b09d37a177 /security
parent5879a32fc1944c36628b1e7819ada4579e2ba300 (diff)
downloadfreebsd-ports-gnome-cba7fb3a11285e74e36932c7be4eb51be9471989.tar.gz
freebsd-ports-gnome-cba7fb3a11285e74e36932c7be4eb51be9471989.tar.zst
freebsd-ports-gnome-cba7fb3a11285e74e36932c7be4eb51be9471989.zip
fastd, fastd-devel: Disable mpclmul module on FreeBSD 9.
This fixes the build on 9, which has failed ever since it was added to the tree. From the fallout logs: CMake Error at src/crypto/mac/ghash/pclmulqdq/CMakeLists.txt:9 (message): WITH_MAC_GHASH_PCLMULQDQ enabled, but there is no compiler support for -mpclmul This happens because GCC 4.2.1 in base (the default compiler) does not support the -mpcmul option. Fix it by disabling the module when on FreeBSD < 10 (i.e. when base GCC is the default compiler). PR 205017 PR: 205018 Approved by: Jan Bramkamp <crest_maintainer@rlwinm.de> (maintainer)
Diffstat (limited to 'security')
-rw-r--r--security/fastd-devel/Makefile9
-rw-r--r--security/fastd/Makefile9
2 files changed, 16 insertions, 2 deletions
diff --git a/security/fastd-devel/Makefile b/security/fastd-devel/Makefile
index b6972ec53ad9..222065997ac6 100644
--- a/security/fastd-devel/Makefile
+++ b/security/fastd-devel/Makefile
@@ -27,7 +27,14 @@ USE_RC_SUBR= fastd_devel
PLIST_FILES= bin/fastd-devel \
man/man1/fastd-devel.1.gz
+.include <bsd.port.pre.mk>
+
+# GCC from base does not support -mpclmul.
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000024
+CMAKE_ARGS+= -DWITH_MAC_GHASH_PCLMULQDQ=FALSE
+.endif
+
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/fastd.1 ${STAGEDIR}${PREFIX}/man/man1/fastd-devel.1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/security/fastd/Makefile b/security/fastd/Makefile
index 8d37c9c2299c..0c82796e0997 100644
--- a/security/fastd/Makefile
+++ b/security/fastd/Makefile
@@ -22,7 +22,14 @@ USE_RC_SUBR= fastd
PLIST_FILES= bin/fastd \
man/man1/fastd.1.gz
+.include <bsd.port.pre.mk>
+
+# GCC from base does not support -mpclmul.
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1000024
+CMAKE_ARGS+= -DWITH_MAC_GHASH_PCLMULQDQ=FALSE
+.endif
+
post-install:
${INSTALL_MAN} ${WRKSRC}/doc/fastd.1 ${STAGEDIR}${PREFIX}/man/man1
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>