aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorcsjp <csjp@FreeBSD.org>2009-03-03 22:53:31 +0800
committercsjp <csjp@FreeBSD.org>2009-03-03 22:53:31 +0800
commit3bf99ce2637d2beb42e47114eae3d652680d2f46 (patch)
tree62afd1d2447e3db52af3beb75a9fc5bc7fec93b6 /security
parent51ffc2fa85e092108a88a3000a951b2b340859de (diff)
downloadfreebsd-ports-gnome-3bf99ce2637d2beb42e47114eae3d652680d2f46.tar.gz
freebsd-ports-gnome-3bf99ce2637d2beb42e47114eae3d652680d2f46.tar.zst
freebsd-ports-gnome-3bf99ce2637d2beb42e47114eae3d652680d2f46.zip
Add rc file for termlog.
PR: 129571 Submitted by: Alex Keda Approved by: wxs
Diffstat (limited to 'security')
-rw-r--r--security/termlog/Makefile2
-rw-r--r--security/termlog/files/termlog.in31
2 files changed, 33 insertions, 0 deletions
diff --git a/security/termlog/Makefile b/security/termlog/Makefile
index 59079147243c..495f227d9594 100644
--- a/security/termlog/Makefile
+++ b/security/termlog/Makefile
@@ -7,6 +7,7 @@
PORTNAME= termlog
PORTVERSION= 2.5
+PORTREVISION= 1
CATEGORIES= security sysutils
MASTER_SITES= http://www.seccuris.com/documents/downloads/
MASTER_SITE_SUBDIR= termlog
@@ -15,6 +16,7 @@ MAINTAINER= csjp@FreeBSD.org
COMMENT= Monitor or log multiple system terminals synchronously
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_RC_SUBR= ${PORTNAME}
MAN1= termlog.1
PLIST_FILES= bin/termlog
diff --git a/security/termlog/files/termlog.in b/security/termlog/files/termlog.in
new file mode 100644
index 000000000000..3d194bdc865d
--- /dev/null
+++ b/security/termlog/files/termlog.in
@@ -0,0 +1,31 @@
+#!/bin/sh
+
+# PROVIDE: termlog
+# REQUIRE: cron devfs syslogd
+
+. /etc/rc.subr
+
+load_rc_config termlog
+
+name=termlog
+rcvar=`set_rcvar`
+
+command="/usr/local/bin/termlog"
+
+# default to disable
+termlog_enable=${termlog_enable:-"NO"}
+# logging path
+termlog_log_dir=${termlog_log_dir:-"/var/log/termlog/"}
+# maximum monitored consoles
+termlog_max_cons=${termlog_max_cons:-"30"}
+termlog_flags=${termlog_flags:-" -C $termlog_log_dir -f -n $termlog_max_cons &"}
+
+start_precmd=start_precmd
+
+start_precmd()
+{
+ mkdir -p $termlog_log_dir
+ chmod 0700 $termlog_log_dir
+}
+
+run_rc_command "$1"