aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authornovel <novel@FreeBSD.org>2011-05-27 23:11:07 +0800
committernovel <novel@FreeBSD.org>2011-05-27 23:11:07 +0800
commit4ef96bb7fd2bba46254695ddd9c3b0aa52ad553d (patch)
tree2360a29809b29486606d8c20d3f7d7ab240df0d5 /security
parented099f339982287fe5d3d001e1b71b73df468dde (diff)
downloadfreebsd-ports-gnome-4ef96bb7fd2bba46254695ddd9c3b0aa52ad553d.tar.gz
freebsd-ports-gnome-4ef96bb7fd2bba46254695ddd9c3b0aa52ad553d.tar.zst
freebsd-ports-gnome-4ef96bb7fd2bba46254695ddd9c3b0aa52ad553d.zip
Update to 2.99.2.
Diffstat (limited to 'security')
-rw-r--r--security/gnutls-devel/Makefile16
-rw-r--r--security/gnutls-devel/Makefile.man1
-rw-r--r--security/gnutls-devel/distinfo4
-rw-r--r--security/gnutls-devel/files/patch-lib-Makefile.in22
-rw-r--r--security/gnutls-devel/files/patch-src-udp-serv.c10
-rw-r--r--security/gnutls-devel/pkg-plist36
6 files changed, 58 insertions, 31 deletions
diff --git a/security/gnutls-devel/Makefile b/security/gnutls-devel/Makefile
index e1fc0887a222..d8bab9f3a342 100644
--- a/security/gnutls-devel/Makefile
+++ b/security/gnutls-devel/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gnutls
-PORTVERSION= 2.11.6
+PORTVERSION= 2.99.2
CATEGORIES= security net
MASTER_SITES= http://alpha.gnu.org/gnu/gnutls/ \
ftp://ftp.gnutls.org/pub/gnutls/devel/
@@ -15,8 +15,8 @@ PKGNAMESUFFIX= -devel
MAINTAINER= novel@FreeBSD.org
COMMENT= GNU Transport Layer Security library
-LIB_DEPENDS= gcrypt.17:${PORTSDIR}/security/libgcrypt \
- gpg-error.0:${PORTSDIR}/security/libgpg-error
+LIB_DEPENDS= gpg-error.0:${PORTSDIR}/security/libgpg-error \
+ nettle.4:${PORTSDIR}/security/nettle
CONFLICTS= gnutls-[0-9]*
@@ -29,7 +29,8 @@ USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS} -fPIC" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS+= --disable-guile --with-libgcrypt
+CONFIGURE_ARGS+= --disable-guile --disable-silent-rules \
+ --disable-hardware-acceleration
MANCOMPRESSED= no
.include <bsd.port.pre.mk>
@@ -40,13 +41,6 @@ LIB_DEPENDS+= tasn1.4:${PORTSDIR}/security/libtasn1
CONFIGURE_ARGS+= --with-included-libtasn1
.endif
-.if (defined(WITH_LZO) || exists(${LOCALBASE}/lib/liblzo2.so)) && !defined(WITHOUT_LZO)
-LIB_DEPENDS+= lzo2:${PORTSDIR}/archivers/lzo2
-CONFIGURE_ARGS+= --with-lzo
-.else
-CONFIGURE_ARGS+= --with-lzo=no
-.endif
-
.if defined(WITHOUT_CXX)
CONFIGURE_ARGS+= --disable-cxx
PLIST_SUB+= CXX="@comment "
diff --git a/security/gnutls-devel/Makefile.man b/security/gnutls-devel/Makefile.man
index 68e72477ea3b..15f36ba6486e 100644
--- a/security/gnutls-devel/Makefile.man
+++ b/security/gnutls-devel/Makefile.man
@@ -528,7 +528,6 @@ MAN3= \
gnutls_x509_crq_get_key_rsa_raw.3 \
gnutls_x509_crq_get_key_usage.3 \
gnutls_x509_crq_get_pk_algorithm.3 \
- gnutls_x509_crq_get_preferred_hash_algorithm.3 \
gnutls_x509_crq_get_subject_alt_name.3 \
gnutls_x509_crq_get_subject_alt_othername_oid.3 \
gnutls_x509_crq_get_version.3 \
diff --git a/security/gnutls-devel/distinfo b/security/gnutls-devel/distinfo
index 47fbb2ad5619..8b61bbe54eb2 100644
--- a/security/gnutls-devel/distinfo
+++ b/security/gnutls-devel/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gnutls-2.11.6.tar.bz2) = 4ea79c7a8c215f281994f81f9b8fc80787ac83f8b1c5ff2d89fc5eedd9502c3e
-SIZE (gnutls-2.11.6.tar.bz2) = 7743287
+SHA256 (gnutls-2.99.2.tar.bz2) = d847ef206ee1a3ef8f456c17070de8a650efb3556d992855fd01dec6333f6cc7
+SIZE (gnutls-2.99.2.tar.bz2) = 6287967
diff --git a/security/gnutls-devel/files/patch-lib-Makefile.in b/security/gnutls-devel/files/patch-lib-Makefile.in
new file mode 100644
index 000000000000..82c451c57e61
--- /dev/null
+++ b/security/gnutls-devel/files/patch-lib-Makefile.in
@@ -0,0 +1,22 @@
+--- lib/Makefile.in.orig 2011-05-27 14:29:56.000000000 +0400
++++ lib/Makefile.in 2011-05-27 14:30:30.000000000 +0400
+@@ -1162,7 +1162,7 @@
+ $(am__append_4)
+
+ # Pkg-config script.
+-pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = gnutls.pc
+ DISTCLEANFILES = $(pkgconfig_DATA) $(am__append_17)
+ lib_LTLIBRARIES = libgnutls.la $(am__append_18)
+@@ -1217,8 +1217,8 @@
+ @HAVE_LD_OUTPUT_DEF_TRUE@defexec_DATA = libgnutls-$(DLL_VERSION).def
+
+ # C++ library
+-@ENABLE_CXX_TRUE@libgnutlsxx_la_CPPFLAGS = -I$(top_srcdir)/includes -I$(top_builddir)/includes
+-@ENABLE_CXX_TRUE@AM_CXXFLAGS = -I$(srcdir)/includes
++@ENABLE_CXX_TRUE@libgnutlsxx_la_CPPFLAGS = -I$(top_srcdir)/includes -I$(top_builddir)/includes -I$(srcdir)/includes
++@ENABLE_CXX_TRUE@AM_CXXFLAGS =
+ @ENABLE_CXX_TRUE@libgnutlsxx_la_SOURCES = gnutlsxx.cpp libgnutlsxx.map
+ @ENABLE_CXX_TRUE@libgnutlsxx_la_LDFLAGS = -no-undefined -version-info \
+ @ENABLE_CXX_TRUE@ $(CXX_LT_CURRENT):$(CXX_LT_REVISION):$(CXX_LT_AGE) \
diff --git a/security/gnutls-devel/files/patch-src-udp-serv.c b/security/gnutls-devel/files/patch-src-udp-serv.c
new file mode 100644
index 000000000000..04c075d6ea2d
--- /dev/null
+++ b/security/gnutls-devel/files/patch-src-udp-serv.c
@@ -0,0 +1,10 @@
+--- src/udp-serv.c.orig 2011-05-27 13:22:44.000000000 +0400
++++ src/udp-serv.c 2011-05-27 13:22:54.000000000 +0400
+@@ -1,6 +1,7 @@
+ #include <stdio.h>
+ #include <sys/socket.h>
+ #include <arpa/inet.h>
++#include <netinet/in.h>
+ #include <stdlib.h>
+ #include <string.h>
+ #include <unistd.h>
diff --git a/security/gnutls-devel/pkg-plist b/security/gnutls-devel/pkg-plist
index 9f4161d7cce7..489f525fffcb 100644
--- a/security/gnutls-devel/pkg-plist
+++ b/security/gnutls-devel/pkg-plist
@@ -22,6 +22,7 @@ info/pkcs11-vision.png
include/gnutls/abstract.h
include/gnutls/compat.h
include/gnutls/crypto.h
+include/gnutls/dtls.h
include/gnutls/extra.h
include/gnutls/gnutls.h
include/gnutls/openpgp.h
@@ -30,22 +31,22 @@ include/gnutls/pkcs11.h
include/gnutls/pkcs12.h
include/gnutls/x509.h
%%CXX%%include/gnutls/gnutlsxx.h
-%%CXX%%lib/libgnutlsxx.so.27
+%%CXX%%lib/libgnutlsxx.so.28
%%CXX%%lib/libgnutlsxx.so
%%CXX%%lib/libgnutlsxx.la
%%CXX%%lib/libgnutlsxx.a
lib/libgnutls-extra.a
lib/libgnutls-extra.la
lib/libgnutls-extra.so
-lib/libgnutls-extra.so.44
+lib/libgnutls-extra.so.27
lib/libgnutls-openssl.a
lib/libgnutls-openssl.la
lib/libgnutls-openssl.so
-lib/libgnutls-openssl.so.44
+lib/libgnutls-openssl.so.27
lib/libgnutls.a
lib/libgnutls.la
lib/libgnutls.so
-lib/libgnutls.so.44
+lib/libgnutls.so.27
libdata/pkgconfig/gnutls-extra.pc
libdata/pkgconfig/gnutls.pc
%%EXAMPLESDIR%%/ex-alert.c
@@ -54,7 +55,7 @@ libdata/pkgconfig/gnutls.pc
%%EXAMPLESDIR%%/ex-client-psk.c
%%EXAMPLESDIR%%/ex-client-resume.c
%%EXAMPLESDIR%%/ex-client-srp.c
-%%EXAMPLESDIR%%/ex-client-tlsia.c
+%%EXAMPLESDIR%%/ex-client-udp.c
%%EXAMPLESDIR%%/ex-client1.c
%%EXAMPLESDIR%%/ex-client2.c
%%EXAMPLESDIR%%/ex-crq.c
@@ -69,17 +70,18 @@ libdata/pkgconfig/gnutls.pc
%%EXAMPLESDIR%%/ex-verify.c
%%EXAMPLESDIR%%/ex-x509-info.c
%%EXAMPLESDIR%%/tcp.c
-%%NLS%%share/locale/cs/LC_MESSAGES/libgnutls.mo
-%%NLS%%share/locale/de/LC_MESSAGES/libgnutls.mo
-%%NLS%%share/locale/en@boldquot/LC_MESSAGES/libgnutls.mo
-%%NLS%%share/locale/en@quot/LC_MESSAGES/libgnutls.mo
-%%NLS%%share/locale/fr/LC_MESSAGES/libgnutls.mo
-%%NLS%%share/locale/it/LC_MESSAGES/libgnutls.mo
-%%NLS%%share/locale/ms/LC_MESSAGES/libgnutls.mo
-%%NLS%%share/locale/nl/LC_MESSAGES/libgnutls.mo
-%%NLS%%share/locale/pl/LC_MESSAGES/libgnutls.mo
-%%NLS%%share/locale/sv/LC_MESSAGES/libgnutls.mo
-%%NLS%%share/locale/vi/LC_MESSAGES/libgnutls.mo
-%%NLS%%share/locale/zh_CN/LC_MESSAGES/libgnutls.mo
+%%EXAMPLESDIR%%/udp.c
+%%NLS%%share/locale/cs/LC_MESSAGES/gnutls.mo
+%%NLS%%share/locale/de/LC_MESSAGES/gnutls.mo
+%%NLS%%share/locale/en@boldquot/LC_MESSAGES/gnutls.mo
+%%NLS%%share/locale/en@quot/LC_MESSAGES/gnutls.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/gnutls.mo
+%%NLS%%share/locale/it/LC_MESSAGES/gnutls.mo
+%%NLS%%share/locale/ms/LC_MESSAGES/gnutls.mo
+%%NLS%%share/locale/nl/LC_MESSAGES/gnutls.mo
+%%NLS%%share/locale/pl/LC_MESSAGES/gnutls.mo
+%%NLS%%share/locale/sv/LC_MESSAGES/gnutls.mo
+%%NLS%%share/locale/vi/LC_MESSAGES/gnutls.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/gnutls.mo
@dirrm %%EXAMPLESDIR%%
@dirrm include/gnutls