aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2017-10-12 06:35:28 +0800
committerehaupt <ehaupt@FreeBSD.org>2017-10-12 06:35:28 +0800
commit537ae1b42ced8e6a573d32b69d6eea0aab9390e3 (patch)
treeabf67e59be77a2ad639f2f0cd5f5f208cd621487 /security
parent1f1cf085410156b21abf44d03875ac1e19bcab51 (diff)
downloadfreebsd-ports-gnome-537ae1b42ced8e6a573d32b69d6eea0aab9390e3.tar.gz
freebsd-ports-gnome-537ae1b42ced8e6a573d32b69d6eea0aab9390e3.tar.zst
freebsd-ports-gnome-537ae1b42ced8e6a573d32b69d6eea0aab9390e3.zip
Add py-trezor 0.7.16, client side implementation for TREZOR Bitcoin
hardware wallets.
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/py-trezor/Makefile27
-rw-r--r--security/py-trezor/distinfo3
-rw-r--r--security/py-trezor/pkg-descr3
4 files changed, 34 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index d0a9eb08a37c..bb0973929018 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -963,6 +963,7 @@
SUBDIR += py-stem
SUBDIR += py-stix
SUBDIR += py-tlslite
+ SUBDIR += py-trezor
SUBDIR += py-trustedpickle
SUBDIR += py-tuf
SUBDIR += py-twofish
diff --git a/security/py-trezor/Makefile b/security/py-trezor/Makefile
new file mode 100644
index 000000000000..74bfdd6c3e31
--- /dev/null
+++ b/security/py-trezor/Makefile
@@ -0,0 +1,27 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= trezor
+PORTVERSION= 0.7.16
+DISTVERSIONPREFIX= v
+CATEGORIES= security
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= Client side implementation for TREZOR Bitcoin hardware wallets
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}mnemonic>=0:security/py-mnemonic \
+ ${PYTHON_PKGNAMEPREFIX}hidapi>=0:comms/py-hidapi \
+ ${PYTHON_PKGNAMEPREFIX}ecdsa>0:security/py-ecdsa \
+ ${PYTHON_PKGNAMEPREFIX}protobuf>=2.5.0:devel/py-protobuf
+
+USES= python
+USE_GITHUB= yes
+USE_PYTHON= autoplist distutils
+
+GH_PROJECT= python-trezor
+
+.include <bsd.port.mk>
diff --git a/security/py-trezor/distinfo b/security/py-trezor/distinfo
new file mode 100644
index 000000000000..7d658ee40f99
--- /dev/null
+++ b/security/py-trezor/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1507051332
+SHA256 (trezor-python-trezor-v0.7.16_GH0.tar.gz) = 02924aa0a52e50e7447cc77dc376f55a1cc0aa5b9ba62121f886b7eddbf4ab5d
+SIZE (trezor-python-trezor-v0.7.16_GH0.tar.gz) = 111602
diff --git a/security/py-trezor/pkg-descr b/security/py-trezor/pkg-descr
new file mode 100644
index 000000000000..25df25ce8af4
--- /dev/null
+++ b/security/py-trezor/pkg-descr
@@ -0,0 +1,3 @@
+Client side implementation for TREZOR-compatible Bitcoin hardware wallets.
+
+WWW: https://github.com/trezor/python-trezor