aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2010-07-28 02:07:06 +0800
committermakc <makc@FreeBSD.org>2010-07-28 02:07:06 +0800
commit61b92c9da9f5ebc6087f3b0c3c547506d29ffa9a (patch)
tree5af009c4d5ad327b57fc9fc42d60da5ac4bc4cca /security
parent1e6726ba16fad3bd7723aae9407d886d57090200 (diff)
downloadfreebsd-ports-gnome-61b92c9da9f5ebc6087f3b0c3c547506d29ffa9a.tar.gz
freebsd-ports-gnome-61b92c9da9f5ebc6087f3b0c3c547506d29ffa9a.tar.zst
freebsd-ports-gnome-61b92c9da9f5ebc6087f3b0c3c547506d29ffa9a.zip
Fix build with GnuPG 1.x (add unconditional dependency on security/libassuan)
PR: ports/148888 Submitted by: Jason E. Hale (maintainer)
Diffstat (limited to 'security')
-rw-r--r--security/gpgme/Makefile5
-rw-r--r--security/gpgme/files/patch-src__engine-gpgconf.c10
2 files changed, 2 insertions, 13 deletions
diff --git a/security/gpgme/Makefile b/security/gpgme/Makefile
index 5cc17277079e..e0dceaecb673 100644
--- a/security/gpgme/Makefile
+++ b/security/gpgme/Makefile
@@ -16,7 +16,8 @@ EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
MAINTAINER= bsdkaffee@gmail.com
COMMENT= A library to make access to GnuPG easier
-LIB_DEPENDS= gpg-error.0:${PORTSDIR}/security/libgpg-error
+LIB_DEPENDS= assuan.0:${PORTSDIR}/security/libassuan \
+ gpg-error.0:${PORTSDIR}/security/libgpg-error
USE_BZIP2= yes
USE_AUTOTOOLS= libtool:22
@@ -52,7 +53,6 @@ RUN_DEPENDS+= gpg2:${PORTSDIR}/security/gnupg
CONFIGURE_ARGS+=--with-gpg=${LOCALBASE}/bin/gpg2 \
--with-gpgconf=${LOCALBASE}/bin/gpgconf
.if exists(${LOCALBASE}/bin/gpgsm)
-LIB_DEPENDS+= assuan.0:${PORTSDIR}/security/libassuan
CONFIGURE_ARGS+=--with-gpgsm=${LOCALBASE}/bin/gpgsm
.else
CONFIGURE_ARGS+=--with-gpgsm=no
@@ -69,7 +69,6 @@ PLIST_SUB+= WITH_PTH='@comment '
.if defined(WITH_UISERVER)
CONFIGURE_ARGS+=--enable-fd-passing
-LIB_DEPENDS+= assuan.0:${PORTSDIR}/security/libassuan
.endif
verify: checksum
diff --git a/security/gpgme/files/patch-src__engine-gpgconf.c b/security/gpgme/files/patch-src__engine-gpgconf.c
deleted file mode 100644
index d14f81c78f43..000000000000
--- a/security/gpgme/files/patch-src__engine-gpgconf.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- ./src/engine-gpgconf.c.orig 2009-06-15 07:59:37.000000000 -0400
-+++ ./src/engine-gpgconf.c 2009-12-05 03:03:51.000000000 -0500
-@@ -38,7 +38,6 @@
- #include "priv-io.h"
- #include "sema.h"
-
--#include "assuan.h"
- #include "debug.h"
-
- #include "engine-backend.h"