aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2017-10-01 02:07:27 +0800
committerrene <rene@FreeBSD.org>2017-10-01 02:07:27 +0800
commit6206e53e1a3cfd7fd76cabf82bda15c9ab34bd96 (patch)
tree22c33a985f9bc1407138a0f94844ce7a12091592 /security
parent0fed9a6193a9bc2af11cac267c64a905e4f64b2c (diff)
downloadfreebsd-ports-gnome-6206e53e1a3cfd7fd76cabf82bda15c9ab34bd96.tar.gz
freebsd-ports-gnome-6206e53e1a3cfd7fd76cabf82bda15c9ab34bd96.tar.zst
freebsd-ports-gnome-6206e53e1a3cfd7fd76cabf82bda15c9ab34bd96.zip
security/sandsifter: post-commit fixes
- spell ONLY_FOR_ARCH_REASON correctly [1] - remove stale import which broke running the port [2] PR: 222701 [2] Submitted by: John Smith (godevilove AT ya.ru) [2] Submitted by: adamw [1] via private mail
Diffstat (limited to 'security')
-rw-r--r--security/sandsifter/Makefile2
-rw-r--r--security/sandsifter/files/patch-sifter.py10
2 files changed, 5 insertions, 7 deletions
diff --git a/security/sandsifter/Makefile b/security/sandsifter/Makefile
index be73c40c4dc9..9b35652e27da 100644
--- a/security/sandsifter/Makefile
+++ b/security/sandsifter/Makefile
@@ -13,7 +13,7 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}capstone>0:devel/py-capstone
USES= gmake python localbase shebangfix
ONLY_FOR_ARCH= amd64 i386
-ONLY_FOR_ARCH_RAESON=Designed for x86
+ONLY_FOR_ARCH_REASON=Designed for x86
USE_GITHUB= yes
GH_ACCOUNT= xoreaxeaxeax
diff --git a/security/sandsifter/files/patch-sifter.py b/security/sandsifter/files/patch-sifter.py
index 06bcdde6fc93..10594f375d4a 100644
--- a/security/sandsifter/files/patch-sifter.py
+++ b/security/sandsifter/files/patch-sifter.py
@@ -1,10 +1,8 @@
---- sifter.py.orig 2017-09-22 12:42:26 UTC
+--- sifter.py.orig 2017-09-30 17:57:06 UTC
+++ sifter.py
-@@ -26,11 +26,12 @@ import argparse
- import code
+@@ -27,10 +27,10 @@ import code
import copy
from ctypes import *
-+import sysctl
-INJECTOR = "./injector"
+INJECTOR = "injector"
@@ -15,7 +13,7 @@
LOG = OUTPUT + "log"
SYNC = OUTPUT + "sync"
TICK = OUTPUT + "tick"
-@@ -679,7 +680,7 @@ class Gui:
+@@ -679,7 +679,7 @@ class Gui:
time.sleep(self.TIME_SLICE)
def get_cpu_info():
@@ -24,7 +22,7 @@
cpu = [l.strip() for l in f.readlines()[:7]]
return cpu
-@@ -808,9 +809,16 @@ def main():
+@@ -808,9 +808,16 @@ def main():
if not os.path.exists(OUTPUT):
os.makedirs(OUTPUT)