aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorume <ume@FreeBSD.org>2003-12-28 00:58:08 +0800
committerume <ume@FreeBSD.org>2003-12-28 00:58:08 +0800
commit6e1a80922f49bd7c8f9bd9c7ea07b9e32089e58c (patch)
tree64b036803aaf59e6a4dab9a522d6b80528fcfd05 /security
parentd3381103410f4bdf08f56b058230ecdc34e8e90d (diff)
downloadfreebsd-ports-gnome-6e1a80922f49bd7c8f9bd9c7ea07b9e32089e58c.tar.gz
freebsd-ports-gnome-6e1a80922f49bd7c8f9bd9c7ea07b9e32089e58c.tar.zst
freebsd-ports-gnome-6e1a80922f49bd7c8f9bd9c7ea07b9e32089e58c.zip
add WITH_PGSQL knob which supports sql plugin with postgresql backend.
PR: ports/60606 Submitted by: mat
Diffstat (limited to 'security')
-rw-r--r--security/cyrus-sasl2/Makefile12
1 files changed, 11 insertions, 1 deletions
diff --git a/security/cyrus-sasl2/Makefile b/security/cyrus-sasl2/Makefile
index c6528eb8f299..3d54ce530892 100644
--- a/security/cyrus-sasl2/Makefile
+++ b/security/cyrus-sasl2/Makefile
@@ -81,7 +81,17 @@ WANT_MYSQL_VER= 323
.endif
.if defined(WITH_MYSQL)
USE_MYSQL= YES
-CONFIGURE_ARGS+=--enable-sql --with-mysql=${PREFIX}
+CONFIGURE_ARGS+=--with-mysql=${PREFIX}
+.endif
+
+.if defined(WITH_PGSQL)
+POSTGRESQL_PORT?= databases/postgresql-client
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+CONFIGURE_ARGS+=--with-pgsql=${PREFIX}
+.endif
+
+.if defined(WITH_MYSQL) || defined(WITH_PGSQL)
+CONFIGURE_ARGS+=--enable-sql
.else
SQL= "@comment "
.endif