aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2014-08-06 14:39:21 +0800
committerhrs <hrs@FreeBSD.org>2014-08-06 14:39:21 +0800
commit819cb05023fc81bd1cc06e302367b11b0b5ffaf8 (patch)
tree5872d74708e6a85c6424d4b9ee545fc20daef741 /security
parenta46f8bdcd0bd94d6fe1cdcc8ce6a6f67bd2e39a8 (diff)
downloadfreebsd-ports-gnome-819cb05023fc81bd1cc06e302367b11b0b5ffaf8.tar.gz
freebsd-ports-gnome-819cb05023fc81bd1cc06e302367b11b0b5ffaf8.tar.zst
freebsd-ports-gnome-819cb05023fc81bd1cc06e302367b11b0b5ffaf8.zip
Remove reference to my_init and my_fini. These functions were causing
symbol conflicts with other software like MySQL. PR: 192156
Diffstat (limited to 'security')
-rw-r--r--security/trousers/Makefile2
-rw-r--r--security/trousers/files/patch-src-tspi-rpc-hosttable.c18
2 files changed, 13 insertions, 7 deletions
diff --git a/security/trousers/Makefile b/security/trousers/Makefile
index 82e2fcaabd49..a338a78f3c14 100644
--- a/security/trousers/Makefile
+++ b/security/trousers/Makefile
@@ -3,7 +3,7 @@
PORTNAME= trousers
PORTVERSION= 0.3.10
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= security
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}
diff --git a/security/trousers/files/patch-src-tspi-rpc-hosttable.c b/security/trousers/files/patch-src-tspi-rpc-hosttable.c
index d86294d7a463..befd61032770 100644
--- a/security/trousers/files/patch-src-tspi-rpc-hosttable.c
+++ b/security/trousers/files/patch-src-tspi-rpc-hosttable.c
@@ -1,6 +1,6 @@
---- src/tspi/rpc/hosttable.c.orig 2010-05-02 11:39:11.000000000 +0900
-+++ src/tspi/rpc/hosttable.c 2010-10-24 21:04:04.845560543 +0900
-@@ -36,8 +36,8 @@
+--- src/tspi/rpc/hosttable.c.orig 2012-09-20 02:35:07.000000000 +0900
++++ src/tspi/rpc/hosttable.c 2014-08-06 15:35:22.000000000 +0900
+@@ -36,10 +36,10 @@
}
#ifdef SOLARIS
@@ -9,8 +9,11 @@
+#pragma init(_init_hosttable)
+void _init_hosttable(void)
#else
- void __attribute__ ((constructor)) my_init(void)
+-void __attribute__ ((constructor)) my_init(void)
++static void __attribute__ ((constructor)) my_init(void)
#endif
+ {
+ host_table_init();
@@ -51,6 +51,8 @@
{
struct host_table_entry *hte, *next = NULL;
@@ -20,7 +23,7 @@
MUTEX_LOCK(ht->lock);
for (hte = ht->entries; hte; hte = next) {
-@@ -70,8 +72,8 @@
+@@ -70,10 +72,10 @@
}
#ifdef SOLARIS
@@ -29,8 +32,11 @@
+#pragma fini(_fini_hosttable)
+void _fini_hosttable(void)
#else
- void __attribute__ ((destructor)) my_fini(void)
+-void __attribute__ ((destructor)) my_fini(void)
++static void __attribute__ ((destructor)) my_fini(void)
#endif
+ {
+ host_table_final();
@@ -84,6 +86,8 @@
{
struct host_table_entry *entry, *tmp;