aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2017-10-08 23:37:03 +0800
committerashish <ashish@FreeBSD.org>2017-10-08 23:37:03 +0800
commit8e9969c0ac1705d6f6193120c29c8fe0ebc3baa6 (patch)
tree1696c4918fd1611cd72ab6667eb4780ca0abb8c1 /security
parent2e5e5399789eb21f5725f1866e09717997ef291c (diff)
downloadfreebsd-ports-gnome-8e9969c0ac1705d6f6193120c29c8fe0ebc3baa6.tar.gz
freebsd-ports-gnome-8e9969c0ac1705d6f6193120c29c8fe0ebc3baa6.tar.zst
freebsd-ports-gnome-8e9969c0ac1705d6f6193120c29c8fe0ebc3baa6.zip
git-remote-gcrypt is a git remote helper to push and pull from
repositories encrypted with GnuPG. It works with the standard git transports, including repository hosting services like GitHub. WWW: https://spwhitton.name/tech/code/git-remote-gcrypt/
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/git-remote-gcrypt/Makefile34
-rw-r--r--security/git-remote-gcrypt/distinfo3
-rw-r--r--security/git-remote-gcrypt/pkg-descr5
4 files changed, 43 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 69db6b27a88f..95cb1f5a0376 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -170,6 +170,7 @@
SUBDIR += gcipher
SUBDIR += gcr
SUBDIR += git-crypt
+ SUBDIR += git-remote-gcrypt
SUBDIR += gnome-gpg
SUBDIR += gnome-keyring
SUBDIR += gnome-keyring-sharp
diff --git a/security/git-remote-gcrypt/Makefile b/security/git-remote-gcrypt/Makefile
new file mode 100644
index 000000000000..77201075f10f
--- /dev/null
+++ b/security/git-remote-gcrypt/Makefile
@@ -0,0 +1,34 @@
+# Created by: Ashish SHUKLA <ashish@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= git-remote-gcrypt
+PORTVERSION= 1.0.2
+CATEGORIES= security
+
+MAINTAINER= ashish@FreeBSD.org
+COMMENT= PGP-encrypt git remotes
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= rst2man:textproc/py-docutils
+RUN_DEPENDS= rsync:net/rsync \
+ curl:ftp/curl \
+ gpg:security/gnupg
+
+USE_GITHUB= yes
+GH_ACCOUNT= spwhitton
+MAKE_ENV= DESTDIR=${STAGEDIR}
+
+NO_BUILD=
+
+PLIST_FILES= bin/${PORTNAME} \
+ man/man1/${PORTNAME}.1.gz
+
+post-extract:
+ @${REINPLACE_CMD} -e s,prefix/share/man,prefix/man, ${WRKSRC}/install.sh
+
+do-install:
+ @cd ${WRKSRC} && ${SETENV} ${MAKE_ENV} ${WRKSRC}/install.sh
+
+.include <bsd.port.mk>
diff --git a/security/git-remote-gcrypt/distinfo b/security/git-remote-gcrypt/distinfo
new file mode 100644
index 000000000000..336117ac0d5f
--- /dev/null
+++ b/security/git-remote-gcrypt/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1507468770
+SHA256 (spwhitton-git-remote-gcrypt-1.0.2_GH0.tar.gz) = 002994d60d4b3c9a93452d2655bdf3e761c581159431f743d0827127d88f7be2
+SIZE (spwhitton-git-remote-gcrypt-1.0.2_GH0.tar.gz) = 26226
diff --git a/security/git-remote-gcrypt/pkg-descr b/security/git-remote-gcrypt/pkg-descr
new file mode 100644
index 000000000000..b7776d687556
--- /dev/null
+++ b/security/git-remote-gcrypt/pkg-descr
@@ -0,0 +1,5 @@
+git-remote-gcrypt is a git remote helper to push and pull from
+repositories encrypted with GnuPG. It works with the standard git
+transports, including repository hosting services like GitHub.
+
+WWW: https://spwhitton.name/tech/code/git-remote-gcrypt/