aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorculot <culot@FreeBSD.org>2012-03-15 20:42:09 +0800
committerculot <culot@FreeBSD.org>2012-03-15 20:42:09 +0800
commita45a655e69ff6259ad940f4977f31efaa8b2f58c (patch)
tree0e89268afa95891d2543c35817775bdfd98e7413 /security
parent6552d4855bcde1b333012c9e1ac5e013d633c673 (diff)
downloadfreebsd-ports-gnome-a45a655e69ff6259ad940f4977f31efaa8b2f58c.tar.gz
freebsd-ports-gnome-a45a655e69ff6259ad940f4977f31efaa8b2f58c.tar.zst
freebsd-ports-gnome-a45a655e69ff6259ad940f4977f31efaa8b2f58c.zip
File::KeePass is an interface to KeePassX and KeePass V1 database files.
It supports only Rijndael encryption and only bases which were secured via passkeys (key files not supported). WWW: http://search.cpan.org/dist/File-KeePass/ PR: ports/165922 (based on) Submitted by: Alexander Y. Grigoryev <alexander.4mail@gmail.com> Feature safe: yes
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-File-KeePass/Makefile33
-rw-r--r--security/p5-File-KeePass/distinfo2
-rw-r--r--security/p5-File-KeePass/pkg-descr5
-rw-r--r--security/p5-File-KeePass/pkg-plist5
5 files changed, 46 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 842d061c158d..98d1709fe1db 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -525,6 +525,7 @@
SUBDIR += p5-Digest-SV1
SUBDIR += p5-Digest-Tiger
SUBDIR += p5-Digest-Whirlpool
+ SUBDIR += p5-File-KeePass
SUBDIR += p5-File-Scan
SUBDIR += p5-File-Scan-ClamAV
SUBDIR += p5-Filter-CBC
diff --git a/security/p5-File-KeePass/Makefile b/security/p5-File-KeePass/Makefile
new file mode 100644
index 000000000000..60172c3e3255
--- /dev/null
+++ b/security/p5-File-KeePass/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: p5-File-KeePass
+# Date created: 2012-03-10
+# Whom: Alexander Y. Grigoryev <alexander.4mail@gmail.com>
+#
+# $FreeBSD$
+
+PORTNAME= File-KeePass
+PORTVERSION= 0.03
+CATEGORIES= security perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= alexander.4mail@gmail.com
+COMMENT= Interface to KeePass V1 and KeePassX database files
+
+LICENSE= ART10 GPLv1
+LICENSE_COMB= dual
+
+BUILD_DEPENDS= p5-Crypt-Rijndael>=1.0:${PORTSDIR}/security/p5-Crypt-Rijndael
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= File::KeePass.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 501000
+BUILD_DEPENDS+= p5-Digest-SHA>=1.0:${PORTSDIR}/security/p5-Digest-SHA
+RUN_DEPENDS+= p5-Digest-SHA>=1.0:${PORTSDIR}/security/p5-Digest-SHA
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/security/p5-File-KeePass/distinfo b/security/p5-File-KeePass/distinfo
new file mode 100644
index 000000000000..618ff7df5725
--- /dev/null
+++ b/security/p5-File-KeePass/distinfo
@@ -0,0 +1,2 @@
+SHA256 (File-KeePass-0.03.tar.gz) = 858b9052ec05e7203e504fe8d8ccea0b936f814bd30f3192a4253d0c985743f4
+SIZE (File-KeePass-0.03.tar.gz) = 16264
diff --git a/security/p5-File-KeePass/pkg-descr b/security/p5-File-KeePass/pkg-descr
new file mode 100644
index 000000000000..50ac5242c49d
--- /dev/null
+++ b/security/p5-File-KeePass/pkg-descr
@@ -0,0 +1,5 @@
+File::KeePass is an interface to KeePassX and KeePass V1 database files.
+It supports only Rijndael encryption and only bases which were secured
+via passkeys (key files not supported).
+
+WWW: http://search.cpan.org/dist/File-KeePass/
diff --git a/security/p5-File-KeePass/pkg-plist b/security/p5-File-KeePass/pkg-plist
new file mode 100644
index 000000000000..de3c8d48639b
--- /dev/null
+++ b/security/p5-File-KeePass/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/File/KeePass.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/KeePass/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/KeePass
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File
+@dirrmtry %%SITE_PERL%%/File