aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-07-24 21:32:58 +0800
committerbapt <bapt@FreeBSD.org>2014-07-24 21:32:58 +0800
commita8844613fabe6f02880be5a2bbab4d9af2853c2d (patch)
treeffddb673c48038e781d69f6c3d08ec8855ad33a5 /security
parent12f33c255d02d5e8b350ff2daf6aa8ed112b6508 (diff)
downloadfreebsd-ports-gnome-a8844613fabe6f02880be5a2bbab4d9af2853c2d.tar.gz
freebsd-ports-gnome-a8844613fabe6f02880be5a2bbab4d9af2853c2d.tar.zst
freebsd-ports-gnome-a8844613fabe6f02880be5a2bbab4d9af2853c2d.zip
Only use libevent2
Remove libevent as libevent2 is providing a good compatibility interface as well as providing better performances. Remove custom patches from libevent2 and install libevent2 the regular way Mark ports abusing private fields of the libevent1 API as broken Import a patch from fedora to have honeyd working with libevent2 Remove most of the patches necessary to find the custom installation we used to have for libevent2 With hat: portmgr
Diffstat (limited to 'security')
-rw-r--r--security/fragroute/Makefile4
-rw-r--r--security/fragroute/files/patch-fragroute.c78
-rw-r--r--security/scanssh/Makefile4
-rw-r--r--security/spybye/Makefile14
-rw-r--r--security/stegdetect/Makefile4
-rw-r--r--security/tor-devel/Makefile19
-rw-r--r--security/tor/Makefile18
7 files changed, 108 insertions, 33 deletions
diff --git a/security/fragroute/Makefile b/security/fragroute/Makefile
index 070d0c455489..70f3b715906f 100644
--- a/security/fragroute/Makefile
+++ b/security/fragroute/Makefile
@@ -3,7 +3,7 @@
PORTNAME= fragroute
PORTVERSION= 1.2
-PORTREVISION= 11
+PORTREVISION= 12
CATEGORIES= security net
MASTER_SITES= http://monkey.org/~dugsong/fragroute/ \
${MASTER_SITE_PACKETSTORM}
@@ -15,7 +15,7 @@ COMMENT= Tool for intercepting, modifying, and rewriting egress traffic
LICENSE= BSD3CLAUSE
LIB_DEPENDS= libdnet.so:${PORTSDIR}/net/libdnet \
- libevent-1.4.so:${PORTSDIR}/devel/libevent
+ libevent.so:${PORTSDIR}/devel/libevent2
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --with-libdnet=${LOCALBASE} \
diff --git a/security/fragroute/files/patch-fragroute.c b/security/fragroute/files/patch-fragroute.c
new file mode 100644
index 000000000000..f8dc691ade55
--- /dev/null
+++ b/security/fragroute/files/patch-fragroute.c
@@ -0,0 +1,78 @@
+$NetBSD: patch-fragroute.c,v 1.1 2013/05/23 16:02:13 christos Exp $
+In the unix case, don't use the obsolete libevent signal interface
+
+--- fragroute.c.orig 2002-04-07 18:55:20.000000000 -0400
++++ fragroute.c 2013-05-23 11:59:52.000000000 -0400
+@@ -36,10 +36,6 @@
+
+ static struct fr_ctx ctx;
+
+-/* XXX - these should be in event.h */
+-extern int (*event_sigcb)(void);
+-extern int event_gotsig;
+-
+ static void
+ usage(void)
+ {
+@@ -136,6 +132,10 @@
+ }
+
+ #ifdef WIN32
++/* XXX - these should be in event.h */
++extern int (*event_sigcb)(void);
++extern int event_gotsig;
++
+ static BOOL CALLBACK
+ fragroute_signal(DWORD sig)
+ {
+@@ -144,12 +144,25 @@
+ return (TRUE);
+ }
+ #else
++
+ static void
+-fragroute_signal(int sig)
++fragroute_signal(evutil_socket_t fd, short what, void *arg)
+ {
++ int sig;
++ recv(fd, &sig, sizeof(sig), 0);
+ warnx("exiting on signal %d", sig);
+- event_gotsig++;
++ exit(sig);
+ }
++
++static void
++addsignal(int sig) {
++ struct event sig_ev;
++ int got;
++
++ evsignal_set(&sig_ev, sig, fragroute_signal, &got);
++ evsignal_add(&sig_ev, NULL);
++}
++
+ #endif
+
+ static void
+@@ -165,9 +178,6 @@
+ err(1, "couldn't initialize Winsock");
+
+ SetConsoleCtrlHandler(fragroute_signal, TRUE);
+-#else
+- signal(SIGINT, fragroute_signal);
+- signal(SIGTERM, fragroute_signal);
+ #endif
+ if (addr_aton(dst, &ctx.dst) < 0)
+ err(1, "destination address invalid");
+@@ -178,7 +188,12 @@
+ pkt_init(128);
+
+ event_init();
++#ifdef WIN32
+ event_sigcb = fragroute_close;
++#else
++ addsignal(SIGINT);
++ addsignal(SIGTERM);
++#endif
+
+ if ((ctx.arp = arp_open()) == NULL ||
+ (ctx.intf = intf_open()) == NULL ||
diff --git a/security/scanssh/Makefile b/security/scanssh/Makefile
index 71947487025d..bb6f04bfdb94 100644
--- a/security/scanssh/Makefile
+++ b/security/scanssh/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scanssh
PORTVERSION= 2.1
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= security net
MASTER_SITES= http://www.monkey.org/~provos/
@@ -11,7 +11,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Scans networks for open proxies, SSH, web, and SMTP servers
LIB_DEPENDS= libdnet.so:${PORTSDIR}/net/libdnet \
- libevent-1.so:${PORTSDIR}/devel/libevent
+ libevent.so:${PORTSDIR}/devel/libevent2
GNU_CONFIGURE= YES
PLIST_FILES= bin/scanssh man/man1/scanssh.1.gz
diff --git a/security/spybye/Makefile b/security/spybye/Makefile
index 300c72043c74..e3f22ca11e83 100644
--- a/security/spybye/Makefile
+++ b/security/spybye/Makefile
@@ -3,14 +3,14 @@
PORTNAME= spybye
PORTVERSION= 0.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= security www
MASTER_SITES= http://www.monkey.org/~provos/
MAINTAINER= pauls@utdallas.edu
COMMENT= Web proxy to detect malware
-LIB_DEPENDS= libevent-1.4.so:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
OPTIONS_DEFINE= CLAMAV
CLAMAV_DESC= Enable CLAMAV support
@@ -18,11 +18,7 @@ CLAMAV_DESC= Enable CLAMAV support
USE_RC_SUBR= spybye
GNU_CONFIGURE= yes
-.include <bsd.port.pre.mk>
+CLAMAV_LIB_DEPENDS= libclamav.so:${PORTSDIR}/security/clamav
+CLAMAV_CONFIGURE_ON= --with-libclamav=${PREFIX}/bin
-.if ${PORT_OPTIONS:MCLAMAV}
-LIB_DEPENDS+= libclamav.so:${PORTSDIR}/security/clamav
-CONFIGURE_ARGS+= --with-libclamav=${PREFIX}/bin
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/security/stegdetect/Makefile b/security/stegdetect/Makefile
index c7a1bd18bbc3..b9a035e80e6e 100644
--- a/security/stegdetect/Makefile
+++ b/security/stegdetect/Makefile
@@ -3,7 +3,7 @@
PORTNAME= stegdetect
PORTVERSION= 0.6
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= security
MASTER_SITES= http://www.outguess.org/ \
http://distfiles.master.finkmirrors.net/ \
@@ -18,7 +18,7 @@ OPTIONS_DEFAULT= X11
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MX11}
-LIB_DEPENDS= libevent-1.4.so:${PORTSDIR}/devel/libevent
+LIB_DEPENDS= libevent.so:${PORTSDIR}/devel/libevent2
USE_GNOME= gtk12
CONFIGURE_ENV+= PATH_GTKCONFIG="${GTK_CONFIG}"
PLIST_SUB+= X11=""
diff --git a/security/tor-devel/Makefile b/security/tor-devel/Makefile
index f070fe4e96e3..293e70b32e83 100644
--- a/security/tor-devel/Makefile
+++ b/security/tor-devel/Makefile
@@ -3,6 +3,7 @@
PORTNAME= tor
DISTVERSION= 0.2.5.5-alpha
+PORTREVISION= 1
CATEGORIES= security net ipv6
MASTER_SITES= TOR
PKGNAMESUFFIX= -devel
@@ -16,8 +17,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openssl-dir="${OPENSSLBASE}" --disable-asciidoc
-CONFIGURE_ENV= TOR_CPPFLAGS_libevent="-I${LOCALBASE}/include/event2 -I${LOCALBASE}/include" \
- TOR_LDFLAGS_libevent="-L${LOCALBASE}/lib/event2" \
+CONFIGURE_ENV= TOR_CPPFLAGS_libevent="-I${LOCALBASE}/include" \
+ TOR_LDFLAGS_libevent="-L${LOCALBASE}/lib/" \
TOR_LIBEVENT_LIBS="${TOR_LIBEVENT_LIBS}"
OPTIONS_DEFINE= BUFFEREVENTS BUFFREELISTS INSTR_DOWNLOADS MEMPOOLS \
@@ -80,19 +81,19 @@ CONFIGURE_ARGS+= --disable-mempools
.endif
.if ${PORT_OPTIONS:MSTATIC_TOR}
-BUILD_DEPENDS += ${LOCALBASE}/lib/event2/libevent.a:${PORTSDIR}/devel/libevent2
-CONFIGURE_ARGS+= --enable-static-tor --with-libevent-dir=${LOCALBASE}/lib/event2 \
+BUILD_DEPENDS += ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent2
+CONFIGURE_ARGS+= --enable-static-tor \
--with-zlib-dir=/usr/lib --disable-linker-hardening
-TOR_LIBEVENT_LIBS= ${LOCALBASE}/lib/event2/libevent.a
+TOR_LIBEVENT_LIBS= ${LOCALBASE}/lib/libevent.a
.if ${PORT_OPTIONS:MBUFFEREVENTS}
-TOR_LIBEVENT_LIBS:= ${LOCALBASE}/lib/event2/libevent_openssl.a ${TOR_LIBEVENT_LIBS}
+TOR_LIBEVENT_LIBS:= ${LOCALBASE}/lib/libevent_openssl.a ${TOR_LIBEVENT_LIBS}
.endif
.else
CONFIGURE_ARGS+= --enable-linker-hardening
-LIB_DEPENDS+= libevent-2.0.so:${PORTSDIR}/devel/libevent2
-TOR_LIBEVENT_LIBS= -levent-2.0
+LIB_DEPENDS+= libevent.so:${PORTSDIR}/devel/libevent2
+TOR_LIBEVENT_LIBS= -levent
.if ${PORT_OPTIONS:MBUFFEREVENTS}
-TOR_LIBEVENT_LIBS:= -levent_openssl-2.0 ${TOR_LIBEVENT_LIBS}
+TOR_LIBEVENT_LIBS:= -levent_openssl ${TOR_LIBEVENT_LIBS}
.endif
.endif
diff --git a/security/tor/Makefile b/security/tor/Makefile
index 3384e5bf9344..976a6cb802f8 100644
--- a/security/tor/Makefile
+++ b/security/tor/Makefile
@@ -15,8 +15,8 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
USES= gmake
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-openssl-dir="${OPENSSLBASE}" --disable-asciidoc
-CONFIGURE_ENV= TOR_CPPFLAGS_libevent="-I${LOCALBASE}/include/event2 -I${LOCALBASE}/include" \
- TOR_LDFLAGS_libevent="-L${LOCALBASE}/lib/event2" \
+CONFIGURE_ENV= TOR_CPPFLAGS_libevent="-I${LOCALBASE}/include" \
+ TOR_LDFLAGS_libevent="-L${LOCALBASE}/lib/" \
TOR_LIBEVENT_LIBS="${TOR_LIBEVENT_LIBS}"
OPTIONS_DEFINE= BUFFEREVENTS BUFFREELISTS INSTR_DOWNLOADS \
@@ -71,19 +71,19 @@ CONFIGURE_ARGS+= --disable-instrument-downloads
.endif
.if ${PORT_OPTIONS:MSTATIC_TOR}
-BUILD_DEPENDS += ${LOCALBASE}/lib/event2/libevent.a:${PORTSDIR}/devel/libevent2
-CONFIGURE_ARGS+= --enable-static-tor --with-libevent-dir=${LOCALBASE}/lib/event2 \
+BUILD_DEPENDS += ${LOCALBASE}/lib/libevent.a:${PORTSDIR}/devel/libevent2
+CONFIGURE_ARGS+= --enable-static-tor \
--with-zlib-dir=/usr/lib --disable-linker-hardening
-TOR_LIBEVENT_LIBS= ${LOCALBASE}/lib/event2/libevent.a
+TOR_LIBEVENT_LIBS= ${LOCALBASE}/lib/libevent.a
.if ${PORT_OPTIONS:MBUFFEREVENTS}
-TOR_LIBEVENT_LIBS:= ${LOCALBASE}/lib/event2/libevent_openssl.a ${TOR_LIBEVENT_LIBS}
+TOR_LIBEVENT_LIBS:= ${LOCALBASE}/lib/libevent_openssl.a ${TOR_LIBEVENT_LIBS}
.endif
.else
CONFIGURE_ARGS+= --enable-linker-hardening
-LIB_DEPENDS+= libevent-2.0.so:${PORTSDIR}/devel/libevent2
-TOR_LIBEVENT_LIBS= -levent-2.0
+LIB_DEPENDS+= libevent.so:${PORTSDIR}/devel/libevent2
+TOR_LIBEVENT_LIBS= -levent
.if ${PORT_OPTIONS:MBUFFEREVENTS}
-TOR_LIBEVENT_LIBS:= -levent_openssl-2.0 ${TOR_LIBEVENT_LIBS}
+TOR_LIBEVENT_LIBS:= -levent_openssl ${TOR_LIBEVENT_LIBS}
.endif
.endif