aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2009-12-22 07:08:19 +0800
committergabor <gabor@FreeBSD.org>2009-12-22 07:08:19 +0800
commitb63d6df1d0a8321b0c48c877bdc8028f50aed0cf (patch)
tree6e60a00e16ef4d26b8e3b19e7840b346384ac936 /security
parent4a0a8c12e2587227ddcce55bfdb6955ef91d30f8 (diff)
downloadfreebsd-ports-gnome-b63d6df1d0a8321b0c48c877bdc8028f50aed0cf.tar.gz
freebsd-ports-gnome-b63d6df1d0a8321b0c48c877bdc8028f50aed0cf.tar.zst
freebsd-ports-gnome-b63d6df1d0a8321b0c48c877bdc8028f50aed0cf.zip
- Statically hardcode the hostname at build-time isn't correct because
packages will hold the hostname of the building cluster in this way. Just set $localhost_name to $myhostname instead. The latter is tunable in the configuration file. - Bump PORTREVISION Pointed out by: delphij
Diffstat (limited to 'security')
-rw-r--r--security/amavisd-new/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/security/amavisd-new/Makefile b/security/amavisd-new/Makefile
index 662389c68418..9017ba65b628 100644
--- a/security/amavisd-new/Makefile
+++ b/security/amavisd-new/Makefile
@@ -8,7 +8,7 @@
PORTNAME= amavisd-new
PORTVERSION= 2.6.4
-PORTREVISION= 3
+PORTREVISION= 4
PORTEPOCH= 1
CATEGORIES= security
MASTER_SITES= http://www.ijs.si/software/amavisd/ \
@@ -46,7 +46,6 @@ AMAVISGROUP?= vscan
AMAVISDIR?= /var/amavis
AMAVISQUARANTINE?= /var/virusmails
DAEMON?= /usr/sbin/daemon -p
-HOSTNAME!= /bin/hostname
OPTIONS= BDB "Use BerkeleyDB for nanny/cache/snmp" on \
SNMP "Install amavisd snmp subagent" off \
@@ -245,7 +244,7 @@ post-patch:
-e "s|/var/lib/amavis|${AMAVISDIR}|" \
-e 's|$$log_level = 2;|$$log_level = 0;|' \
-e "s|/var/virusmails|${AMAVISQUARANTINE}|" \
- -e "s|\$localhost_name = \'localhost\';|\$localhost_name = \'${HOSTNAME}\';|g" \
+ -e 's|$$localhost_name = .localhost.;|$$localhost_name = $$myhostname;|' \
-e 's|/var/run/clamav/clamd|/var/run/clamav/clamd.sock|g' \
${WRKSRC}/${i}
.endfor
@@ -260,7 +259,7 @@ post-patch:
@${REINPLACE_CMD} -e "s|/etc/amavisd.conf|${PREFIX}/etc/amavisd.conf|" \
-e "s|/usr/bin/perl|${PERL}|" \
-e "s|/var/amavis|${AMAVISDIR}|g" \
- -e "s|\$localhost_name = \'localhost\';|\$localhost_name = \'${HOSTNAME}\';|g" \
+ -e 's|$$localhost_name = .localhost.;|$$localhost_name = $$myhostname;|' \
${WRKSRC}/amavisd
.if defined(AMAVIS_NOAMAVIS)