aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2002-02-20 22:47:04 +0800
committercy <cy@FreeBSD.org>2002-02-20 22:47:04 +0800
commitc52fefd6520804365aef2fe0d8d0d1bd6a204417 (patch)
tree6eaddcf04c05c1a6247ff3892b1fae413de13bcf /security
parentb9ab993748b73cba3c358482038d0b01bdfef868 (diff)
downloadfreebsd-ports-gnome-c52fefd6520804365aef2fe0d8d0d1bd6a204417.tar.gz
freebsd-ports-gnome-c52fefd6520804365aef2fe0d8d0d1bd6a204417.tar.zst
freebsd-ports-gnome-c52fefd6520804365aef2fe0d8d0d1bd6a204417.zip
Add configuration options to Tripwire 1.3.1 install:
- Add the TWCONFIG variable to install a user defined tw.config instead of the one supplied with the port. - Add the NO_DB_BUILD variable to skip the database build during install for users upgrading or reinstalling the port who wish to use an existing or previously installed Tripwire database. Change MAINTAINER from me (Cy.Schubert@uumail.gov.bc.ca) to me (cy@FreeBSD.org). PR: ports/35127 Submitted by: cjc
Diffstat (limited to 'security')
-rw-r--r--security/tripwire-131/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/security/tripwire-131/Makefile b/security/tripwire-131/Makefile
index 7280327ce353..b4346cea05b5 100644
--- a/security/tripwire-131/Makefile
+++ b/security/tripwire-131/Makefile
@@ -10,7 +10,7 @@ PORTVERSION= 1.3.1
CATEGORIES= security
DISTNAME= Tripwire-${PORTVERSION}-1
-MAINTAINER= Cy.Schubert@uumail.gov.bc.ca
+MAINTAINER= cy@FreeBSD.org
MAN5= tw.config.5
MAN8= siggen.8 tripwire.8
@@ -19,6 +19,8 @@ NO_PACKAGE= "requires local database to be built"
RESTRICTED= "contains crypto class algorithms"
WRKSRC= ${WRKDIR}/tw_ASR_1.3.1_src
+TWCONFIG?= ${FILESDIR}/tw.conf.freebsd2
+
.include <bsd.port.pre.mk>
.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
@@ -27,11 +29,12 @@ IGNORE='Please read http://www.tripwiresecurity.com/ for details of how to obtai
pre-configure:
@ ${CP} ${FILESDIR}/conf-freebsd2.h ${WRKSRC}/configs
- @ ${CP} ${FILESDIR}/tw.conf.freebsd2 ${WRKSRC}/configs/tw.conf.freebsd2
+ @ ${CP} ${TWCONFIG} ${WRKSRC}/configs/tw.conf.freebsd2
post-install:
@ ${MKDIR} /var/adm/tcheck
- @ ${CP} ${FILESDIR}/tw.conf.freebsd2 /var/adm/tcheck/tw.config
+ @ ${CP} ${TWCONFIG} /var/adm/tcheck/tw.config
+.ifndef NO_DB_BUILD
@ ${ECHO} Creating tripwire database
@ (cd /var/adm/tcheck; tripwire -initialize)
.if defined(TRIPWIRE_FLOPPY) && ${TRIPWIRE_FLOPPY} == YES
@@ -48,5 +51,6 @@ post-install:
@ umount /mnt
@ ${ECHO} Do not forget to remove and write-protect the floppy.
.endif
+.endif
.include <bsd.port.post.mk>