aboutsummaryrefslogtreecommitdiffstats
path: root/security
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2005-11-01 19:49:34 +0800
committerskv <skv@FreeBSD.org>2005-11-01 19:49:34 +0800
commitcd4041681c63d6d55524acb1b6592998c5d57ffc (patch)
treea670c421783bb4d4003f5a5880e4e9fb56af2e7a /security
parenta2e1ce671c873938e0284af89625e931842ebd93 (diff)
downloadfreebsd-ports-gnome-cd4041681c63d6d55524acb1b6592998c5d57ffc.tar.gz
freebsd-ports-gnome-cd4041681c63d6d55524acb1b6592998c5d57ffc.tar.zst
freebsd-ports-gnome-cd4041681c63d6d55524acb1b6592998c5d57ffc.zip
Add p5-Authen-SASL-Cyrus 0.12, XS SASL Authentication.
Diffstat (limited to 'security')
-rw-r--r--security/Makefile1
-rw-r--r--security/p5-Authen-SASL-Cyrus/Makefile26
-rw-r--r--security/p5-Authen-SASL-Cyrus/distinfo2
-rw-r--r--security/p5-Authen-SASL-Cyrus/pkg-descr9
-rw-r--r--security/p5-Authen-SASL-Cyrus/pkg-plist13
5 files changed, 51 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 03651385dc98..86c5e879eb40 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -267,6 +267,7 @@
SUBDIR += p5-Authen-PAM
SUBDIR += p5-Authen-Radius
SUBDIR += p5-Authen-SASL
+ SUBDIR += p5-Authen-SASL-Cyrus
SUBDIR += p5-Authen-Smb
SUBDIR += p5-Authen-TacacsPlus
SUBDIR += p5-Authen-Ticket
diff --git a/security/p5-Authen-SASL-Cyrus/Makefile b/security/p5-Authen-SASL-Cyrus/Makefile
new file mode 100644
index 000000000000..749dd5b5a4bb
--- /dev/null
+++ b/security/p5-Authen-SASL-Cyrus/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Authen-SASL-Cyrus
+# Date created: 01 November 2005
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Authen-SASL-Cyrus
+PORTVERSION= 0.12
+CATEGORIES= security perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Authen
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= XS SASL Authentication
+
+BUILD_DEPENDS= ${SITE_PERL}/Authen/SASL.pm:${PORTSDIR}/security/p5-Authen-SASL
+LIB_DEPENDS= sasl2:${PORTSDIR}/security/cyrus-sasl2
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Authen::SASL::Cyrus.3
+
+.include <bsd.port.mk>
diff --git a/security/p5-Authen-SASL-Cyrus/distinfo b/security/p5-Authen-SASL-Cyrus/distinfo
new file mode 100644
index 000000000000..5ba36f6f9e9b
--- /dev/null
+++ b/security/p5-Authen-SASL-Cyrus/distinfo
@@ -0,0 +1,2 @@
+MD5 (Authen-SASL-Cyrus-0.12.tar.gz) = d075113234b00b40af8cd1644a566970
+SIZE (Authen-SASL-Cyrus-0.12.tar.gz) = 11522
diff --git a/security/p5-Authen-SASL-Cyrus/pkg-descr b/security/p5-Authen-SASL-Cyrus/pkg-descr
new file mode 100644
index 000000000000..bfe70681b79f
--- /dev/null
+++ b/security/p5-Authen-SASL-Cyrus/pkg-descr
@@ -0,0 +1,9 @@
+SASL is a generic mechanism for authentication used by several network
+protocols. Authen::SASL::Cyrus provides an implementation framework
+that all protocols should be able to share.
+
+The XS framework makes calls into the existing libsasl2.so shared
+library to perform SASL client connection functionality, including
+loading existing shared library mechanisms.
+
+WWW: http://search.cpan.org/dist/Authen-SASL-Cyrus/
diff --git a/security/p5-Authen-SASL-Cyrus/pkg-plist b/security/p5-Authen-SASL-Cyrus/pkg-plist
new file mode 100644
index 000000000000..7f10f5ad82ae
--- /dev/null
+++ b/security/p5-Authen-SASL-Cyrus/pkg-plist
@@ -0,0 +1,13 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Authen/SASL/Cyrus.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/Authen/SASL/Cyrus.pod
+%%SITE_PERL%%/%%PERL_ARCH%%/Authen/SASL/Cyrus/Security.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/SASL/Cyrus/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/SASL/Cyrus/Cyrus.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/SASL/Cyrus/Cyrus.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/Authen/SASL/Cyrus
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/SASL/Cyrus
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Authen/SASL 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/Authen 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/SASL/Cyrus 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen/SASL 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/%%PERL_ARCH%%/auto/Authen 2>/dev/null || true